Bug 64754 - XMLGUI items (toolbar icons, menu items) from merge sections move or disappear
Summary: XMLGUI items (toolbar icons, menu items) from merge sections move or disappear
Status: RESOLVED FIXED
Alias: None
Product: kdelibs
Classification: Frameworks and Libraries
Component: kdeui (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR normal with 300 votes (vote)
Target Milestone: ---
Assignee: David Faure
URL:
Keywords:
: 56229 60156 60935 90431 118722 173764 180756 181702 208402 235937 253190 294103 322165 329541 342170 (view as bug list)
Depends on:
Blocks:
 
Reported: 2003-09-22 22:21 UTC by Carlos Woelz
Modified: 2016-06-18 02:12 UTC (History)
26 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.24


Attachments
attachment-27410-0.html (1.64 KB, text/html)
2016-06-18 02:13 UTC, oldherl
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Carlos Woelz 2003-09-22 22:21:05 UTC
Version:           cvs 19 sep 2003 (using KDE Devel)
Installed from:    Compiled sources
Compiler:          gcc 3.2.2 mdk
OS:          Linux

Description: When I change between files, the icons start changing position in my Kate toolbar. At first (starting with the save icon), they move from extreme right to extreme left. Then, they start to disappear. I waited 2 weeks to report this,  on SadEagle advice. (Wait 2 weeks, if the problem persist, report it.)

How to reproduce it:
Open Kate.
Open a two arbitrary files.
Switch between them.
Comment 1 Carlos Woelz 2003-09-22 22:23:14 UTC
Correction, they move from left to extreme right. (As many dictators do ;)
Comment 2 Christoph Cullmann 2003-09-30 18:22:38 UTC
hmm, can somebody reproduce that ? was busy in the last weeks, but with my 
yesterday build cvs head don't have that :/ 
 
Comment 3 Jesse 2003-10-02 21:55:47 UTC
I can reproduce. 
You need to add items to your "Main Toolbar <kate>" first.  Then open a bunch of 
files and watch things just shuffle all over the place. 
 
I tested mine by adding 'Split Horizontal' and 'Close Current View' _after_ the 3 
merge lines in the Configure Toolbar dialog. The bad thing is is that after you do this 
it's stuck.  You can remove them but the toolbars are totally foobarred and you have 
to delete your config files to get em back.  Is this kate's problem though? I haven't 
tried in other apps yet... 
Comment 4 Christoph Cullmann 2003-10-02 23:09:07 UTC
Subject: Re:  Icons changing position and eventually disappearing on file change

> ------- Additional Comments From yurkjes@iit.edu  2003-10-02 21:55 -------
> I can reproduce.
> You need to add items to your "Main Toolbar <kate>" first.  Then open a
> bunch of files and watch things just shuffle all over the place.
>
> I tested mine by adding 'Split Horizontal' and 'Close Current View' _after_
> the 3 merge lines in the Configure Toolbar dialog. The bad thing is is that
> after you do this it's stuck.  You can remove them but the toolbars are
> totally foobarred and you have to delete your config files to get em back. 
> Is this kate's problem though? I haven't tried in other apps yet...
hmm, kate does nothing special, only plug in/out the kate parts actions :/


Comment 5 Jesse 2003-10-13 20:47:01 UTC
Ok, a little fixup from my previous comment.  Apparently it's not really the fault of the 
MainToolbar <kate> but the katepart one. 
 
You can reproduce quite easily but removing the decrease/increase buttons off the 
katepart toolbar.  This seems to work fine. But now try putting them back.  That's 
where the problem is (or one area of the problem). Seems we're missing the group 
attribute and xmlgui doesn't like that :-/  In other words, anything that interferes with the 
katepart groups is just asking for trouble.  Anyone know of other App/Part applications 
that allow similiar toolbar functionality? 
 
The original katepartui.rc has this for the decrease/increase actions: 
  <Action name="incFontSizes" group="zoom_operations" /> 
  <Action name="decFontSizes" group="zoom_operations" /> 
</ToolBar> 
 
The katepartui.rc written out after you change it and put it back has: 
  <Action name="incFontSizes" /> 
  <Action name="decFontSizes" /> 
</ToolBar> 
Comment 6 Christoph Cullmann 2003-10-28 21:58:57 UTC
is that now a problem of the group usage of the katepart or a problem that the kxmlgui stuff doesn't add the groupname ? if the second, than we should reassign it to kdelibs to get it fixed
Comment 7 Thomas Kjosmoen 2003-10-29 08:04:13 UTC
Isn't this the same bug as the following one?
http://bugs.kde.org/show_bug.cgi?id=60935
Comment 8 Christoph Cullmann 2003-11-05 00:00:42 UTC
could somebody with knowledge of kxmlgui look if this is a problem in the libs or missuse from our side ?
Comment 9 Christoph Cullmann 2003-11-05 00:03:02 UTC
*** Bug 60935 has been marked as a duplicate of this bug. ***
Comment 10 Carlos Woelz 2004-07-22 03:51:38 UTC
I still can reproduce this bug with KDE 3.3 beta 2.
Comment 11 kendamatej 2004-11-02 13:36:47 UTC
In my case, buttons on the toolbar are rearranged and disappear randomly when I switch between open files using the sidebar in IDEAL mode. I use pre-compiled KDE from kde-redhat.org.

This problem was also reported in bug 47532, similar problem in bug 60156.

---

KDE Version
2.3.1 (KDE 3.3.1-0.2.2.kde, Fedora Core release 2 (Tettnang))

Application
Advanced Text Editor

Operating System
Linux (i686) release 2.6.8-1.521smp
Comment 12 Carlos Woelz 2005-02-15 05:26:14 UTC
Still can reproduce...
KDE 3.4 beta 2
Comment 13 Gordon Dexter 2005-07-24 06:48:54 UTC
This bug was also present in KDE 3.2, and I upgraded to 3.4 in hopes that it would be gone--to no avail.

Behavior I observed:
*The bug only occurs AFTER some button has been added to or removed from the katepart toolbar's default layout.
*As soon as  it starts shuffling and randomly losing icons every time the viewer switches from one document to another.
*The icons do not reappear
*If you continue to switch documents eventually it will stop and there will be only a few buttons left (in my case: new, open, and close).
*Making any change and hitting 'apply' in the toolbar editor temporarily replaces the missing buttons, but the behavior continues.

I'm starting to look through the source code but I'm a coding novice, my best hope is to report symptoms and hope it helps somebody else.
Comment 14 Thomas Kjosmoen 2005-10-07 22:48:23 UTC
I just checked if this bug is still present in my KDE 3.4.1, and it sadly is. Does anyone know whether this bug is present in 3.4.2 or 3.5 beta? It's been unresolved for over two years now.
Comment 15 Stolz 2005-10-30 20:06:36 UTC
>Does anyone know whether this bug is present in 3.4.2 or 3.5 beta? It's been unresolved for over two years now. 

Yes, I can reproduce this bug with 3.4.2 and 3.4.3 too. It's really annoying.
Comment 16 Stolz 2005-12-06 16:05:03 UTC
With kate 3.5.0 the bug is still there :(
Comment 17 Alex Brandt 2006-01-08 10:53:54 UTC
It's been nearly a month, and the bug is still there in my 3.4 build...Would just like a fix for this if possible, and actually if someone would like to email me their suggestions on where this bug may reside I could probably look at the code myself.
Comment 18 Stolz 2006-01-14 15:55:22 UTC
>It's been nearly a month,...
In fact, it's been nearly 2.5 years since the bug was reported ;)

I've recorded a video to see the bug:

Mirror1: http://www.uploading.com/?get=2D2Y8JUM
Mirror2: http://rapidshare.de/files/11026329/bugKate.mpeg.html (press FREE button to download)
Mirror3: http://z19.zupload.com/download.php?file=getfile&filepath=6014
Comment 19 kendamatej 2006-01-29 11:52:09 UTC
This problem doesn't happen in KDE 3.5 in Kubuntu 5.10.
Comment 20 Rick Harris 2006-04-04 01:00:14 UTC
Yet another confirmation here that the bug still exists.

$ kate --version
Qt: 3.3.4
KDE: 3.5.1
Kate: 2.5.1

Hand editing ~/.kde/share/apps/katepart/katepartui.rc as per Jesse's post above fixes it, but would be great to have katepart write the XML correctly when customising the toolbar.
Comment 21 Stolz 2007-02-14 02:56:24 UTC
bug still exists

$ kate --version
Qt: 3.3.6
KDE: 3.5.6
Kate: 2.5.6

It's been unresolved for over 3 years now. 
Comment 22 oldherl 2008-04-12 14:57:03 UTC
bug 160684 seems to be a duplicated of this.

I can reproduce this even in 3.5.9, the latest KDE 3 now.

It hasn't been fixed for over 4.5 years!
I wonder if this still remains in KDE 4...
Comment 23 oldherl 2008-04-12 15:16:17 UTC
Note:
You have to add a "Encoding..." button in katepartview tooolbar to reproduce this.
Comment 24 Stolz 2008-05-07 19:20:11 UTC
>Note:
>You have to add a "Encoding..." button in katepartview tooolbar to reproduce this.
I can reproduce it without adding that button

Would be possible to know if someone in KDE team is officially trying to solve this bug?
Comment 25 oldherl 2008-05-09 10:40:05 UTC
Who knows...

2008/5/8 Stolz <stolz@ya.com>:
[bugs.kde.org quoted mail]
Comment 26 Ivo Anjo 2008-07-10 13:09:07 UTC
After playing with adding encoding to the toolbar, making the icons move a bit, then removing it and closing kate, I get a crash.

So, changing severity to crash.

Backtrace I got with 4.0.4 on openSUSE 11.0:

[?1034h(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread 0xb61786d0 (LWP 22329)]
[KCrash handler]
#6  QApplication::topLevelWidgets ()
    at ../../include/QtCore/../../src/corelib/global/qglobal.h:1936
#7  0xb681101f in QApplicationPrivate::enterModal (widget=0xbf986f2c)
    at kernel/qapplication.cpp:2605
#8  0xb685fe1e in QWidgetPrivate::show_helper (this=0x8578010)
    at kernel/qwidget.cpp:6171
#9  0xb68603ae in QWidget::setVisible (this=0xbf986f2c, visible=true)
    at kernel/qwidget.cpp:6378
#10 0xb6c14d9d in QDialog::setVisible (this=0xbf986f2c, visible=true)
    at dialogs/qdialog.cpp:655
#11 0xb6c14233 in QDialog::exec (this=0xbf986f2c)
    at ../../include/QtGui/../../src/gui/kernel/qwidget.h:470
#12 0xb8003da2 in ?? () from /usr/lib/libkateinterfaces.so.4
#13 0xb800b126 in ?? () from /usr/lib/libkateinterfaces.so.4
#14 0xb800b38b in ?? () from /usr/lib/libkateinterfaces.so.4
#15 0xb78e9bda in KMainWindow::closeEvent (this=0x81e84a8, e=0xbf987544)
    at /usr/src/debug/kdelibs-4.0.4/kdeui/widgets/kmainwindow.cpp:513
#16 0xb685ecd8 in QWidget::event (this=0x81e84a8, event=0xbf987544)
    at kernel/qwidget.cpp:7077
#17 0xb6b624f7 in QMainWindow::event (this=0x81e84a8, event=0xbf987544)
    at widgets/qmainwindow.cpp:1252
#18 0xb78e8d28 in KMainWindow::event (this=0x81e84a8, ev=0xbf987544)
    at /usr/src/debug/kdelibs-4.0.4/kdeui/widgets/kmainwindow.cpp:963
#19 0xb791f51c in KXmlGuiWindow::event (this=0x81e84a8, ev=0xbf987544)
    at /usr/src/debug/kdelibs-4.0.4/kdeui/xmlgui/kxmlguiwindow.cpp:123
#20 0xb8003e93 in ?? () from /usr/lib/libkateinterfaces.so.4
#21 0xb680cecc in QApplicationPrivate::notify_helper (this=0x805a4a0, 
    receiver=0xbf987544, e=0x81e84a8) at kernel/qapplication.cpp:3772
#22 0xb68133ea in QApplication::notify (this=0xbf987c4c, receiver=0x81e84a8, 
    e=0xbf987544) at kernel/qapplication.cpp:3739
#23 0xb782c36d in KApplication::notify (this=0xbf987c4c, receiver=0x81e84a8, 
    event=0xbf987544)
    at /usr/src/debug/kdelibs-4.0.4/kdeui/kernel/kapplication.cpp:314
#24 0xb72a9b51 in QCoreApplication::notifyInternal (this=0xbf987c4c, 
    receiver=0x81e84a8, event=0xbf987544) at kernel/qcoreapplication.cpp:583
#25 0xb685fa52 in QWidgetPrivate::close_helper (this=0x81f6ef8, 
    mode=QWidgetPrivate::CloseWithSpontaneousEvent)
    at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#26 0xb686453b in QApplication::x11ClientMessage (this=0xbf987c4c, 
    w=0x81e84a8, event=0xbf9879cc, passive_only=9)
    at kernel/qapplication_x11.cpp:4898
#27 0xb687113a in QApplication::x11ProcessEvent (this=0xbf987c4c, 
    event=0xbf9879cc) at kernel/qapplication_x11.cpp:3384
#28 0xb68973ae in QEventDispatcherX11::processEvents (this=0x8057810, flags=
      {i = -1080526232}) at kernel/qeventdispatcher_x11.cpp:134
#29 0xb72a82ca in QEventLoop::processEvents (this=0xbf987ad0, flags=
      {i = -1080526168}) at kernel/qeventloop.cpp:149
#30 0xb72a848a in QEventLoop::exec (this=0xbf987ad0, flags={i = -1080526120})
    at kernel/qeventloop.cpp:196
#31 0xb72aa66d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:845
#32 0xb680cd47 in QApplication::exec () at kernel/qapplication.cpp:3304
#33 0xb8047975 in kdemain () from /usr/lib/libkdeinit4_kate.so
#34 0x08048812 in _start ()
#0  0xffffe430 in __kernel_vsyscall ()

Backtrace from latest kde4daily:

Application: Kate (kate), signal SIGSEGV
KDE4Daily is generating a backtrace - please be patient :)
KDESVNTRUNKr829808
------

[Thread debugging using libthread_db enabled]
[New Thread 0xb5d0f720 (LWP 4702)]
0xb7f3d402 in __kernel_vsyscall ()

#1  0xb6105c90 in nanosleep () from /lib/tls/i686/cmov/libc.so.6
#2  0xb6105ac7 in sleep () from /lib/tls/i686/cmov/libc.so.6
#3  0xb74c7269 in KCrash::startDrKonqi (argv=0xbfa23c20, argc=17) at /home/kde4daily/src/kdelibs/kdeui/util/kcrash.cpp:412
#4  0xb74c7dac in KCrash::defaultCrashHandler (sig=11) at /home/kde4daily/src/kdelibs/kdeui/util/kcrash.cpp:337
#6  0xb6483eef in QDomNamedNodeMapPrivate::clearMap () from /home/kde4daily/install/qt-copy/lib/libQtXml.so.4
#7  0xb6483f89 in QDomNamedNodeMapPrivate::~QDomNamedNodeMapPrivate () from /home/kde4daily/install/qt-copy/lib/libQtXml.so.4
#8  0xb6483fe6 in QDomElementPrivate::~QDomElementPrivate () from /home/kde4daily/install/qt-copy/lib/libQtXml.so.4
#9  0xb647cfc0 in QDomNodePrivate::~QDomNodePrivate () from /home/kde4daily/install/qt-copy/lib/libQtXml.so.4
#10 0xb6483ffc in QDomElementPrivate::~QDomElementPrivate () from /home/kde4daily/install/qt-copy/lib/libQtXml.so.4
#11 0xb647cfc0 in QDomNodePrivate::~QDomNodePrivate () from /home/kde4daily/install/qt-copy/lib/libQtXml.so.4
#12 0xb6483ffc in QDomElementPrivate::~QDomElementPrivate () from /home/kde4daily/install/qt-copy/lib/libQtXml.so.4
#13 0xb647cfc0 in QDomNodePrivate::~QDomNodePrivate () from /home/kde4daily/install/qt-copy/lib/libQtXml.so.4
#14 0xb647d0c5 in QDomDocumentPrivate::~QDomDocumentPrivate () from /home/kde4daily/install/qt-copy/lib/libQtXml.so.4
#15 0xb647a0be in QDomNode::~QDomNode () from /home/kde4daily/install/qt-copy/lib/libQtXml.so.4
#16 0xb647bcc9 in QDomDocument::~QDomDocument () from /home/kde4daily/install/qt-copy/lib/libQtXml.so.4
#17 0xb756ba3c in ~KXMLGUIClientPrivate (this=0x80fecf8) at /home/kde4daily/src/kdelibs/kdeui/xmlgui/kxmlguiclient.cpp:54
#18 0xb756b041 in ~KXMLGUIClient (this=0x826e210) at /home/kde4daily/src/kdelibs/kdeui/xmlgui/kxmlguiclient.cpp:102
#19 0xb7d104e1 in ~KateMainWindow (this=0x826e158) at /home/kde4daily/src/kdesdk/kate/app/katemainwindow.cpp:209
#20 0xb6fab62f in qDeleteInEventHandler () from /home/kde4daily/install/qt-copy/lib/libQtCore.so.4
#21 0xb6faf7f4 in QObject::event () from /home/kde4daily/install/qt-copy/lib/libQtCore.so.4
#22 0xb672cfb9 in QWidget::event () from /home/kde4daily/install/qt-copy/lib/libQtGui.so.4
#23 0xb6ab88c3 in QMainWindow::event () from /home/kde4daily/install/qt-copy/lib/libQtGui.so.4
#24 0xb752420a in KMainWindow::event (this=0x826e158, ev=0x8618528) at /home/kde4daily/src/kdelibs/kdeui/widgets/kmainwindow.cpp:1008
#25 0xb7563cf9 in KXmlGuiWindow::event (this=0x826e158, ev=0x8618528) at /home/kde4daily/src/kdelibs/kdeui/xmlgui/kxmlguiwindow.cpp:122
#26 0xb7d0c82c in KateMainWindow::event (this=0x826e158, e=0x8618528) at /home/kde4daily/src/kdesdk/kate/app/katemainwindow.cpp:795
#27 0xb66ce81d in QApplicationPrivate::notify_helper () from /home/kde4daily/install/qt-copy/lib/libQtGui.so.4
#28 0xb66d0406 in QApplication::notify () from /home/kde4daily/install/qt-copy/lib/libQtGui.so.4
#29 0xb7460511 in KApplication::notify (this=0xbfa24a90, receiver=0x826e158, event=0x8618528) at /home/kde4daily/src/kdelibs/kdeui/kernel/kapplication.cpp:311
#30 0xb6f9c68a in QCoreApplication::notifyInternal () from /home/kde4daily/install/qt-copy/lib/libQtCore.so.4
#31 0xb7a5ceaf in QCoreApplication::sendEvent () from /home/kde4daily/install/qt-copy/lib/libQt3Support.so.4
#32 0xb6f9cba2 in QCoreApplicationPrivate::sendPostedEvents () from /home/kde4daily/install/qt-copy/lib/libQtCore.so.4
#33 0xb6f9cd53 in QCoreApplication::sendPostedEvents () from /home/kde4daily/install/qt-copy/lib/libQtCore.so.4
#34 0xb6f9cec1 in QCoreApplication::exec () from /home/kde4daily/install/qt-copy/lib/libQtCore.so.4
#35 0xb66ce536 in QApplication::exec () from /home/kde4daily/install/qt-copy/lib/libQtGui.so.4
#36 0xb7f384a5 in kdemain (argc=1, argv=0xbfa25004) at /home/kde4daily/src/kdesdk/kate/app/katemain.cpp:252
#37 0x08048826 in main ()

A friend also mentioned he could get it to crash when he removed the "encoding" button from the toolbar, by clicking apply on the configure toolbar dialog, but I could not repeat it.
Comment 27 Andy Goss 2009-01-24 02:44:26 UTC
I am getting this bug in Debian Lenny using Kate 2.5.10 (KDE 3.5.10), but I did not get it in Debian Etch, Kubuntu Dapper, or SUSE 10.1.
Comment 28 Christoph Feck 2009-10-05 17:56:16 UTC
The crash about editing the toolbar is probably fixed bug 200815.

The moving UI items are still visible in current trunk, e.g. with Kate, at least with an customized toolbar.
Comment 29 Christoph Feck 2009-10-05 17:59:19 UTC
*** Bug 181702 has been marked as a duplicate of this bug. ***
Comment 30 Christoph Feck 2009-10-05 18:06:08 UTC
*** Bug 56229 has been marked as a duplicate of this bug. ***
Comment 31 Christoph Feck 2010-04-11 02:35:37 UTC
*** Bug 173764 has been marked as a duplicate of this bug. ***
Comment 32 Christoph Feck 2010-08-31 03:48:39 UTC
*** Bug 208402 has been marked as a duplicate of this bug. ***
Comment 33 Christoph Feck 2011-07-25 16:05:34 UTC
*** Bug 60156 has been marked as a duplicate of this bug. ***
Comment 34 Christoph Feck 2011-07-26 13:34:20 UTC
*** Bug 90431 has been marked as a duplicate of this bug. ***
Comment 35 Christoph Feck 2011-12-20 01:03:20 UTC
*** Bug 118722 has been marked as a duplicate of this bug. ***
Comment 36 Christoph Feck 2012-10-27 11:36:08 UTC
*** Bug 253190 has been marked as a duplicate of this bug. ***
Comment 37 Christoph Feck 2012-10-28 05:22:40 UTC
*** Bug 294103 has been marked as a duplicate of this bug. ***
Comment 38 Greg Lepore 2013-02-10 13:26:46 UTC
Bug is still occuring on Kate 3.10 and KDE 4.10.  Does this bug not affect the developers or do they not use Kate? Playing whack-a-mole with the tool bar icons in order to hit the correct icon when it's moving around regularly is ridiculous.  I am in Kate for many hours a day, editing dozens of files, and this bug is severe (look at the votes.) How about an update from a dev? If there is any thing that a user can do to help isolate this nearly 10 year old bug, please ask.
Comment 39 Greg Lepore 2013-03-09 14:50:18 UTC
Upgraded to KDE 4.10.1, bug is still occuring, still looking for some indication from a dev that they are or will be looking at this.
Comment 40 Christoph Feck 2013-07-08 03:08:10 UTC
*** Bug 235937 has been marked as a duplicate of this bug. ***
Comment 41 Christoph Feck 2013-07-08 03:27:27 UTC
*** Bug 180756 has been marked as a duplicate of this bug. ***
Comment 42 Christoph Feck 2014-01-02 22:14:58 UTC
*** Bug 329541 has been marked as a duplicate of this bug. ***
Comment 43 naraesk 2014-08-16 11:22:47 UTC
any news? there is still no fix. :(
Comment 44 Christoph Feck 2014-12-23 19:35:30 UTC
*** Bug 342170 has been marked as a duplicate of this bug. ***
Comment 45 Monika Eggers 2014-12-23 23:47:55 UTC
(In reply to Christoph Feck from comment #44)
> *** Bug 342170 has been marked as a duplicate of this bug. ***

Cool, my 2014 bug is a duplicate of a 2003 bug.
Comment 46 Monika Eggers 2014-12-24 00:15:24 UTC
(In reply to Monika Eggers from comment #45)
> (In reply to Christoph Feck from comment #44)
> > *** Bug 342170 has been marked as a duplicate of this bug. ***
> 
> Cool, my 2014 bug is a duplicate of a 2003 bug.

I made a screen video: https://www.youtube.com/watch?v=mVsL3PuQ9n8

I also noticed the following: On a fresh installation of the same version it doesn't happen. The only difference there is that the "paste" ("Einfügen") button in the KatePartView toolbar is not present there. When I remove it on my main computer, where I experienced the problem, then it stops happening there. When I add this button on the other installation the problem starts occurring there (even without restarting kate).

Also, not sure if it's relevant/related, but who knows: When I add/remove the button from/to the toolbar, it's only present/gone on one of the two files (there where I made the toolbar edit), but not yet/still present on the other one. (But the problem is not triggered by adding/removing the button, it persists after restarting kate, i.e. when the button is present on both files.
Comment 47 Greg Lepore 2015-04-08 11:33:47 UTC
This ancient bug is still appearing in Kate 5.0.0 using KDE 5.8.0. Can we please get someone to look at this?
Comment 48 Dominik Haumann 2016-06-16 12:16:44 UTC
*** Bug 322165 has been marked as a duplicate of this bug. ***
Comment 49 David Faure 2016-06-17 08:49:48 UTC
Git commit cfb9d1923b1376153760519edf4760248176c7c8 by David Faure.
Committed on 17/06/2016 at 08:49.
Pushed by dfaure into branch 'master'.

KXMLGui: Fix merge indices when removing xmlgui clients with actions in groups.

Summary:
The code was assuming that all actions from the client being removed
were together in one merge point, but the group feature (added slightly later)
changed that. Indices therefore have to be adjusted after each action removal.

While extending the unittest to check this for dynamic actionlists, I found
another bug in the updating of merging indices: when a client inserts an
actionlist element (or possibly a group element for child-child-clients)
and then N more actions, the actionlist would go down N times. Fixed by
comparing clientNames, i.e. only merge points from other clients should
go down while inserting actions, nor our own [except in plugActionList].
FIXED-IN: 5.24

Test Plan:
Editing toolbars in kate to add actions (without group) to
the katepart toolbar, would lead to incoherent moving of toolbar buttons
at every document switch. This commit fixes that.

Reviewers: svuorela, dhaumann

Reviewed By: dhaumann

Subscribers: kde-frameworks-devel

Differential Revision: https://phabricator.kde.org/D1924

M  +73   -45   autotests/kxmlgui_unittest.cpp
M  +3    -1    src/kxmlguibuilder.h
M  +2    -12   src/kxmlguifactory.cpp
M  +46   -69   src/kxmlguifactory_p.cpp
M  +3    -3    src/kxmlguifactory_p.h

http://commits.kde.org/kxmlgui/cfb9d1923b1376153760519edf4760248176c7c8
Comment 50 Bobby 2016-06-17 20:43:46 UTC
David Faure, you deserve a medal.  A 13 year old KDE bug finally fixed.  Just think, when this bug was first reported:

-- The current Linux Kernel was 2.6.31
-- Top Movie?  The ORIGINAL Underworld.
-- Windows XP was the most current desktop verison.  Vista was still 3 years away.
-- Top 2 Linux verions?  Mandrake and Redhat (Fedora wouldn't be released for another 2 months, Ubuntu's first was more than a year away.)
-- Top billboard song?  Crazy In Love by Jay-Z & Beyoncé (who was barely old enough to drink)
-- 3 of the 5 KDE ev board members hadn't ever used KDE
-- Palestinian Prime Minister Mahmoud Abbas resigns ending "Road Map for Peace"
-- Current KDE version?  3.1.4  (KDE 3 had only been out for a year)

Very very cool!
Comment 51 Christoph Cullmann 2016-06-17 21:18:38 UTC
https://en.wikipedia.org/wiki/Linux_kernel tells 2.6.0 was not even released if I read the charts right but otherwise: brilliant :P
Comment 52 oldherl 2016-06-18 02:12:56 UTC
Created attachment 99558 [details]
attachment-27410-0.html

Wow, that's incredible!
Add a line: There was no Facebook, Gmail, or Twitter at the time this bug
was filed.
2016年6月18日 上午4:43,"Bobby via KDE Bugzilla" <bugzilla_noreply@kde.org>写道:

> https://bugs.kde.org/show_bug.cgi?id=64754
>
> --- Comment #50 from Bobby <rrockers@gmail.com> ---
> David Faure, you deserve a medal.  A 13 year old KDE bug finally fixed.
> Just
> think, when this bug was first reported:
>
> -- The current Linux Kernel was 2.6.31
> -- Top Movie?  The ORIGINAL Underworld.
> -- Windows XP was the most current desktop verison.  Vista was still 3
> years
> away.
> -- Top 2 Linux verions?  Mandrake and Redhat (Fedora wouldn't be released
> for
> another 2 months, Ubuntu's first was more than a year away.)
> -- Top billboard song?  Crazy In Love by Jay-Z & Beyoncé (who was barely
> old
> enough to drink)
> -- 3 of the 5 KDE ev board members hadn't ever used KDE
> -- Palestinian Prime Minister Mahmoud Abbas resigns ending "Road Map for
> Peace"
> -- Current KDE version?  3.1.4  (KDE 3 had only been out for a year)
>
> Very very cool!
>
> --
> You are receiving this mail because:
> You are on the CC list for the bug.
> You voted for the bug.