Bug 118722 - Configured toolbars mess up when reloading a project
Summary: Configured toolbars mess up when reloading a project
Status: RESOLVED DUPLICATE of bug 64754
Alias: None
Product: kdelibs
Classification: Frameworks and Libraries
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR normal
Target Milestone: ---
Assignee: kdevelop-bugs-null
URL:
Keywords:
: 72359 73771 123075 135355 144067 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-12-20 16:22 UTC by Fred
Modified: 2011-12-20 01:03 UTC (History)
7 users (show)

See Also:
Latest Commit:
Version Fixed In:
Sentry Crash Report:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Fred 2005-12-20 16:22:48 UTC
Version:           3.2.1 (using KDE KDE 3.4.2)
Installed from:    Fedora RPMs
OS:                Linux

I configured the KDevTrollProject toolbars, mostly to remove the infamous "Rebuild all" button, and to reorder some buttons. The buttons (actions) I have (or want) in the toolbar are now :
 - Build Project
 - Execute Main Program
 - --- line separator ---
 - Compile File

The ~/.kde/share/apps/kdevtrollproject/kdevtrollproject.rc file seems to have been saved correctly :
<!DOCTYPE kpartgui SYSTEM "kpartgui.dtd">
<kpartgui version="3" name="KDevTrollProject" >
 <MenuBar>
  <Menu name="build" >
   <Action name="build_build_project" />
   <Action name="build_rebuild_project" />
   <Action name="build_execute_project" />
   <Action name="build_clean_project" />
   <Separator/>
   <Action name="build_build_target" />
   <Action name="build_rebuild_target" />
   <Action name="build_execute_target" />
   <Action name="build_clean_target" />
   <Separator/>
   <Action name="build_compilefile" />
  </Menu>
 </MenuBar>
 <ToolBar noMerge="1" name="buildToolBar" >
  <Action group="build_operations" name="build_build_project" />
  <Action group="build_operations" name="build_execute_project" />
  <Separator group="build_operations" name="separator_0" />
  <Action name="build_compilefile" />
 </ToolBar>
</kpartgui>


Upon the first launch of KDevelop, it automatically loads the last project I worked on and it loads the toolbars correctly. However, if I close the project (through Project --> Close Project) and then I open a new KDevTrollProject project (through Project --> Open Project), the KDevTrollProject toolbar gets loaded randomly. Sometimes, not all the buttons are displayed, and they're almost never in the appropriate order. However, if I go to Settings --> Configure Toolbars... and select the KDevTrollProject toolbar, the dialog displays the "Current actions" appropriately, but I need to swap them back and forth and press "Apply" for the toolbar to be ok.
Comment 1 Fred 2006-01-10 00:09:33 UTC
It still happens on KDevelop 3.3 (Using KDE 3.5.0)
Comment 2 Jens Dagerbo 2006-12-17 18:13:41 UTC
*** Bug 123075 has been marked as a duplicate of this bug. ***
Comment 3 Jens Dagerbo 2006-12-17 18:14:42 UTC
*** Bug 72359 has been marked as a duplicate of this bug. ***
Comment 4 Jens Dagerbo 2006-12-17 18:15:45 UTC
*** Bug 73771 has been marked as a duplicate of this bug. ***
Comment 5 Jens Dagerbo 2006-12-17 22:18:38 UTC
*** Bug 135355 has been marked as a duplicate of this bug. ***
Comment 6 Jens Dagerbo 2007-01-09 01:44:11 UTC
The problem, as can be seen in the rc example above, is that the "build_compilefile" action is not given any "group" to belong to when added to that toolbar. This then leads to some bug when merging that results in toolbar buttons dropping from the toolbar. If the "build_operations" group is added to that action manually, everything then works as intended.

It tried to reproduce it with Kate to make sure this happens with other apps as well, and the easiest way I found was: 
1. Start Kate
2. Settings -> Configure toolbars
3. Select "Main Toolbar <KateViewPart>" and add an action to it
4. switch between several open documents
=> (almost) every time a new document is activated the toolbar loses one button

(It's actually the 2nd oldest bug open against Kate: http://bugs.kde.org/show_bug.cgi?id=56229)

As I understand it, this cannot be caused or fixed by the client application as the toolbar editing dialog is a kdelibs component. Reassigning.
Comment 7 Jens Dagerbo 2007-04-11 20:29:52 UTC
*** Bug 144067 has been marked as a duplicate of this bug. ***
Comment 8 Christoph Feck 2011-12-20 01:03:20 UTC

*** This bug has been marked as a duplicate of bug 64754 ***