Bug 60156 - Partial Icon bar rewrite when text window focus is changed (flickering)
Summary: Partial Icon bar rewrite when text window focus is changed (flickering)
Status: RESOLVED DUPLICATE of bug 64754
Alias: None
Product: kdelibs
Classification: Frameworks and Libraries
Component: general (show other bugs)
Version: unspecified
Platform: Debian testing Linux
: NOR normal
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
: 60106 (view as bug list)
Depends on:
Blocks:
 
Reported: 2003-06-20 21:44 UTC by Elektro Schock
Modified: 2011-07-25 16:05 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:
Sentry Crash Report:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Elektro Schock 2003-06-20 21:44:01 UTC
Version:            (using KDE KDE 3.1.2)
Installed from:    Debian testing/unstable Packages
OS:          Linux

I devided my edited text into two horizontal texts edit boxes. when i change the focus betwenn those two via mouse click, parts of the main icon bar are rewritten also they are not affected. Not the whole Icon bar, beginning with the floppy button. I don't think that is necessary at all. The same happens when I use the up/down button in the icon bar.
I looks as if the righter part of the Icon bar moves about 2 pt into the direction "right" and then is rewritten. This causes a flickering effect. 
the behaviour can be reproduced.
Comment 1 Anders Lund 2003-06-22 08:27:09 UTC
Yes I have a little flicker. 
The redrawind og the toolbar has to do with the fact that the redrawn buttons are 
provided by the view, which we are not likely to change. 
Konqueror in tabbede mode seems to have less flickering, maybe we should look at 
how it is done there. 
Comment 2 Anders Lund 2003-06-22 08:32:58 UTC
*** Bug 60106 has been marked as a duplicate of this bug. ***
Comment 3 Elektro Schock 2003-06-23 00:30:15 UTC
I used a Knoppix based LIVE CD, 1,3 MHZ machine, therefore a little bit slower. 
You can also see that the Icon bar is painted by light blue first. I think it 
would be better to use a color that is more similar to the usual bar color. 
(Normal Kontrol center settings, Keramik)
Comment 4 Dale Clapperton 2003-06-23 15:37:31 UTC
A bug I filed, 60106 has been marked as a duplicate of this bug.  I'm not
entirely sure they're the same problem, and the "fix" noted by Anders is
incorrect.  The missing toolbar buttons do not "come back", the only way to get
them back is to close Kate and restart it.
Comment 5 Anders Lund 2003-06-23 18:40:12 UTC
Hm, it is related, it has the same origin: the fact that the buttons are owned by the 
individual editor view. 
 
I never heard about them not coming back, can that be comfirmed by other freeBSD 
users? 
 
Comment 6 Anders Lund 2003-06-23 18:50:51 UTC
Subject: Re:  Partial Icon bar rewrite when text window focus is changed (flickering)

On Monday 23 June 2003 00:30, Elektro Schock wrote:
> I used a Knoppix based LIVE CD, 1,3 MHZ machine, therefore a little bit
> slower. You can also see that the Icon bar is painted by light blue first.
> I think it would be better to use a color that is more similar to the usual
> bar color. (Normal Kontrol center settings, Keramik)
The painting of toolbars is not a kate job, that is performed by ktoolbar.
you should not have that sort of dealy in a 1.3mhz running knoppix - for 
example i don't see that in my 400 celery laptop running knoppix... You 
wouldn't be short of memory? I really cant see why anybody would have that 
much delay :(

-anders

Comment 7 Elektro Schock 2003-06-29 19:14:42 UTC
Subject: Re:  Partial Icon bar rewrite when text window focus
    is changed (flickering)

I think the problem is more up to the design a program is written. As I learned the icons belong to the window that the focus ist on. So it's a kind of "erase the icon bar" and then rewrite it (however now it belongs to another application). It must be possible to avoid unneccessary rewrites.
Comment 8 Nicole Landau 2004-09-18 19:15:54 UTC
I have the problem of the disappearing icons aswell, for me opening the Configure Toolbar, removing one button and then putting it back in helps get the toolbar icons all back, however that's just really anoying, I don't want to do that every time my save button has disappeared..
Comment 9 kendamatej 2004-11-02 13:36:52 UTC
In my case, buttons on the toolbar are rearranged and disappear randomly when I switch between open files using the sidebar in IDEAL mode. I use pre-compiled KDE from kde-redhat.org.

This problem was also reported in bug 47532, similar problem in bug 64754.

---

KDE Version
2.3.1 (KDE 3.3.1-0.2.2.kde, Fedora Core release 2 (Tettnang))

Application
Advanced Text Editor

Operating System
Linux (i686) release 2.6.8-1.521smp
Comment 10 David King 2008-12-23 02:01:57 UTC
Has this been fixed yet?  I lose tool buttons _every time I close a file_.  FYI I have changed toolbar config -- I think it started doing it after that. I think I added some buttons under "Main Toolbar <katePartView>" (as opposed to "Main Toolbar <kate>" <-- I suspect that distinction is as meaningless to most other viewers as it is to me....  'katePartView'??... c'mon, don't be such nerds...)

It doesn't take long before I lose the save icon (which is _really_ irritating, as if kate suddenly decided I'll never want to save anything again....)

--->a clue(?):  If I 'configure toolbars' and change something (just so I can 'apply' -- I also undo it) _all my toolbuttons come back_ (but not for long.)


This would be a great editor if it didn't have brain-damaged bugs like this.  I'm still hanging on, but will change soon if it's not fixed.  You can't expect professionals to develop code with such a buggy text editor -- the text editor is a programmer's lifesblood.  PLEASE FIX!!!

I am willing to send config files if you need them.


Comment 11 Christoph Feck 2011-07-25 16:05:34 UTC

*** This bug has been marked as a duplicate of bug 64754 ***