Bug 325109 - Muon Crash on update repositories
Summary: Muon Crash on update repositories
Status: RESOLVED FIXED
Alias: None
Product: Discover
Classification: Unclassified
Component: Updates (interactive) (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash
Target Milestone: ---
Assignee: Jonathan Thomas
URL:
Keywords: drkonqi
: 321818 325525 326255 326263 326537 327912 328347 328995 329528 329935 330054 330407 330486 330615 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-09-19 23:57 UTC by Cristian M. Barbe
Modified: 2016-03-02 14:23 UTC (History)
23 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (9.83 KB, text/plain)
2013-11-06 23:33 UTC, Buddlespit
Details
New crash information added by DrKonqi (10.33 KB, text/plain)
2013-12-15 11:46 UTC, p92
Details
New crash information added by DrKonqi (10.12 KB, text/plain)
2014-01-03 09:42 UTC, daniel
Details
New crash information added by DrKonqi (10.08 KB, text/plain)
2014-01-04 10:14 UTC, Ben
Details
New crash information added by DrKonqi (11.13 KB, text/plain)
2014-01-30 12:59 UTC, Dan Mac
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Cristian M. Barbe 2013-09-19 23:57:40 UTC
Application: muon-updater (2.0.65)
KDE Platform Version: 4.11.1
Qt Version: 4.8.4
Operating System: Linux 3.11.0-7-generic x86_64
Distribution: Ubuntu Saucy Salamander (development branch)

-- Information about the crash:
- What I was doing when the application crashed:

Waiting for updates to install all... muon crash when i click on update button.



sorry my english

The crash can be reproduced sometimes.

-- Backtrace:
Application: Gestor de actualizaciones Muon (muon-updater), signal: Aborted
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f9a764397c0 (LWP 12905))]

Thread 3 (Thread 0x7f9a6331a700 (LWP 12906)):
#0  0x00007f9a73a923dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f9a70e196b4 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f9a70e197bc in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f9a741e95ef in QEventLoop::processEvents (this=this@entry=0x7f9a63319d70, flags=...) at kernel/qeventloop.cpp:149
#4  0x00007f9a741e98e5 in QEventLoop::exec (this=this@entry=0x7f9a63319d70, flags=...) at kernel/qeventloop.cpp:204
#5  0x00007f9a740e888f in QThread::exec (this=this@entry=0x88f380) at thread/qthread.cpp:542
#6  0x00007f9a741cad13 in QInotifyFileSystemWatcherEngine::run (this=0x88f380) at io/qfilesystemwatcher_inotify.cpp:265
#7  0x00007f9a740eaf2f in QThreadPrivate::start (arg=0x88f380) at thread/qthread_unix.cpp:338
#8  0x00007f9a712f1f6e in start_thread (arg=0x7f9a6331a700) at pthread_create.c:311
#9  0x00007f9a73a9ee2d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 2 (Thread 0x7f9a51600700 (LWP 13131)):
#0  0x00007f9a70e5951d in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f9a70e3e7e0 in g_thread_join () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f9a70e187ec in g_get_monotonic_time () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f9a4c771b20 in ?? ()
#4  0x0000000000000001 in ?? ()
#5  0x00007f9a515ffd00 in ?? ()
#6  0x00007f9a70e19575 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#7  0x00007f9a4c6333c0 in ?? ()
#8  0x00007f9a515ffd10 in ?? ()
#9  0x00007f9a515ffd60 in ?? ()
#10 0x00007f9a515ffd10 in ?? ()
#11 0x0000000000659570 in ?? ()
#12 0x0000000000000012 in ?? ()
#13 0x00007f9a741e95ef in QEventLoop::processEvents (this=this@entry=0x7f9a515ffd70, flags=...) at kernel/qeventloop.cpp:149
#14 0x00007f9a741e98e5 in QEventLoop::exec (this=this@entry=0x7f9a515ffd70, flags=...) at kernel/qeventloop.cpp:204
#15 0x00007f9a740e888f in QThread::exec (this=this@entry=0xd65a70) at thread/qthread.cpp:542
#16 0x00007f9a741cad13 in QInotifyFileSystemWatcherEngine::run (this=0xd65a70) at io/qfilesystemwatcher_inotify.cpp:265
#17 0x00007f9a740eaf2f in QThreadPrivate::start (arg=0xd65a70) at thread/qthread_unix.cpp:338
#18 0x00007f9a712f1f6e in start_thread (arg=0x7f9a51600700) at pthread_create.c:311
#19 0x00007f9a73a9ee2d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 1 (Thread 0x7f9a764397c0 (LWP 12905)):
[KCrash Handler]
#6  0x00007f9a739dbf77 in __GI_raise (sig=sig@entry=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:56
#7  0x00007f9a739df5e8 in __GI_abort () at abort.c:90
#8  0x00007f9a740e0912 in qt_message_output (msgType=msgType@entry=QtFatalMsg, buf=0x16c4dd8 "ASSERT failure in QList<T>::at: \"index out of range\", file /usr/include/qt4/QtCore/qlist.h, line 469") at global/qglobal.cpp:2347
#9  0x00007f9a740e0c79 in qt_message(QtMsgType, const char *, typedef __va_list_tag __va_list_tag *) (msgType=msgType@entry=QtFatalMsg, msg=msg@entry=0x7f9a7424baa8 "ASSERT failure in %s: \"%s\", file %s, line %d", ap=ap@entry=0x7fff82adc408) at global/qglobal.cpp:2393
#10 0x00007f9a740e1484 in qFatal (msg=msg@entry=0x7f9a7424baa8 "ASSERT failure in %s: \"%s\", file %s, line %d") at global/qglobal.cpp:2576
#11 0x00007f9a740e14ea in qt_assert_x (where=where@entry=0x7f9a60d9d0ac "QList<T>::at", what=what@entry=0x7f9a60d9d08a "index out of range", file=file@entry=0x7f9a60d9cf70 "/usr/include/qt4/QtCore/qlist.h", line=line@entry=469) at global/qglobal.cpp:2029
#12 0x00007f9a60d6c05a in at (i=67036, this=0xb91728) at /usr/include/qt4/QtCore/qlist.h:469
#13 QApt::Backend::stateChanges (this=<optimized out>, oldState=..., excluded=...) at /build/buildd/qapt-2.0.65/src/backend.cpp:754
#14 0x00007f9a61622674 in ApplicationUpdates::calculateUpdates (this=this@entry=0xb916f0) at /build/buildd/muon-2.0.65/libmuon/backends/ApplicationBackend/ApplicationUpdates.cpp:438
#15 0x00007f9a61622b09 in ApplicationUpdates::reloadFinished (this=0xb916f0) at /build/buildd/muon-2.0.65/libmuon/backends/ApplicationBackend/ApplicationUpdates.cpp:431
#16 0x00007f9a741fea58 in QMetaObject::activate (sender=sender@entry=0xb8e290, m=m@entry=0x7f9a7624b300 <AbstractResourcesBackend::staticMetaObject>, local_signal_index=local_signal_index@entry=2, argv=argv@entry=0x0) at kernel/qobject.cpp:3539
#17 0x00007f9a76025933 in AbstractResourcesBackend::reloadFinished (this=this@entry=0xb8e290) at /build/buildd/muon-2.0.65/obj-x86_64-linux-gnu/libmuon/moc_AbstractResourcesBackend.cpp:170
#18 0x00007f9a61615a35 in ApplicationBackend::reload (this=0xb8e290) at /build/buildd/muon-2.0.65/libmuon/backends/ApplicationBackend/ApplicationBackend.cpp:176
#19 0x00007f9a61621c82 in ApplicationUpdates::statusChanged (this=0xb916f0, status=12905) at /build/buildd/muon-2.0.65/libmuon/backends/ApplicationBackend/ApplicationUpdates.cpp:355
#20 0x00007f9a741fea58 in QMetaObject::activate (sender=0x246e250, m=m@entry=0x7f9a60fae9c0 <QApt::Transaction::staticMetaObject>, local_signal_index=local_signal_index@entry=1, argv=argv@entry=0x7fff82adc970) at kernel/qobject.cpp:3539
#21 0x00007f9a60d992e1 in QApt::Transaction::statusChanged (this=<optimized out>, _t1=QApt::FinishedStatus) at /build/buildd/qapt-2.0.65/obj-x86_64-linux-gnu/src/moc_transaction.cxx:291
#22 0x00007f9a60d8c44e in QApt::Transaction::updateProperty (this=0x246e250, type=12905, variant=...) at /build/buildd/qapt-2.0.65/src/transaction.cpp:518
#23 0x00007f9a60d99974 in QApt::Transaction::qt_static_metacall (_o=0x246e250, _c=<optimized out>, _id=<optimized out>, _a=0x7fff82adcb90) at /build/buildd/qapt-2.0.65/obj-x86_64-linux-gnu/src/moc_transaction.cxx:164
#24 0x00007f9a741fea58 in QMetaObject::activate (sender=sender@entry=0x24992f0, m=m@entry=0x7f9a60faeaa0 <OrgKubuntuQaptworkerTransactionInterface::staticMetaObject>, local_signal_index=local_signal_index@entry=4, argv=argv@entry=0x7fff82adcb90) at kernel/qobject.cpp:3539
#25 0x00007f9a60d9a3d6 in OrgKubuntuQaptworkerTransactionInterface::propertyChanged (this=this@entry=0x24992f0, _t1=3, _t2=...) at /build/buildd/qapt-2.0.65/obj-x86_64-linux-gnu/src/moc_transactiondbus.cxx:246
#26 0x00007f9a60d9a77c in OrgKubuntuQaptworkerTransactionInterface::qt_static_metacall (_o=_o@entry=0x24992f0, _c=_c@entry=QMetaObject::InvokeMetaMethod, _id=_id@entry=4, _a=_a@entry=0x7fff82adce50) at /build/buildd/qapt-2.0.65/obj-x86_64-linux-gnu/src/moc_transactiondbus.cxx:111
#27 0x00007f9a60d9b0f7 in OrgKubuntuQaptworkerTransactionInterface::qt_metacall (this=0x24992f0, _c=QMetaObject::InvokeMetaMethod, _id=4, _a=0x7fff82adce50) at /build/buildd/qapt-2.0.65/obj-x86_64-linux-gnu/src/moc_transactiondbus.cxx:164
#28 0x00007f9a7329ce36 in QDBusConnectionPrivate::deliverCall (this=0x88f3e0, object=0x24992f0, msg=..., metaTypes=..., slotIdx=9) at qdbusintegrator.cpp:951
#29 0x00007f9a74202dce in QObject::event (this=0x24992f0, e=<optimized out>) at kernel/qobject.cpp:1194
#30 0x00007f9a74bdbdfc in QApplicationPrivate::notify_helper (this=this@entry=0x68ce80, receiver=receiver@entry=0x24992f0, e=e@entry=0x24e4f30) at kernel/qapplication.cpp:4567
#31 0x00007f9a74be2470 in QApplication::notify (this=this@entry=0x7fff82add600, receiver=receiver@entry=0x24992f0, e=e@entry=0x24e4f30) at kernel/qapplication.cpp:4353
#32 0x00007f9a758e59aa in KApplication::notify (this=0x7fff82add600, receiver=0x24992f0, event=0x24e4f30) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x00007f9a741ea8bd in QCoreApplication::notifyInternal (this=0x7fff82add600, receiver=receiver@entry=0x24992f0, event=event@entry=0x24e4f30) at kernel/qcoreapplication.cpp:946
#34 0x00007f9a741ede1f in sendEvent (event=0x24e4f30, receiver=0x24992f0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#35 QCoreApplicationPrivate::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0x659500) at kernel/qcoreapplication.cpp:1570
#36 0x00007f9a741ee2c3 in QCoreApplication::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0) at kernel/qcoreapplication.cpp:1463
#37 0x00007f9a74218073 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#38 postEventSourceDispatch (s=0x67cfb0) at kernel/qeventdispatcher_glib.cpp:279
#39 0x00007f9a70e193c6 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#40 0x00007f9a70e19718 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#41 0x00007f9a70e197bc in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#42 0x00007f9a74c7d9d6 in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#43 0x00007f9a741e95ef in QEventLoop::processEvents (this=this@entry=0x7fff82add500, flags=...) at kernel/qeventloop.cpp:149
#44 0x00007f9a741e98e5 in QEventLoop::exec (this=this@entry=0x7fff82add500, flags=...) at kernel/qeventloop.cpp:204
#45 0x00007f9a741eee5b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1218
#46 0x00007f9a74bda34c in QApplication::exec () at kernel/qapplication.cpp:3828
#47 0x000000000040cdb1 in main (argc=5, argv=0x7fff82add738) at /build/buildd/muon-2.0.65/updater/main.cpp:59

Possible duplicates by query: bug 321818, bug 321758, bug 311441, bug 307621.

Reported using DrKonqi
Comment 1 Jekyll Wu 2013-09-26 21:30:01 UTC
*** Bug 321818 has been marked as a duplicate of this bug. ***
Comment 2 Jekyll Wu 2013-10-02 00:50:38 UTC
*** Bug 325525 has been marked as a duplicate of this bug. ***
Comment 3 Jekyll Wu 2013-10-19 10:16:54 UTC
*** Bug 326255 has been marked as a duplicate of this bug. ***
Comment 4 Jekyll Wu 2013-10-19 21:07:41 UTC
*** Bug 326263 has been marked as a duplicate of this bug. ***
Comment 5 Christoph Feck 2013-10-24 06:18:51 UTC
*** Bug 326537 has been marked as a duplicate of this bug. ***
Comment 6 Buddlespit 2013-11-06 23:33:10 UTC
Created attachment 83387 [details]
New crash information added by DrKonqi

muon-updater (2.1.0) on KDE Platform 4.11.2 using Qt 4.8.4

- What I was doing when the application crashed: I had tried to install updates. Updater crashes every time I click install.

-- Backtrace (Reduced):
#6  0x00007f1aea70ef77 in __GI_raise (sig=sig@entry=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:56
#7  0x00007f1aea7125e8 in __GI_abort () at abort.c:90
[...]
#11 0x00007f1aeae194ea in qt_assert_x (where=where@entry=0x7f1ad35570ac "QList<T>::at", what=what@entry=0x7f1ad355708a "index out of range", file=file@entry=0x7f1ad3556f70 "/usr/include/qt4/QtCore/qlist.h", line=line@entry=469) at global/qglobal.cpp:2029
#12 0x00007f1ad352605a in at (i=67208, this=0xdaea38) at /usr/include/qt4/QtCore/qlist.h:469
#13 QApt::Backend::stateChanges (this=<optimized out>, oldState=..., excluded=...) at /build/buildd/qapt-2.0.65/src/backend.cpp:754
Comment 7 Jekyll Wu 2013-11-22 06:06:58 UTC
*** Bug 327912 has been marked as a duplicate of this bug. ***
Comment 8 Jekyll Wu 2013-12-03 01:13:17 UTC
*** Bug 328347 has been marked as a duplicate of this bug. ***
Comment 9 p92 2013-12-15 11:46:59 UTC
Created attachment 84105 [details]
New crash information added by DrKonqi

muon-updater (2.1.1) on KDE Platform 4.11.2 using Qt 4.8.4

- What I was doing when the application crashed:
after adding a new recommanded software source uin advanced menu and closing advanced menu, muon start to refresh software updates and crashed
- Unusual behavior I noticed:

-- Backtrace (Reduced):
#6  0x00007f60c455bf77 in __GI_raise (sig=sig@entry=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:56
#7  0x00007f60c455f5e8 in __GI_abort () at abort.c:90
[...]
#11 0x00007f60c4c624ea in qt_assert_x (where=where@entry=0x7f60b193c0ac "QList<T>::at", what=what@entry=0x7f60b193c08a "index out of range", file=file@entry=0x7f60b193bf70 "/usr/include/qt4/QtCore/qlist.h", line=line@entry=469) at global/qglobal.cpp:2029
#12 0x00007f60b190b05a in at (i=67699, this=0xf77a18) at /usr/include/qt4/QtCore/qlist.h:469
#13 QApt::Backend::stateChanges (this=<optimized out>, oldState=..., excluded=...) at /build/buildd/qapt-2.0.65/src/backend.cpp:754
Comment 10 Jekyll Wu 2013-12-19 16:53:07 UTC
*** Bug 328995 has been marked as a duplicate of this bug. ***
Comment 11 Jekyll Wu 2014-01-03 03:44:08 UTC
*** Bug 329528 has been marked as a duplicate of this bug. ***
Comment 12 daniel 2014-01-03 09:42:43 UTC
Created attachment 84426 [details]
New crash information added by DrKonqi

muon-updater (2.1.2) on KDE Platform 4.12.0 using Qt 4.8.4

- What I was doing when the application crashed:
Hello
when updating software via the icon on the system tray: it crash at the end.
When I then run the Muon package manager, I get the message:
"can not mark updates. Some updates may present dependence impossible to satisfy for now or may have been prevented dependencies manually."
I compared the battery debug with KDEdif3: they are different.
Gest regards

-- Backtrace (Reduced):
#6  0x00007ff4955dff59 in __GI_raise (sig=sig@entry=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:56
#7  0x00007ff4955e3368 in __GI_abort () at abort.c:89
[...]
#11 0x00007ff495ce54ca in qt_assert_x (where=where@entry=0x7ff47ef9b0ac "QList<T>::at", what=what@entry=0x7ff47ef9b08a "index out of range", file=file@entry=0x7ff47ef9af70 "/usr/include/qt4/QtCore/qlist.h", line=line@entry=469) at global/qglobal.cpp:2029
#12 0x00007ff47ef6a05a in at (i=69445, this=0x22b4e98) at /usr/include/qt4/QtCore/qlist.h:469
#13 QApt::Backend::stateChanges (this=<optimized out>, oldState=..., excluded=...) at /build/buildd/qapt-2.0.65/src/backend.cpp:754
Comment 13 daniel 2014-01-03 09:46:34 UTC
Comment on attachment 84426 [details]
New crash information added by DrKonqi

when updating software via the icon on the system tray: it crash at the end.
When I then run the Muon package manager, I get the message:
"can not mark updates. Some updates may present impossible to satisfy for now or may have been prevented dependencies manually."
I compared the pile debug with KDEdif3: they are different.
Daniel
Comment 14 Ben 2014-01-04 10:14:20 UTC
Created attachment 84440 [details]
New crash information added by DrKonqi

muon-updater (2.1.2) on KDE Platform 4.12.0 using Qt 4.8.4

- What I was doing when the application crashed:

Refreshing Update Lists and picked new server

-- Backtrace (Reduced):
#6  0x00007fb8f9c91f59 in __GI_raise (sig=sig@entry=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:56
#7  0x00007fb8f9c95368 in __GI_abort () at abort.c:89
[...]
#11 0x00007fb8fa3974ca in qt_assert_x (where=where@entry=0x7fb8e8de10ac "QList<T>::at", what=what@entry=0x7fb8e8de108a "index out of range", file=file@entry=0x7fb8e8de0f70 "/usr/include/qt4/QtCore/qlist.h", line=line@entry=469) at global/qglobal.cpp:2029
#12 0x00007fb8e8db005a in at (i=69117, this=0xe6f928) at /usr/include/qt4/QtCore/qlist.h:469
#13 QApt::Backend::stateChanges (this=<optimized out>, oldState=..., excluded=...) at /build/buildd/qapt-2.0.65/src/backend.cpp:754
Comment 15 Jekyll Wu 2014-01-14 00:56:45 UTC
*** Bug 329935 has been marked as a duplicate of this bug. ***
Comment 16 Harald Sitter 2014-01-14 03:16:45 UTC
Crashes because of qapt/backend.cpp:
> (int i = 0; i < d->packages.size(); ++i)
does static iteration while d->packages can change because ApplicationBackend.cpp of muon uses it in a partially threaded manner (particularly init).

Related to bug #327406 which is also suffering from problems caused by the threaded init.
Comment 17 Jekyll Wu 2014-01-17 01:53:47 UTC
*** Bug 330054 has been marked as a duplicate of this bug. ***
Comment 18 Jekyll Wu 2014-01-26 01:36:26 UTC
*** Bug 330407 has been marked as a duplicate of this bug. ***
Comment 19 Jekyll Wu 2014-01-28 02:19:36 UTC
*** Bug 330486 has been marked as a duplicate of this bug. ***
Comment 20 Dan Mac 2014-01-30 12:59:48 UTC
Created attachment 84895 [details]
New crash information added by DrKonqi

muon-updater (2.1.2) on KDE Platform 4.12.1 using Qt 4.8.6

- What I was doing when the application crashed:

Updating repos via More -> Check for Updates.

After the crash, restarted Muon Update Manager, tried again and succeeded to update repos, however upon selecting all updates and installing, two updates still remain uninstalled. (Gwenview and Ubuntu One) According to /var/log/apt/history.log these were not requested to be updated, but I know for a fact they were already in the list and ticked. Restarting Muon and re-running Install Updates successfully updated these packages.

-- Backtrace (Reduced):
#8  0xb5f3f776 in __GI_raise (sig=sig@entry=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:56
#9  0xb5f42bc3 in __GI_abort () at abort.c:89
[...]
#13 0xb620771d in qt_assert_x (where=where@entry=0xb08dd89c "QList<T>::at", what=what@entry=0xb08dd87a "index out of range", file=file@entry=0xb08dd768 "/usr/include/qt4/QtCore/qlist.h", line=line@entry=469) at global/qglobal.cpp:2065
#14 0xb08a9c1b in at (i=44767, this=0xa090ec4) at /usr/include/qt4/QtCore/qlist.h:469
#15 QApt::Backend::stateChanges (this=0x9e78780, oldState=..., excluded=...) at /build/buildd/qapt-2.0.65/src/backend.cpp:754
Comment 21 Harald Sitter 2014-01-30 13:20:38 UTC
Just a quick headsup. We introduced a couple of changes the past few days that might just help resolve this crash. You should be able to expect a muon update for Kubuntu 13.10 sometime within the next two weeks.
Comment 22 Harald Sitter 2014-01-31 15:57:48 UTC
*** Bug 330615 has been marked as a duplicate of this bug. ***
Comment 23 Jekyll Wu 2014-02-11 00:55:47 UTC
*** Bug 330999 has been marked as a duplicate of this bug. ***
Comment 24 Jekyll Wu 2014-02-12 15:16:33 UTC
*** Bug 330999 has been marked as a duplicate of this bug. ***
Comment 25 Harald Sitter 2014-03-21 00:30:33 UTC
I am going to consider this fixed as we haven't seen a crash in over a month. Should you encounter the crash in versions greater than 2.1.3, please reopen this report or file a new one and refence this one.

Thanks.