Bug 329935 - Crash when update
Summary: Crash when update
Status: RESOLVED DUPLICATE of bug 325109
Alias: None
Product: Discover
Classification: Unclassified
Component: Updates (interactive) (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash
Target Milestone: ---
Assignee: Jonathan Thomas
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2014-01-13 22:08 UTC by Cristian M. Barbe
Modified: 2016-03-02 13:25 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Cristian M. Barbe 2014-01-13 22:08:38 UTC
Application: muon-updater (2.1.2)
KDE Platform Version: 4.12.0
Qt Version: 4.8.4
Operating System: Linux 3.13.0-1-generic x86_64
Distribution: Ubuntu Trusty Tahr (development branch)

-- Information about the crash:
- What I was doing when the application crashed:

Click on update for software and this crash on instant, posible duplicated.

The crash can be reproduced every time.

-- Backtrace:
Application: Gestor de actualizaciones Muon (muon-updater), signal: Aborted
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fa8449b67c0 (LWP 1750))]

Thread 3 (Thread 0x7fa833354700 (LWP 1751)):
#0  0x00007fff665fea1f in ?? ()
#1  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7fa8214a7700 (LWP 1808)):
#0  0x00007fa84200b65d in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007fa83f388cf4 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fa83f388dfc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fa8427906c6 in QEventDispatcherGlib::processEvents (this=0x7fa8140008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007fa84276227f in QEventLoop::processEvents (this=this@entry=0x7fa8214a6de0, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fa842762575 in QEventLoop::exec (this=this@entry=0x7fa8214a6de0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007fa84266185f in QThread::exec (this=this@entry=0x12f0a80) at thread/qthread.cpp:542
#7  0x00007fa842743ab3 in QInotifyFileSystemWatcherEngine::run (this=0x12f0a80) at io/qfilesystemwatcher_inotify.cpp:265
#8  0x00007fa842663eff in QThreadPrivate::start (arg=0x12f0a80) at thread/qthread_unix.cpp:338
#9  0x00007fa83f861182 in start_thread (arg=0x7fa8214a7700) at pthread_create.c:312
#10 0x00007fa842018a6d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 1 (Thread 0x7fa8449b67c0 (LWP 1750)):
[KCrash Handler]
#6  0x00007fa841f54f59 in __GI_raise (sig=sig@entry=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:56
#7  0x00007fa841f58368 in __GI_abort () at abort.c:89
#8  0x00007fa8426598f2 in qt_message_output (msgType=msgType@entry=QtFatalMsg, buf=0x2f548f8 "ASSERT failure in QList<T>::at: \"index out of range\", file /usr/include/qt4/QtCore/qlist.h, line 469") at global/qglobal.cpp:2347
#9  0x00007fa842659c59 in qt_message(QtMsgType, const char *, typedef __va_list_tag __va_list_tag *) (msgType=msgType@entry=QtFatalMsg, msg=msg@entry=0x7fa8427c4728 "ASSERT failure in %s: \"%s\", file %s, line %d", ap=ap@entry=0x7fff665abb68) at global/qglobal.cpp:2393
#10 0x00007fa84265a464 in qFatal (msg=msg@entry=0x7fa8427c4728 "ASSERT failure in %s: \"%s\", file %s, line %d") at global/qglobal.cpp:2576
#11 0x00007fa84265a4ca in qt_assert_x (where=where@entry=0x7fa830dd40ac "QList<T>::at", what=what@entry=0x7fa830dd408a "index out of range", file=file@entry=0x7fa830dd3f70 "/usr/include/qt4/QtCore/qlist.h", line=line@entry=469) at global/qglobal.cpp:2029
#12 0x00007fa830da305a in at (i=69170, this=0x131f038) at /usr/include/qt4/QtCore/qlist.h:469
#13 QApt::Backend::stateChanges (this=<optimized out>, oldState=..., excluded=...) at /build/buildd/qapt-2.0.65/src/backend.cpp:754
#14 0x00007fa831659f84 in ApplicationUpdates::calculateUpdates (this=this@entry=0x131f000) at /build/buildd/muon-2.1.2/libmuon/backends/ApplicationBackend/ApplicationUpdates.cpp:448
#15 0x00007fa83165a5e8 in ApplicationUpdates::fetchingChanged (this=0x131f000) at /build/buildd/muon-2.1.2/libmuon/backends/ApplicationBackend/ApplicationUpdates.cpp:441
#16 0x00007fa8427776d8 in QMetaObject::activate (sender=sender@entry=0x131ea10, m=m@entry=0x7fa8447c7180 <AbstractResourcesBackend::staticMetaObject>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x0) at kernel/qobject.cpp:3539
#17 0x00007fa8445a1040 in AbstractResourcesBackend::fetchingChanged (this=this@entry=0x131ea10) at /build/buildd/muon-2.1.2/obj-x86_64-linux-gnu/libmuon/moc_AbstractResourcesBackend.cpp:156
#18 0x00007fa83164be33 in ApplicationBackend::setFetching (this=0x131ea10, f=<optimized out>) at /build/buildd/muon-2.1.2/libmuon/backends/ApplicationBackend/ApplicationBackend.cpp:642
#19 0x00007fa83164e461 in ApplicationBackend::reload (this=0x131ea10) at /build/buildd/muon-2.1.2/libmuon/backends/ApplicationBackend/ApplicationBackend.cpp:175
#20 0x00007fa8316590c4 in ApplicationUpdates::transactionFinished (this=0x131f000) at /build/buildd/muon-2.1.2/libmuon/backends/ApplicationBackend/ApplicationUpdates.cpp:210
#21 0x00007fa8427776d8 in QMetaObject::activate (sender=0x2a2eb30, m=m@entry=0x7fa830fe59c0 <QApt::Transaction::staticMetaObject>, local_signal_index=local_signal_index@entry=8, argv=argv@entry=0x7fff665ac0b0) at kernel/qobject.cpp:3539
#22 0x00007fa830dd0441 in QApt::Transaction::finished (this=<optimized out>, _t1=QApt::ExitSuccess) at /build/buildd/qapt-2.0.65/obj-x86_64-linux-gnu/src/moc_transaction.cxx:338
#23 0x00007fa830dc31af in QApt::Transaction::updateProperty (this=0x2a2eb30, type=1750, variant=...) at /build/buildd/qapt-2.0.65/src/transaction.cpp:546
#24 0x00007fa830dd0974 in QApt::Transaction::qt_static_metacall (_o=0x2a2eb30, _c=<optimized out>, _id=<optimized out>, _a=0x7fff665ac2d0) at /build/buildd/qapt-2.0.65/obj-x86_64-linux-gnu/src/moc_transaction.cxx:164
#25 0x00007fa8427776d8 in QMetaObject::activate (sender=sender@entry=0x2a27180, m=m@entry=0x7fa830fe5aa0 <OrgKubuntuQaptworkerTransactionInterface::staticMetaObject>, local_signal_index=local_signal_index@entry=4, argv=argv@entry=0x7fff665ac2d0) at kernel/qobject.cpp:3539
#26 0x00007fa830dd13d6 in OrgKubuntuQaptworkerTransactionInterface::propertyChanged (this=this@entry=0x2a27180, _t1=11, _t2=...) at /build/buildd/qapt-2.0.65/obj-x86_64-linux-gnu/src/moc_transactiondbus.cxx:246
#27 0x00007fa830dd177c in OrgKubuntuQaptworkerTransactionInterface::qt_static_metacall (_o=_o@entry=0x2a27180, _c=_c@entry=QMetaObject::InvokeMetaMethod, _id=_id@entry=4, _a=_a@entry=0x7fff665ac590) at /build/buildd/qapt-2.0.65/obj-x86_64-linux-gnu/src/moc_transactiondbus.cxx:111
#28 0x00007fa830dd20f7 in OrgKubuntuQaptworkerTransactionInterface::qt_metacall (this=0x2a27180, _c=QMetaObject::InvokeMetaMethod, _id=4, _a=0x7fff665ac590) at /build/buildd/qapt-2.0.65/obj-x86_64-linux-gnu/src/moc_transactiondbus.cxx:164
#29 0x00007fa84180ae26 in QDBusConnectionPrivate::deliverCall (this=0x1061640, object=0x2a27180, msg=..., metaTypes=..., slotIdx=9) at qdbusintegrator.cpp:951
#30 0x00007fa84277ba3e in QObject::event (this=0x2a27180, e=<optimized out>) at kernel/qobject.cpp:1194
#31 0x00007fa843154dac in QApplicationPrivate::notify_helper (this=this@entry=0xe01930, receiver=receiver@entry=0x2a27180, e=e@entry=0x2b9c010) at kernel/qapplication.cpp:4567
#32 0x00007fa84315b420 in QApplication::notify (this=this@entry=0x7fff665acd30, receiver=receiver@entry=0x2a27180, e=e@entry=0x2b9c010) at kernel/qapplication.cpp:4353
#33 0x00007fa843e5ea8a in KApplication::notify (this=0x7fff665acd30, receiver=0x2a27180, event=0x2b9c010) at ../../kdeui/kernel/kapplication.cpp:311
#34 0x00007fa84276354d in QCoreApplication::notifyInternal (this=0x7fff665acd30, receiver=receiver@entry=0x2a27180, event=event@entry=0x2b9c010) at kernel/qcoreapplication.cpp:946
#35 0x00007fa842766a9d in sendEvent (event=0x2b9c010, receiver=0x2a27180) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#36 QCoreApplicationPrivate::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0xdd6500) at kernel/qcoreapplication.cpp:1570
#37 0x00007fa842766f43 in QCoreApplication::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0) at kernel/qcoreapplication.cpp:1463
#38 0x00007fa842790cc3 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#39 postEventSourceDispatch (s=0xe006f0) at kernel/qeventdispatcher_glib.cpp:279
#40 0x00007fa83f388b14 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#41 0x00007fa83f388d58 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#42 0x00007fa83f388dfc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#43 0x00007fa8427906a5 in QEventDispatcherGlib::processEvents (this=0xdd7de0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#44 0x00007fa8431f68c6 in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#45 0x00007fa84276227f in QEventLoop::processEvents (this=this@entry=0x7fff665acc30, flags=...) at kernel/qeventloop.cpp:149
#46 0x00007fa842762575 in QEventLoop::exec (this=this@entry=0x7fff665acc30, flags=...) at kernel/qeventloop.cpp:204
#47 0x00007fa842767ad9 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1218
#48 0x00007fa8431532fc in QApplication::exec () at kernel/qapplication.cpp:3828
#49 0x000000000040ce11 in main (argc=5, argv=0x7fff665ace68) at /build/buildd/muon-2.1.2/updater/main.cpp:59

The reporter indicates this bug may be a duplicate of or related to bug 325109.

Possible duplicates by query: bug 329528, bug 328995, bug 328347, bug 327912, bug 327104.

Reported using DrKonqi
Comment 1 Jekyll Wu 2014-01-14 00:56:45 UTC

*** This bug has been marked as a duplicate of bug 325109 ***