Bug 328347 - muon crash checking for updates
Summary: muon crash checking for updates
Status: RESOLVED DUPLICATE of bug 325109
Alias: None
Product: Discover
Classification: Unclassified
Component: Updates (interactive) (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash
Target Milestone: ---
Assignee: Jonathan Thomas
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2013-12-03 00:40 UTC by diehard67
Modified: 2016-03-02 13:27 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description diehard67 2013-12-03 00:40:42 UTC
Application: muon-updater (2.1.1)
KDE Platform Version: 4.11.2
Qt Version: 4.8.4
Operating System: Linux 3.11.0-13-generic x86_64
Distribution: Ubuntu 13.10

-- Information about the crash:
- What I was doing when the application crashed:
I told muon to check for updates to be sure I was getting all of the new stuff and it crashed, worked fine after restarting it though.

-- Backtrace:
Application: Muon Update Manager (muon-updater), signal: Aborted
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f89146667c0 (LWP 13522))]

Thread 4 (Thread 0x7f88ffa48700 (LWP 13527)):
#0  0x00007f8911cd4f7d in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f890f0616a4 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f890f061b0a in g_main_loop_run () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f890656bb66 in ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
#4  0x00007f890f0860f5 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f890f539f6e in start_thread (arg=0x7f88ffa48700) at pthread_create.c:311
#6  0x00007f8911ce19cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 3 (Thread 0x7f88ff247700 (LWP 13528)):
#0  0x00007f890f53d05f in __pthread_mutex_unlock_usercnt (mutex=0x8f6820, decr=<optimized out>) at pthread_mutex_unlock.c:52
#1  0x00007f890f0a13d1 in g_mutex_unlock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f890f060830 in g_main_context_acquire () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f890f061565 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f890f0617ac in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f890f0617f9 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#6  0x00007f890f0860f5 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#7  0x00007f890f539f6e in start_thread (arg=0x7f88ff247700) at pthread_create.c:311
#8  0x00007f8911ce19cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 2 (Thread 0x7f88f48be700 (LWP 13529)):
#0  0x00007f890f060e2b in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f890f0615c3 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f890f0617ac in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f891245aa76 in QEventDispatcherGlib::processEvents (this=0x7f88ec0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f891242c5ef in QEventLoop::processEvents (this=this@entry=0x7f88f48bdd70, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f891242c8e5 in QEventLoop::exec (this=this@entry=0x7f88f48bdd70, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f891232b88f in QThread::exec (this=this@entry=0xbe7f00) at thread/qthread.cpp:542
#7  0x00007f891240dd13 in QInotifyFileSystemWatcherEngine::run (this=0xbe7f00) at io/qfilesystemwatcher_inotify.cpp:265
#8  0x00007f891232df2f in QThreadPrivate::start (arg=0xbe7f00) at thread/qthread_unix.cpp:338
#9  0x00007f890f539f6e in start_thread (arg=0x7f88f48be700) at pthread_create.c:311
#10 0x00007f8911ce19cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 1 (Thread 0x7f89146667c0 (LWP 13522)):
[KCrash Handler]
#6  0x00007f8911c1df77 in __GI_raise (sig=sig@entry=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:56
#7  0x00007f8911c215e8 in __GI_abort () at abort.c:90
#8  0x00007f8912323912 in qt_message_output (msgType=msgType@entry=QtFatalMsg, buf=0x311dd68 "ASSERT failure in QList<T>::at: \"index out of range\", file /usr/include/qt4/QtCore/qlist.h, line 469") at global/qglobal.cpp:2347
#9  0x00007f8912323c79 in qt_message(QtMsgType, const char *, typedef __va_list_tag __va_list_tag *) (msgType=msgType@entry=QtFatalMsg, msg=msg@entry=0x7f891248eaa8 "ASSERT failure in %s: \"%s\", file %s, line %d", ap=ap@entry=0x7fff9dce3488) at global/qglobal.cpp:2393
#10 0x00007f8912324484 in qFatal (msg=msg@entry=0x7f891248eaa8 "ASSERT failure in %s: \"%s\", file %s, line %d") at global/qglobal.cpp:2576
#11 0x00007f89123244ea in qt_assert_x (where=where@entry=0x7f88eb2450ac "QList<T>::at", what=what@entry=0x7f88eb24508a "index out of range", file=file@entry=0x7f88eb244f70 "/usr/include/qt4/QtCore/qlist.h", line=line@entry=469) at global/qglobal.cpp:2029
#12 0x00007f88eb21405a in at (i=67587, this=0xbb5f58) at /usr/include/qt4/QtCore/qlist.h:469
#13 QApt::Backend::stateChanges (this=<optimized out>, oldState=..., excluded=...) at /build/buildd/qapt-2.0.65/src/backend.cpp:754
#14 0x00007f88ebacb014 in ApplicationUpdates::calculateUpdates (this=this@entry=0xbb5f20) at /build/buildd/muon-2.1.1/libmuon/backends/ApplicationBackend/ApplicationUpdates.cpp:448
#15 0x00007f88ebacb668 in ApplicationUpdates::fetchingChanged (this=0xbb5f20) at /build/buildd/muon-2.1.1/libmuon/backends/ApplicationBackend/ApplicationUpdates.cpp:441
#16 0x00007f8912441a58 in QMetaObject::activate (sender=sender@entry=0xfa6c60, m=m@entry=0x7f89144913c0 <AbstractResourcesBackend::staticMetaObject>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x0) at kernel/qobject.cpp:3539
#17 0x00007f891426a940 in AbstractResourcesBackend::fetchingChanged (this=this@entry=0xfa6c60) at /build/buildd/muon-2.1.1/obj-x86_64-linux-gnu/libmuon/moc_AbstractResourcesBackend.cpp:156
#18 0x00007f88ebabce93 in ApplicationBackend::setFetching (this=0xfa6c60, f=<optimized out>) at /build/buildd/muon-2.1.1/libmuon/backends/ApplicationBackend/ApplicationBackend.cpp:643
#19 0x00007f88ebabf4c3 in ApplicationBackend::reload (this=0xfa6c60) at /build/buildd/muon-2.1.1/libmuon/backends/ApplicationBackend/ApplicationBackend.cpp:175
#20 0x00007f88ebaca154 in ApplicationUpdates::transactionFinished (this=0xbb5f20) at /build/buildd/muon-2.1.1/libmuon/backends/ApplicationBackend/ApplicationUpdates.cpp:210
#21 0x00007f8912441a58 in QMetaObject::activate (sender=0x25f8770, m=m@entry=0x7f88eb4569c0 <QApt::Transaction::staticMetaObject>, local_signal_index=local_signal_index@entry=8, argv=argv@entry=0x7fff9dce39d0) at kernel/qobject.cpp:3539
#22 0x00007f88eb241441 in QApt::Transaction::finished (this=<optimized out>, _t1=QApt::ExitSuccess) at /build/buildd/qapt-2.0.65/obj-x86_64-linux-gnu/src/moc_transaction.cxx:338
#23 0x00007f88eb2341af in QApt::Transaction::updateProperty (this=0x25f8770, type=13522, variant=...) at /build/buildd/qapt-2.0.65/src/transaction.cpp:546
#24 0x00007f88eb241974 in QApt::Transaction::qt_static_metacall (_o=0x25f8770, _c=<optimized out>, _id=<optimized out>, _a=0x7fff9dce3bf0) at /build/buildd/qapt-2.0.65/obj-x86_64-linux-gnu/src/moc_transaction.cxx:164
#25 0x00007f8912441a58 in QMetaObject::activate (sender=sender@entry=0x264ce60, m=m@entry=0x7f88eb456aa0 <OrgKubuntuQaptworkerTransactionInterface::staticMetaObject>, local_signal_index=local_signal_index@entry=4, argv=argv@entry=0x7fff9dce3bf0) at kernel/qobject.cpp:3539
#26 0x00007f88eb2423d6 in OrgKubuntuQaptworkerTransactionInterface::propertyChanged (this=this@entry=0x264ce60, _t1=11, _t2=...) at /build/buildd/qapt-2.0.65/obj-x86_64-linux-gnu/src/moc_transactiondbus.cxx:246
#27 0x00007f88eb24277c in OrgKubuntuQaptworkerTransactionInterface::qt_static_metacall (_o=_o@entry=0x264ce60, _c=_c@entry=QMetaObject::InvokeMetaMethod, _id=_id@entry=4, _a=_a@entry=0x7fff9dce3eb0) at /build/buildd/qapt-2.0.65/obj-x86_64-linux-gnu/src/moc_transactiondbus.cxx:111
#28 0x00007f88eb2430f7 in OrgKubuntuQaptworkerTransactionInterface::qt_metacall (this=0x264ce60, _c=QMetaObject::InvokeMetaMethod, _id=4, _a=0x7fff9dce3eb0) at /build/buildd/qapt-2.0.65/obj-x86_64-linux-gnu/src/moc_transactiondbus.cxx:164
#29 0x00007f89114dee36 in QDBusConnectionPrivate::deliverCall (this=0xbfc300, object=0x264ce60, msg=..., metaTypes=..., slotIdx=9) at qdbusintegrator.cpp:951
#30 0x00007f8912445dce in QObject::event (this=0x264ce60, e=<optimized out>) at kernel/qobject.cpp:1194
#31 0x00007f8912e1edfc in QApplicationPrivate::notify_helper (this=this@entry=0x8024b0, receiver=receiver@entry=0x264ce60, e=e@entry=0xfa6d10) at kernel/qapplication.cpp:4567
#32 0x00007f8912e25470 in QApplication::notify (this=this@entry=0x7fff9dce4660, receiver=receiver@entry=0x264ce60, e=e@entry=0xfa6d10) at kernel/qapplication.cpp:4353
#33 0x00007f8913b28a6a in KApplication::notify (this=0x7fff9dce4660, receiver=0x264ce60, event=0xfa6d10) at ../../kdeui/kernel/kapplication.cpp:311
#34 0x00007f891242d8bd in QCoreApplication::notifyInternal (this=0x7fff9dce4660, receiver=receiver@entry=0x264ce60, event=event@entry=0xfa6d10) at kernel/qcoreapplication.cpp:946
#35 0x00007f8912430e1f in sendEvent (event=0xfa6d10, receiver=0x264ce60) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#36 QCoreApplicationPrivate::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0x7d3500) at kernel/qcoreapplication.cpp:1570
#37 0x00007f89124312c3 in QCoreApplication::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0) at kernel/qcoreapplication.cpp:1463
#38 0x00007f891245b073 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#39 postEventSourceDispatch (s=0x812540) at kernel/qeventdispatcher_glib.cpp:279
#40 0x00007f890f0613b6 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#41 0x00007f890f061708 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#42 0x00007f890f0617ac in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#43 0x00007f891245aa55 in QEventDispatcherGlib::processEvents (this=0x7d4de0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#44 0x00007f8912ec09d6 in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#45 0x00007f891242c5ef in QEventLoop::processEvents (this=this@entry=0x7fff9dce4560, flags=...) at kernel/qeventloop.cpp:149
#46 0x00007f891242c8e5 in QEventLoop::exec (this=this@entry=0x7fff9dce4560, flags=...) at kernel/qeventloop.cpp:204
#47 0x00007f8912431e5b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1218
#48 0x00007f8912e1d34c in QApplication::exec () at kernel/qapplication.cpp:3828
#49 0x000000000040ce11 in main (argc=5, argv=0x7fff9dce4798) at /build/buildd/muon-2.1.1/updater/main.cpp:59

The reporter indicates this bug may be a duplicate of or related to bug 325109.

Possible duplicates by query: bug 327912, bug 327104, bug 327032, bug 326774, bug 326770.

Reported using DrKonqi
Comment 1 Jekyll Wu 2013-12-03 01:13:17 UTC

*** This bug has been marked as a duplicate of bug 325109 ***