Bug 327912 - Muon Crashed while checking for update.
Summary: Muon Crashed while checking for update.
Status: RESOLVED DUPLICATE of bug 325109
Alias: None
Product: Discover
Classification: Unclassified
Component: Updates (interactive) (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash
Target Milestone: ---
Assignee: Jonathan Thomas
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2013-11-21 18:03 UTC by AV
Modified: 2016-03-02 13:26 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description AV 2013-11-21 18:03:33 UTC
Application: muon-updater (2.1.1)
KDE Platform Version: 4.11.2
Qt Version: 4.8.4
Operating System: Linux 3.11.0-14-generic x86_64
Distribution: Ubuntu 13.10

-- Information about the crash:
I clicked on "Check For update (Ctrl+R)". Then it started to download and after a while it crashed. It never showed the list of updates.

The crash can be reproduced sometimes.

-- Backtrace:
Application: Muon Update Manager (muon-updater), signal: Aborted
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fd3597dc7c0 (LWP 14259))]

Thread 3 (Thread 0x7fd3467a8700 (LWP 14260)):
#0  __GI___pthread_mutex_lock (mutex=0x7fd340000a60) at pthread_mutex_lock.c:57
#1  0x00007fd3542103a1 in g_mutex_lock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fd3541cfd59 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fd3541d05c3 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007fd3541d07ac in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007fd3575c9a76 in QEventDispatcherGlib::processEvents (this=0x7fd3400008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x00007fd35759b5ef in QEventLoop::processEvents (this=this@entry=0x7fd3467a7d70, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007fd35759b8e5 in QEventLoop::exec (this=this@entry=0x7fd3467a7d70, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007fd35749a88f in QThread::exec (this=this@entry=0xc8aa70) at thread/qthread.cpp:542
#9  0x00007fd35757cd13 in QInotifyFileSystemWatcherEngine::run (this=0xc8aa70) at io/qfilesystemwatcher_inotify.cpp:265
#10 0x00007fd35749cf2f in QThreadPrivate::start (arg=0xc8aa70) at thread/qthread_unix.cpp:338
#11 0x00007fd3546a8f6e in start_thread (arg=0x7fd3467a8700) at pthread_create.c:311
#12 0x00007fd356e509cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 2 (Thread 0x7fd33cad0700 (LWP 14307)):
#0  0x00007fd3542100ed in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007fd3542103c9 in g_mutex_unlock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fd3541d0119 in g_main_context_check () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fd3541d063b in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007fd3541d07ac in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007fd3575c9a76 in QEventDispatcherGlib::processEvents (this=0x7fd3280008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x00007fd35759b5ef in QEventLoop::processEvents (this=this@entry=0x7fd33cacfd70, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007fd35759b8e5 in QEventLoop::exec (this=this@entry=0x7fd33cacfd70, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007fd35749a88f in QThread::exec (this=this@entry=0x113e070) at thread/qthread.cpp:542
#9  0x00007fd35757cd13 in QInotifyFileSystemWatcherEngine::run (this=0x113e070) at io/qfilesystemwatcher_inotify.cpp:265
#10 0x00007fd35749cf2f in QThreadPrivate::start (arg=0x113e070) at thread/qthread_unix.cpp:338
#11 0x00007fd3546a8f6e in start_thread (arg=0x7fd33cad0700) at pthread_create.c:311
#12 0x00007fd356e509cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 1 (Thread 0x7fd3597dc7c0 (LWP 14259)):
[KCrash Handler]
#6  0x00007fd356d8cf77 in __GI_raise (sig=sig@entry=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:56
#7  0x00007fd356d905e8 in __GI_abort () at abort.c:90
#8  0x00007fd357492912 in qt_message_output (msgType=msgType@entry=QtFatalMsg, buf=0x30d0f58 "ASSERT failure in QList<T>::at: \"index out of range\", file /usr/include/qt4/QtCore/qlist.h, line 469") at global/qglobal.cpp:2347
#9  0x00007fd357492c79 in qt_message(QtMsgType, const char *, typedef __va_list_tag __va_list_tag *) (msgType=msgType@entry=QtFatalMsg, msg=msg@entry=0x7fd3575fdaa8 "ASSERT failure in %s: \"%s\", file %s, line %d", ap=ap@entry=0x7fffce679ea8) at global/qglobal.cpp:2393
#10 0x00007fd357493484 in qFatal (msg=msg@entry=0x7fd3575fdaa8 "ASSERT failure in %s: \"%s\", file %s, line %d") at global/qglobal.cpp:2576
#11 0x00007fd3574934ea in qt_assert_x (where=where@entry=0x7fd3441e10ac "QList<T>::at", what=what@entry=0x7fd3441e108a "index out of range", file=file@entry=0x7fd3441e0f70 "/usr/include/qt4/QtCore/qlist.h", line=line@entry=469) at global/qglobal.cpp:2029
#12 0x00007fd3441b005a in at (i=67411, this=0xf8f8f8) at /usr/include/qt4/QtCore/qlist.h:469
#13 QApt::Backend::stateChanges (this=<optimized out>, oldState=..., excluded=...) at /build/buildd/qapt-2.0.65/src/backend.cpp:754
#14 0x00007fd344a67014 in ApplicationUpdates::calculateUpdates (this=this@entry=0xf8f8c0) at /build/buildd/muon-2.1.1/libmuon/backends/ApplicationBackend/ApplicationUpdates.cpp:448
#15 0x00007fd344a67668 in ApplicationUpdates::fetchingChanged (this=0xf8f8c0) at /build/buildd/muon-2.1.1/libmuon/backends/ApplicationBackend/ApplicationUpdates.cpp:441
#16 0x00007fd3575b0a58 in QMetaObject::activate (sender=sender@entry=0xf8f390, m=m@entry=0x7fd3596003c0 <AbstractResourcesBackend::staticMetaObject>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x0) at kernel/qobject.cpp:3539
#17 0x00007fd3593d9940 in AbstractResourcesBackend::fetchingChanged (this=this@entry=0xf8f390) at /build/buildd/muon-2.1.1/obj-x86_64-linux-gnu/libmuon/moc_AbstractResourcesBackend.cpp:156
#18 0x00007fd344a58e93 in ApplicationBackend::setFetching (this=0xf8f390, f=<optimized out>) at /build/buildd/muon-2.1.1/libmuon/backends/ApplicationBackend/ApplicationBackend.cpp:643
#19 0x00007fd344a5b4c3 in ApplicationBackend::reload (this=0xf8f390) at /build/buildd/muon-2.1.1/libmuon/backends/ApplicationBackend/ApplicationBackend.cpp:175
#20 0x00007fd344a66154 in ApplicationUpdates::transactionFinished (this=0xf8f8c0) at /build/buildd/muon-2.1.1/libmuon/backends/ApplicationBackend/ApplicationUpdates.cpp:210
#21 0x00007fd3575b0a58 in QMetaObject::activate (sender=0x2155630, m=m@entry=0x7fd3443f29c0 <QApt::Transaction::staticMetaObject>, local_signal_index=local_signal_index@entry=8, argv=argv@entry=0x7fffce67a3f0) at kernel/qobject.cpp:3539
#22 0x00007fd3441dd441 in QApt::Transaction::finished (this=<optimized out>, _t1=QApt::ExitSuccess) at /build/buildd/qapt-2.0.65/obj-x86_64-linux-gnu/src/moc_transaction.cxx:338
#23 0x00007fd3441d01af in QApt::Transaction::updateProperty (this=0x2155630, type=14259, variant=...) at /build/buildd/qapt-2.0.65/src/transaction.cpp:546
#24 0x00007fd3441dd974 in QApt::Transaction::qt_static_metacall (_o=0x2155630, _c=<optimized out>, _id=<optimized out>, _a=0x7fffce67a610) at /build/buildd/qapt-2.0.65/obj-x86_64-linux-gnu/src/moc_transaction.cxx:164
#25 0x00007fd3575b0a58 in QMetaObject::activate (sender=sender@entry=0x27be6a0, m=m@entry=0x7fd3443f2aa0 <OrgKubuntuQaptworkerTransactionInterface::staticMetaObject>, local_signal_index=local_signal_index@entry=4, argv=argv@entry=0x7fffce67a610) at kernel/qobject.cpp:3539
#26 0x00007fd3441de3d6 in OrgKubuntuQaptworkerTransactionInterface::propertyChanged (this=this@entry=0x27be6a0, _t1=11, _t2=...) at /build/buildd/qapt-2.0.65/obj-x86_64-linux-gnu/src/moc_transactiondbus.cxx:246
#27 0x00007fd3441de77c in OrgKubuntuQaptworkerTransactionInterface::qt_static_metacall (_o=_o@entry=0x27be6a0, _c=_c@entry=QMetaObject::InvokeMetaMethod, _id=_id@entry=4, _a=_a@entry=0x7fffce67a8d0) at /build/buildd/qapt-2.0.65/obj-x86_64-linux-gnu/src/moc_transactiondbus.cxx:111
#28 0x00007fd3441df0f7 in OrgKubuntuQaptworkerTransactionInterface::qt_metacall (this=0x27be6a0, _c=QMetaObject::InvokeMetaMethod, _id=4, _a=0x7fffce67a8d0) at /build/buildd/qapt-2.0.65/obj-x86_64-linux-gnu/src/moc_transactiondbus.cxx:164
#29 0x00007fd35664de36 in QDBusConnectionPrivate::deliverCall (this=0xcc7780, object=0x27be6a0, msg=..., metaTypes=..., slotIdx=9) at qdbusintegrator.cpp:951
#30 0x00007fd3575b4dce in QObject::event (this=0x27be6a0, e=<optimized out>) at kernel/qobject.cpp:1194
#31 0x00007fd357f8ddfc in QApplicationPrivate::notify_helper (this=this@entry=0xa55480, receiver=receiver@entry=0x27be6a0, e=e@entry=0xc91d60) at kernel/qapplication.cpp:4567
#32 0x00007fd357f94470 in QApplication::notify (this=this@entry=0x7fffce67b080, receiver=receiver@entry=0x27be6a0, e=e@entry=0xc91d60) at kernel/qapplication.cpp:4353
#33 0x00007fd358c97a6a in KApplication::notify (this=0x7fffce67b080, receiver=0x27be6a0, event=0xc91d60) at ../../kdeui/kernel/kapplication.cpp:311
#34 0x00007fd35759c8bd in QCoreApplication::notifyInternal (this=0x7fffce67b080, receiver=receiver@entry=0x27be6a0, event=event@entry=0xc91d60) at kernel/qcoreapplication.cpp:946
#35 0x00007fd35759fe1f in sendEvent (event=0xc91d60, receiver=0x27be6a0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#36 QCoreApplicationPrivate::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0xa22500) at kernel/qcoreapplication.cpp:1570
#37 0x00007fd3575a02c3 in QCoreApplication::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0) at kernel/qcoreapplication.cpp:1463
#38 0x00007fd3575ca073 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#39 postEventSourceDispatch (s=0xa4d3d0) at kernel/qeventdispatcher_glib.cpp:279
#40 0x00007fd3541d03b6 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#41 0x00007fd3541d0708 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#42 0x00007fd3541d07ac in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#43 0x00007fd3575c9a55 in QEventDispatcherGlib::processEvents (this=0xa23de0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#44 0x00007fd35802f9d6 in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#45 0x00007fd35759b5ef in QEventLoop::processEvents (this=this@entry=0x7fffce67af80, flags=...) at kernel/qeventloop.cpp:149
#46 0x00007fd35759b8e5 in QEventLoop::exec (this=this@entry=0x7fffce67af80, flags=...) at kernel/qeventloop.cpp:204
#47 0x00007fd3575a0e5b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1218
#48 0x00007fd357f8c34c in QApplication::exec () at kernel/qapplication.cpp:3828
#49 0x000000000040ce11 in main (argc=1, argv=0x7fffce67b1b8) at /build/buildd/muon-2.1.1/updater/main.cpp:59

The reporter indicates this bug may be a duplicate of or related to bug 325109.

Possible duplicates by query: bug 327104, bug 327032, bug 326774, bug 326770, bug 326754.

Reported using DrKonqi
Comment 1 Jekyll Wu 2013-11-22 06:06:58 UTC

*** This bug has been marked as a duplicate of bug 325109 ***