Bug 329528 - Muon update crash while checking for updates
Summary: Muon update crash while checking for updates
Status: RESOLVED DUPLICATE of bug 325109
Alias: None
Product: Discover
Classification: Unclassified
Component: Updates (interactive) (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash
Target Milestone: ---
Assignee: Jonathan Thomas
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2014-01-02 13:26 UTC by stevano2
Modified: 2016-03-02 13:25 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description stevano2 2014-01-02 13:26:31 UTC
Application: muon-updater (2.1.1)
KDE Platform Version: 4.11.3
Qt Version: 4.8.4
Operating System: Linux 3.11.0-13-generic x86_64
Distribution: Ubuntu 13.10

-- Information about the crash:
- What I was doing when the application crashed:

I started Muon updater and used Ctrl+R to check for new updates. While loading the update list, Muon updater crashed. No other programs were running at the time.

The crash can be reproduced sometimes.

-- Backtrace:
Application: Muon Update Manager (muon-updater), signal: Aborted
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f5e784427c0 (LWP 1972))]

Thread 3 (Thread 0x7f5e6542a700 (LWP 1973)):
#0  0x00007f5e75a93f7d in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f5e72e1e6a4 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f5e72e1e7ac in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f5e76219a76 in QEventDispatcherGlib::processEvents (this=0x7f5e600008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f5e761eb5ef in QEventLoop::processEvents (this=this@entry=0x7f5e65429d70, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f5e761eb8e5 in QEventLoop::exec (this=this@entry=0x7f5e65429d70, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f5e760ea88f in QThread::exec (this=this@entry=0x118a640) at thread/qthread.cpp:542
#7  0x00007f5e761ccd13 in QInotifyFileSystemWatcherEngine::run (this=0x118a640) at io/qfilesystemwatcher_inotify.cpp:265
#8  0x00007f5e760ecf2f in QThreadPrivate::start (arg=0x118a640) at thread/qthread_unix.cpp:338
#9  0x00007f5e732f6f6e in start_thread (arg=0x7f5e6542a700) at pthread_create.c:311
#10 0x00007f5e75aa09cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 2 (Thread 0x7f5e553da700 (LWP 2041)):
#0  0x00007f5e72e5e0ea in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f5e72e5e399 in g_mutex_lock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f5e72e1dd59 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f5e72e1e5c3 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f5e72e1e7ac in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f5e76219a76 in QEventDispatcherGlib::processEvents (this=0x7f5e480008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x00007f5e761eb5ef in QEventLoop::processEvents (this=this@entry=0x7f5e553d9d70, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007f5e761eb8e5 in QEventLoop::exec (this=this@entry=0x7f5e553d9d70, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007f5e760ea88f in QThread::exec (this=this@entry=0x1470790) at thread/qthread.cpp:542
#9  0x00007f5e761ccd13 in QInotifyFileSystemWatcherEngine::run (this=0x1470790) at io/qfilesystemwatcher_inotify.cpp:265
#10 0x00007f5e760ecf2f in QThreadPrivate::start (arg=0x1470790) at thread/qthread_unix.cpp:338
#11 0x00007f5e732f6f6e in start_thread (arg=0x7f5e553da700) at pthread_create.c:311
#12 0x00007f5e75aa09cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 1 (Thread 0x7f5e784427c0 (LWP 1972)):
[KCrash Handler]
#6  0x00007f5e759dcf77 in __GI_raise (sig=sig@entry=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:56
#7  0x00007f5e759e05e8 in __GI_abort () at abort.c:90
#8  0x00007f5e760e2912 in qt_message_output (msgType=msgType@entry=QtFatalMsg, buf=0x35b0a88 "ASSERT failure in QList<T>::at: \"index out of range\", file /usr/include/qt4/QtCore/qlist.h, line 469") at global/qglobal.cpp:2347
#9  0x00007f5e760e2c79 in qt_message(QtMsgType, const char *, typedef __va_list_tag __va_list_tag *) (msgType=msgType@entry=QtFatalMsg, msg=msg@entry=0x7f5e7624daa8 "ASSERT failure in %s: \"%s\", file %s, line %d", ap=ap@entry=0x7fff360adcb8) at global/qglobal.cpp:2393
#10 0x00007f5e760e3484 in qFatal (msg=msg@entry=0x7f5e7624daa8 "ASSERT failure in %s: \"%s\", file %s, line %d") at global/qglobal.cpp:2576
#11 0x00007f5e760e34ea in qt_assert_x (where=where@entry=0x7f5e5ed640ac "QList<T>::at", what=what@entry=0x7f5e5ed6408a "index out of range", file=file@entry=0x7f5e5ed63f70 "/usr/include/qt4/QtCore/qlist.h", line=line@entry=469) at global/qglobal.cpp:2029
#12 0x00007f5e5ed3305a in at (i=67136, this=0x1489998) at /usr/include/qt4/QtCore/qlist.h:469
#13 QApt::Backend::stateChanges (this=<optimized out>, oldState=..., excluded=...) at /build/buildd/qapt-2.0.65/src/backend.cpp:754
#14 0x00007f5e5f5ea014 in ApplicationUpdates::calculateUpdates (this=this@entry=0x1489960) at /build/buildd/muon-2.1.1/libmuon/backends/ApplicationBackend/ApplicationUpdates.cpp:448
#15 0x00007f5e5f5ea668 in ApplicationUpdates::fetchingChanged (this=0x1489960) at /build/buildd/muon-2.1.1/libmuon/backends/ApplicationBackend/ApplicationUpdates.cpp:441
#16 0x00007f5e76200a58 in QMetaObject::activate (sender=sender@entry=0x1488990, m=m@entry=0x7f5e782503c0 <AbstractResourcesBackend::staticMetaObject>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x0) at kernel/qobject.cpp:3539
#17 0x00007f5e78029940 in AbstractResourcesBackend::fetchingChanged (this=this@entry=0x1488990) at /build/buildd/muon-2.1.1/obj-x86_64-linux-gnu/libmuon/moc_AbstractResourcesBackend.cpp:156
#18 0x00007f5e5f5dbe93 in ApplicationBackend::setFetching (this=0x1488990, f=<optimized out>) at /build/buildd/muon-2.1.1/libmuon/backends/ApplicationBackend/ApplicationBackend.cpp:643
#19 0x00007f5e5f5de4c3 in ApplicationBackend::reload (this=0x1488990) at /build/buildd/muon-2.1.1/libmuon/backends/ApplicationBackend/ApplicationBackend.cpp:175
#20 0x00007f5e5f5e9154 in ApplicationUpdates::transactionFinished (this=0x1489960) at /build/buildd/muon-2.1.1/libmuon/backends/ApplicationBackend/ApplicationUpdates.cpp:210
#21 0x00007f5e76200a58 in QMetaObject::activate (sender=0x2bbd890, m=m@entry=0x7f5e5ef759c0 <QApt::Transaction::staticMetaObject>, local_signal_index=local_signal_index@entry=8, argv=argv@entry=0x7fff360ae200) at kernel/qobject.cpp:3539
#22 0x00007f5e5ed60441 in QApt::Transaction::finished (this=<optimized out>, _t1=QApt::ExitSuccess) at /build/buildd/qapt-2.0.65/obj-x86_64-linux-gnu/src/moc_transaction.cxx:338
#23 0x00007f5e5ed531af in QApt::Transaction::updateProperty (this=0x2bbd890, type=1972, variant=...) at /build/buildd/qapt-2.0.65/src/transaction.cpp:546
#24 0x00007f5e5ed60974 in QApt::Transaction::qt_static_metacall (_o=0x2bbd890, _c=<optimized out>, _id=<optimized out>, _a=0x7fff360ae420) at /build/buildd/qapt-2.0.65/obj-x86_64-linux-gnu/src/moc_transaction.cxx:164
#25 0x00007f5e76200a58 in QMetaObject::activate (sender=sender@entry=0x2bb0700, m=m@entry=0x7f5e5ef75aa0 <OrgKubuntuQaptworkerTransactionInterface::staticMetaObject>, local_signal_index=local_signal_index@entry=4, argv=argv@entry=0x7fff360ae420) at kernel/qobject.cpp:3539
#26 0x00007f5e5ed613d6 in OrgKubuntuQaptworkerTransactionInterface::propertyChanged (this=this@entry=0x2bb0700, _t1=11, _t2=...) at /build/buildd/qapt-2.0.65/obj-x86_64-linux-gnu/src/moc_transactiondbus.cxx:246
#27 0x00007f5e5ed6177c in OrgKubuntuQaptworkerTransactionInterface::qt_static_metacall (_o=_o@entry=0x2bb0700, _c=_c@entry=QMetaObject::InvokeMetaMethod, _id=_id@entry=4, _a=_a@entry=0x7fff360ae6e0) at /build/buildd/qapt-2.0.65/obj-x86_64-linux-gnu/src/moc_transactiondbus.cxx:111
#28 0x00007f5e5ed620f7 in OrgKubuntuQaptworkerTransactionInterface::qt_metacall (this=0x2bb0700, _c=QMetaObject::InvokeMetaMethod, _id=4, _a=0x7fff360ae6e0) at /build/buildd/qapt-2.0.65/obj-x86_64-linux-gnu/src/moc_transactiondbus.cxx:164
#29 0x00007f5e7529be36 in QDBusConnectionPrivate::deliverCall (this=0x11a62b0, object=0x2bb0700, msg=..., metaTypes=..., slotIdx=9) at qdbusintegrator.cpp:951
#30 0x00007f5e76204dce in QObject::event (this=0x2bb0700, e=<optimized out>) at kernel/qobject.cpp:1194
#31 0x00007f5e76bdddfc in QApplicationPrivate::notify_helper (this=this@entry=0xf8c590, receiver=receiver@entry=0x2bb0700, e=e@entry=0x2cacb20) at kernel/qapplication.cpp:4567
#32 0x00007f5e76be4470 in QApplication::notify (this=this@entry=0x7fff360aee90, receiver=receiver@entry=0x2bb0700, e=e@entry=0x2cacb20) at kernel/qapplication.cpp:4353
#33 0x00007f5e778e7a6a in KApplication::notify (this=0x7fff360aee90, receiver=0x2bb0700, event=0x2cacb20) at ../../kdeui/kernel/kapplication.cpp:311
#34 0x00007f5e761ec8bd in QCoreApplication::notifyInternal (this=0x7fff360aee90, receiver=receiver@entry=0x2bb0700, event=event@entry=0x2cacb20) at kernel/qcoreapplication.cpp:946
#35 0x00007f5e761efe1f in sendEvent (event=0x2cacb20, receiver=0x2bb0700) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#36 QCoreApplicationPrivate::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0xf5a500) at kernel/qcoreapplication.cpp:1570
#37 0x00007f5e761f02c3 in QCoreApplication::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0) at kernel/qcoreapplication.cpp:1463
#38 0x00007f5e7621a073 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#39 postEventSourceDispatch (s=0xf89db0) at kernel/qeventdispatcher_glib.cpp:279
#40 0x00007f5e72e1e3b6 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#41 0x00007f5e72e1e708 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#42 0x00007f5e72e1e7ac in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#43 0x00007f5e76219a55 in QEventDispatcherGlib::processEvents (this=0xf88f30, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#44 0x00007f5e76c7f9d6 in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#45 0x00007f5e761eb5ef in QEventLoop::processEvents (this=this@entry=0x7fff360aed90, flags=...) at kernel/qeventloop.cpp:149
#46 0x00007f5e761eb8e5 in QEventLoop::exec (this=this@entry=0x7fff360aed90, flags=...) at kernel/qeventloop.cpp:204
#47 0x00007f5e761f0e5b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1218
#48 0x00007f5e76bdc34c in QApplication::exec () at kernel/qapplication.cpp:3828
#49 0x000000000040ce11 in main (argc=1, argv=0x7fff360aefc8) at /build/buildd/muon-2.1.1/updater/main.cpp:59

The reporter indicates this bug may be a duplicate of or related to bug 325109.

Possible duplicates by query: bug 328995, bug 328347, bug 327912, bug 327104, bug 327032.

Reported using DrKonqi
Comment 1 Jekyll Wu 2014-01-03 03:44:08 UTC

*** This bug has been marked as a duplicate of bug 325109 ***