Bug 330615 - Muon crashed while installing updates
Summary: Muon crashed while installing updates
Status: RESOLVED DUPLICATE of bug 325109
Alias: None
Product: Discover
Classification: Unclassified
Component: Updates (interactive) (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash
Target Milestone: ---
Assignee: Jonathan Thomas
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2014-01-31 15:55 UTC by ARVIND RATHORE
Modified: 2016-03-02 13:24 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ARVIND RATHORE 2014-01-31 15:55:59 UTC
Application: muon-updater (2.1.2)
KDE Platform Version: 4.12.1
Qt Version: 4.8.6
Operating System: Linux 3.13.0-5-generic x86_64
Distribution: Ubuntu Trusty Tahr (development branch)

-- Information about the crash:
Muon showed some updates are available, clicked for updating the system. After downloading and installing some, it crashed.

-- Backtrace:
Application: Muon Update Manager (muon-updater), signal: Aborted
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fc1355a27c0 (LWP 4278))]

Thread 3 (Thread 0x7fc122181700 (LWP 4279)):
#0  0x00007fc132bffe4d in read () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007fc12ffbb950 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fc12ff7b864 in g_main_context_check () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fc12ff7bccb in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007fc12ff7be3c in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007fc133389836 in QEventDispatcherGlib::processEvents (this=0x7fc11c0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:427
#6  0x00007fc13335b09f in QEventLoop::processEvents (this=this@entry=0x7fc122180de0, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007fc13335b395 in QEventLoop::exec (this=this@entry=0x7fc122180de0, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007fc133257c4f in QThread::exec (this=this@entry=0x1cc6560) at thread/qthread.cpp:537
#9  0x00007fc13333c813 in QInotifyFileSystemWatcherEngine::run (this=0x1cc6560) at io/qfilesystemwatcher_inotify.cpp:265
#10 0x00007fc13325a31f in QThreadPrivate::start (arg=0x1cc6560) at thread/qthread_unix.cpp:349
#11 0x00007fc130455182 in start_thread (arg=0x7fc122181700) at pthread_create.c:312
#12 0x00007fc132c0eb5d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 2 (Thread 0x7fc113fff700 (LWP 4423)):
#0  0x00007fc12ffbc35a in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007fc12ffbc6c9 in g_mutex_unlock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fc12ff7b3d0 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fc12ff7bc53 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007fc12ff7be3c in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007fc133389836 in QEventDispatcherGlib::processEvents (this=0x7fc1040008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:427
#6  0x00007fc13335b09f in QEventLoop::processEvents (this=this@entry=0x7fc113ffede0, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007fc13335b395 in QEventLoop::exec (this=this@entry=0x7fc113ffede0, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007fc133257c4f in QThread::exec (this=this@entry=0x33d48f0) at thread/qthread.cpp:537
#9  0x00007fc13333c813 in QInotifyFileSystemWatcherEngine::run (this=0x33d48f0) at io/qfilesystemwatcher_inotify.cpp:265
#10 0x00007fc13325a31f in QThreadPrivate::start (arg=0x33d48f0) at thread/qthread_unix.cpp:349
#11 0x00007fc130455182 in start_thread (arg=0x7fc113fff700) at pthread_create.c:312
#12 0x00007fc132c0eb5d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 1 (Thread 0x7fc1355a27c0 (LWP 4278)):
[KCrash Handler]
#6  0x00007fc132b4af39 in __GI_raise (sig=sig@entry=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:56
#7  0x00007fc132b4e348 in __GI_abort () at abort.c:89
#8  0x00007fc13324fc82 in qt_message_output (msgType=msgType@entry=QtFatalMsg, buf=0x30962f8 "ASSERT failure in QList<T>::at: \"index out of range\", file /usr/include/qt4/QtCore/qlist.h, line 469") at global/qglobal.cpp:2383
#9  0x00007fc13324ffe9 in qt_message(QtMsgType, const char *, typedef __va_list_tag __va_list_tag *) (msgType=msgType@entry=QtFatalMsg, msg=msg@entry=0x7fc1333bdab8 "ASSERT failure in %s: \"%s\", file %s, line %d", ap=ap@entry=0x7fffb4169e18) at global/qglobal.cpp:2429
#10 0x00007fc1332507f4 in qFatal (msg=msg@entry=0x7fc1333bdab8 "ASSERT failure in %s: \"%s\", file %s, line %d") at global/qglobal.cpp:2612
#11 0x00007fc13325085a in qt_assert_x (where=where@entry=0x7fc11b9bd0ac "QList<T>::at", what=what@entry=0x7fc11b9bd08a "index out of range", file=file@entry=0x7fc11b9bcf70 "/usr/include/qt4/QtCore/qlist.h", line=line@entry=469) at global/qglobal.cpp:2065
#12 0x00007fc11b98c05a in at (i=69933, this=0x204d348) at /usr/include/qt4/QtCore/qlist.h:469
#13 QApt::Backend::stateChanges (this=<optimized out>, oldState=..., excluded=...) at /build/buildd/qapt-2.0.65/src/backend.cpp:754
#14 0x00007fc1203eff84 in ApplicationUpdates::calculateUpdates (this=this@entry=0x204d310) at /build/buildd/muon-2.1.2/libmuon/backends/ApplicationBackend/ApplicationUpdates.cpp:448
#15 0x00007fc1203f05e8 in ApplicationUpdates::fetchingChanged (this=0x204d310) at /build/buildd/muon-2.1.2/libmuon/backends/ApplicationBackend/ApplicationUpdates.cpp:441
#16 0x00007fc133370868 in QMetaObject::activate (sender=sender@entry=0x2049270, m=m@entry=0x7fc1353c4180 <AbstractResourcesBackend::staticMetaObject>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x0) at kernel/qobject.cpp:3539
#17 0x00007fc13519e040 in AbstractResourcesBackend::fetchingChanged (this=this@entry=0x2049270) at /build/buildd/muon-2.1.2/obj-x86_64-linux-gnu/libmuon/moc_AbstractResourcesBackend.cpp:156
#18 0x00007fc1203e1e33 in ApplicationBackend::setFetching (this=0x2049270, f=<optimized out>) at /build/buildd/muon-2.1.2/libmuon/backends/ApplicationBackend/ApplicationBackend.cpp:642
#19 0x00007fc1203e4461 in ApplicationBackend::reload (this=0x2049270) at /build/buildd/muon-2.1.2/libmuon/backends/ApplicationBackend/ApplicationBackend.cpp:175
#20 0x00007fc1203ef0c4 in ApplicationUpdates::transactionFinished (this=0x204d310) at /build/buildd/muon-2.1.2/libmuon/backends/ApplicationBackend/ApplicationUpdates.cpp:210
#21 0x00007fc133370868 in QMetaObject::activate (sender=0x383bc70, m=m@entry=0x7fc11bbce9c0 <QApt::Transaction::staticMetaObject>, local_signal_index=local_signal_index@entry=8, argv=argv@entry=0x7fffb416a360) at kernel/qobject.cpp:3539
#22 0x00007fc11b9b9441 in QApt::Transaction::finished (this=<optimized out>, _t1=QApt::ExitSuccess) at /build/buildd/qapt-2.0.65/obj-x86_64-linux-gnu/src/moc_transaction.cxx:338
#23 0x00007fc11b9ac1af in QApt::Transaction::updateProperty (this=0x383bc70, type=4278, variant=...) at /build/buildd/qapt-2.0.65/src/transaction.cpp:546
#24 0x00007fc11b9b9974 in QApt::Transaction::qt_static_metacall (_o=0x383bc70, _c=<optimized out>, _id=<optimized out>, _a=0x7fffb416a580) at /build/buildd/qapt-2.0.65/obj-x86_64-linux-gnu/src/moc_transaction.cxx:164
#25 0x00007fc133370868 in QMetaObject::activate (sender=sender@entry=0x37a0e70, m=m@entry=0x7fc11bbceaa0 <OrgKubuntuQaptworkerTransactionInterface::staticMetaObject>, local_signal_index=local_signal_index@entry=4, argv=argv@entry=0x7fffb416a580) at kernel/qobject.cpp:3539
#26 0x00007fc11b9ba3d6 in OrgKubuntuQaptworkerTransactionInterface::propertyChanged (this=this@entry=0x37a0e70, _t1=11, _t2=...) at /build/buildd/qapt-2.0.65/obj-x86_64-linux-gnu/src/moc_transactiondbus.cxx:246
#27 0x00007fc11b9ba77c in OrgKubuntuQaptworkerTransactionInterface::qt_static_metacall (_o=_o@entry=0x37a0e70, _c=_c@entry=QMetaObject::InvokeMetaMethod, _id=_id@entry=4, _a=_a@entry=0x7fffb416a840) at /build/buildd/qapt-2.0.65/obj-x86_64-linux-gnu/src/moc_transactiondbus.cxx:111
#28 0x00007fc11b9bb0f7 in OrgKubuntuQaptworkerTransactionInterface::qt_metacall (this=0x37a0e70, _c=QMetaObject::InvokeMetaMethod, _id=4, _a=0x7fffb416a840) at /build/buildd/qapt-2.0.65/obj-x86_64-linux-gnu/src/moc_transactiondbus.cxx:164
#29 0x00007fc1324001f6 in QDBusConnectionPrivate::deliverCall (this=0x1cb2650, object=0x37a0e70, msg=..., metaTypes=..., slotIdx=9) at qdbusintegrator.cpp:951
#30 0x00007fc133374c0e in QObject::event (this=0x37a0e70, e=<optimized out>) at kernel/qobject.cpp:1194
#31 0x00007fc133d4ee2c in QApplicationPrivate::notify_helper (this=this@entry=0x1af1600, receiver=receiver@entry=0x37a0e70, e=e@entry=0x38dc090) at kernel/qapplication.cpp:4567
#32 0x00007fc133d554a0 in QApplication::notify (this=this@entry=0x7fffb416afe0, receiver=receiver@entry=0x37a0e70, e=e@entry=0x38dc090) at kernel/qapplication.cpp:4353
#33 0x00007fc134a5baaa in KApplication::notify (this=0x7fffb416afe0, receiver=0x37a0e70, event=0x38dc090) at ../../kdeui/kernel/kapplication.cpp:311
#34 0x00007fc13335c4cd in QCoreApplication::notifyInternal (this=0x7fffb416afe0, receiver=receiver@entry=0x37a0e70, event=event@entry=0x38dc090) at kernel/qcoreapplication.cpp:953
#35 0x00007fc13335fb2d in sendEvent (event=0x38dc090, receiver=0x37a0e70) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#36 QCoreApplicationPrivate::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0x1ac5500) at kernel/qcoreapplication.cpp:1577
#37 0x00007fc13335ffd3 in QCoreApplication::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0) at kernel/qcoreapplication.cpp:1470
#38 0x00007fc133389f53 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#39 postEventSourceDispatch (s=0x1af8500) at kernel/qeventdispatcher_glib.cpp:280
#40 0x00007fc12ff7bb54 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#41 0x00007fc12ff7bd98 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#42 0x00007fc12ff7be3c in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#43 0x00007fc133389815 in QEventDispatcherGlib::processEvents (this=0x1ac6e00, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#44 0x00007fc133df0bb6 in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#45 0x00007fc13335b09f in QEventLoop::processEvents (this=this@entry=0x7fffb416aee0, flags=...) at kernel/qeventloop.cpp:149
#46 0x00007fc13335b395 in QEventLoop::exec (this=this@entry=0x7fffb416aee0, flags=...) at kernel/qeventloop.cpp:204
#47 0x00007fc133360b69 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1225
#48 0x00007fc133d4d37c in QApplication::exec () at kernel/qapplication.cpp:3828
#49 0x000000000040ce11 in main (argc=1, argv=0x7fffb416b118) at /build/buildd/muon-2.1.2/updater/main.cpp:59

Possible duplicates by query: bug 330486, bug 330407, bug 330054, bug 329935, bug 329528.

Reported using DrKonqi
Comment 1 Harald Sitter 2014-01-31 15:57:48 UTC

*** This bug has been marked as a duplicate of bug 325109 ***