Bug 330407 - Muon crashed when updating system
Summary: Muon crashed when updating system
Status: RESOLVED DUPLICATE of bug 325109
Alias: None
Product: Discover
Classification: Unclassified
Component: Updates (interactive) (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash
Target Milestone: ---
Assignee: Jonathan Thomas
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2014-01-25 21:22 UTC by Aitor González Martínez
Modified: 2016-03-02 13:29 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Aitor González Martínez 2014-01-25 21:22:27 UTC
Application: muon-updater (2.1.2)
KDE Platform Version: 4.12.1
Qt Version: 4.8.6
Operating System: Linux 3.13.0-5-generic i686
Distribution: Ubuntu Trusty Tahr (development branch)

-- Information about the crash:
I was updating my system, Kubuntu 14.04, installed yesterday.

-- Backtrace:
Application: Gestor de actualizaciones Muon (muon-updater), signal: Aborted
Using host libthread_db library "/lib/i386-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0xb5120980 (LWP 2260))]

Thread 3 (Thread 0xb1d88b40 (LWP 2261)):
#0  0xb76f5424 in __kernel_vsyscall ()
#1  0xb5f8fdeb in poll () at ../sysdeps/unix/syscall-template.S:81
#2  0xb57d0f4b in g_poll () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb57c2178 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb57c22b8 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xb62f49ef in QEventDispatcherGlib::processEvents (this=0xb1400468, flags=...) at kernel/qeventdispatcher_glib.cpp:427
#6  0xb62c3813 in QEventLoop::processEvents (this=this@entry=0xb1d88258, flags=...) at kernel/qeventloop.cpp:149
#7  0xb62c3b39 in QEventLoop::exec (this=this@entry=0xb1d88258, flags=...) at kernel/qeventloop.cpp:204
#8  0xb61b023d in QThread::exec (this=this@entry=0x9080da8) at thread/qthread.cpp:537
#9  0xb62a3c34 in QInotifyFileSystemWatcherEngine::run (this=0x9080da8) at io/qfilesystemwatcher_inotify.cpp:265
#10 0xb61b2b6f in QThreadPrivate::start (arg=0x9080da8) at thread/qthread_unix.cpp:349
#11 0xb58a0f70 in start_thread (arg=0xb1d88b40) at pthread_create.c:312
#12 0xb5f9ed1e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:129

Thread 2 (Thread 0xad9ffb40 (LWP 2305)):
#0  0xb57c16df in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#1  0xb57c206f in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0xb57c22b8 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb62f49ef in QEventDispatcherGlib::processEvents (this=0xad000468, flags=...) at kernel/qeventdispatcher_glib.cpp:427
#4  0xb62c3813 in QEventLoop::processEvents (this=this@entry=0xad9ff258, flags=...) at kernel/qeventloop.cpp:149
#5  0xb62c3b39 in QEventLoop::exec (this=this@entry=0xad9ff258, flags=...) at kernel/qeventloop.cpp:204
#6  0xb61b023d in QThread::exec (this=this@entry=0x94c8820) at thread/qthread.cpp:537
#7  0xb62a3c34 in QInotifyFileSystemWatcherEngine::run (this=0x94c8820) at io/qfilesystemwatcher_inotify.cpp:265
#8  0xb61b2b6f in QThreadPrivate::start (arg=0x94c8820) at thread/qthread_unix.cpp:349
#9  0xb58a0f70 in start_thread (arg=0xad9ffb40) at pthread_create.c:312
#10 0xb5f9ed1e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:129

Thread 1 (Thread 0xb5120980 (LWP 2260)):
[KCrash Handler]
#7  0xb76f5424 in __kernel_vsyscall ()
#8  0xb5ee0776 in __GI_raise (sig=sig@entry=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:56
#9  0xb5ee3bc3 in __GI_abort () at abort.c:89
#10 0xb61a7d73 in qt_message_output (msgType=QtFatalMsg, buf=0xa2e3578 "ASSERT failure in QList<T>::at: \"index out of range\", file /usr/include/qt4/QtCore/qlist.h, line 469") at global/qglobal.cpp:2383
#11 0xb61a8127 in qt_message (msgType=msgType@entry=QtFatalMsg, msg=msg@entry=0xb632cf10 "ASSERT failure in %s: \"%s\", file %s, line %d", ap=ap@entry=0xbf933844 "\234\330}\260z\330}\260h\327}\260\325\001") at global/qglobal.cpp:2429
#12 0xb61a8658 in qFatal (msg=msg@entry=0xb632cf10 "ASSERT failure in %s: \"%s\", file %s, line %d") at global/qglobal.cpp:2612
#13 0xb61a871d in qt_assert_x (where=where@entry=0xb07dd89c "QList<T>::at", what=what@entry=0xb07dd87a "index out of range", file=file@entry=0xb07dd768 "/usr/include/qt4/QtCore/qlist.h", line=line@entry=469) at global/qglobal.cpp:2065
#14 0xb07a9c1b in at (i=44600, this=0x928faa4) at /usr/include/qt4/QtCore/qlist.h:469
#15 QApt::Backend::stateChanges (this=0x925cf20, oldState=..., excluded=...) at /build/buildd/qapt-2.0.65/src/backend.cpp:754
#16 0xb095f47b in ApplicationUpdates::calculateUpdates (this=this@entry=0x928fa88) at /build/buildd/muon-2.1.2/libmuon/backends/ApplicationBackend/ApplicationUpdates.cpp:448
#17 0xb095fac0 in ApplicationUpdates::fetchingChanged (this=0x928fa88) at /build/buildd/muon-2.1.2/libmuon/backends/ApplicationBackend/ApplicationUpdates.cpp:441
#18 0xb094ef18 in ApplicationUpdates::qt_static_metacall (_o=<optimized out>, _id=<optimized out>, _a=0xbf933a28, _c=<optimized out>) at /build/buildd/muon-2.1.2/obj-i686-linux-gnu/libmuon/backends/ApplicationBackend/moc_ApplicationUpdates.cpp:83
#19 0xb62da0e7 in QMetaObject::activate (sender=sender@entry=0x9292690, m=m@entry=0xb76d8938 <AbstractResourcesBackend::staticMetaObject>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x0) at kernel/qobject.cpp:3539
#20 0xb76afd95 in AbstractResourcesBackend::fetchingChanged (this=this@entry=0x9292690) at /build/buildd/muon-2.1.2/obj-i686-linux-gnu/libmuon/moc_AbstractResourcesBackend.cpp:156
#21 0xb09505c8 in ApplicationBackend::setFetching (this=0x9292690, f=false) at /build/buildd/muon-2.1.2/libmuon/backends/ApplicationBackend/ApplicationBackend.cpp:642
#22 0xb0952d0b in ApplicationBackend::reload (this=0x9292690) at /build/buildd/muon-2.1.2/libmuon/backends/ApplicationBackend/ApplicationBackend.cpp:175
#23 0xb095e4a6 in ApplicationUpdates::transactionFinished (this=0x928fa88) at /build/buildd/muon-2.1.2/libmuon/backends/ApplicationBackend/ApplicationUpdates.cpp:210
#24 0xb094ede9 in ApplicationUpdates::qt_static_metacall (_o=<optimized out>, _id=<optimized out>, _a=0xbf933bd8, _c=<optimized out>) at /build/buildd/muon-2.1.2/obj-i686-linux-gnu/libmuon/backends/ApplicationBackend/moc_ApplicationUpdates.cpp:85
#25 0xb62da0e7 in QMetaObject::activate (sender=sender@entry=0xa0c1d10, m=m@entry=0xb07eed18 <QApt::Transaction::staticMetaObject>, local_signal_index=local_signal_index@entry=8, argv=argv@entry=0xbf933bd8) at kernel/qobject.cpp:3539
#26 0xb07d9235 in QApt::Transaction::finished (this=this@entry=0xa0c1d10, _t1=QApt::ExitSuccess) at /build/buildd/qapt-2.0.65/obj-i686-linux-gnu/src/moc_transaction.cxx:338
#27 0xb07cb317 in QApt::Transaction::updateProperty (this=this@entry=0xa0c1d10, type=11, variant=...) at /build/buildd/qapt-2.0.65/src/transaction.cpp:546
#28 0xb07d98d4 in QApt::Transaction::qt_static_metacall (_o=_o@entry=0xa0c1d10, _c=_c@entry=QMetaObject::InvokeMetaMethod, _id=24, _a=0xbf933d54) at /build/buildd/qapt-2.0.65/obj-i686-linux-gnu/src/moc_transaction.cxx:164
#29 0xb62da0e7 in QMetaObject::activate (sender=sender@entry=0xa270558, m=m@entry=0xb07eed78 <OrgKubuntuQaptworkerTransactionInterface::staticMetaObject>, local_signal_index=local_signal_index@entry=4, argv=argv@entry=0xbf933d54) at kernel/qobject.cpp:3539
#30 0xb07da5bd in OrgKubuntuQaptworkerTransactionInterface::propertyChanged (this=this@entry=0xa270558, _t1=11, _t2=...) at /build/buildd/qapt-2.0.65/obj-i686-linux-gnu/src/moc_transactiondbus.cxx:246
#31 0xb07da9e9 in OrgKubuntuQaptworkerTransactionInterface::qt_static_metacall (_o=_o@entry=0xa270558, _c=_c@entry=QMetaObject::InvokeMetaMethod, _id=_id@entry=4, _a=_a@entry=0xbf933efc) at /build/buildd/qapt-2.0.65/obj-i686-linux-gnu/src/moc_transactiondbus.cxx:111
#32 0xb07db456 in OrgKubuntuQaptworkerTransactionInterface::qt_metacall (this=0xa270558, _c=QMetaObject::InvokeMetaMethod, _id=4, _a=0xbf933efc) at /build/buildd/qapt-2.0.65/obj-i686-linux-gnu/src/moc_transactiondbus.cxx:164
#33 0xb5d9c21e in QDBusConnectionPrivate::deliverCall (this=0x905be18, object=object@entry=0xa270558, msg=..., metaTypes=..., slotIdx=9) at qdbusintegrator.cpp:951
#34 0xb5da52cd in QDBusCallDeliveryEvent::placeMetaCall (this=0xa144748, object=0xa270558) at qdbusintegrator_p.h:103
#35 0xb62de6eb in QObject::event (this=0xa270558, e=0xa144748) at kernel/qobject.cpp:1194
#36 0xb68207f4 in QApplicationPrivate::notify_helper (this=0x8ef66d0, receiver=0xa270558, e=0xa144748) at kernel/qapplication.cpp:4567
#37 0xb68272d3 in QApplication::notify (this=0xbf934580, receiver=receiver@entry=0xa270558, e=e@entry=0xa144748) at kernel/qapplication.cpp:4353
#38 0xb7372014 in KApplication::notify (this=0xbf934580, receiver=0xa270558, event=0xa144748) at ../../kdeui/kernel/kapplication.cpp:311
#39 0xb62c4e3a in QCoreApplication::notifyInternal (this=0xbf934580, receiver=receiver@entry=0xa270558, event=event@entry=0xa144748) at kernel/qcoreapplication.cpp:953
#40 0xb62c86fd in sendEvent (event=0xa144748, receiver=0xa270558) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#41 QCoreApplicationPrivate::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0x8ece1d8) at kernel/qcoreapplication.cpp:1577
#42 0xb62c8c0c in QCoreApplication::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0) at kernel/qcoreapplication.cpp:1470
#43 0xb62f51ee in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#44 postEventSourceDispatch (s=0x8ef1a58) at kernel/qeventdispatcher_glib.cpp:280
#45 0xb57c1f73 in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#46 0xb57c21f8 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#47 0xb57c22b8 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#48 0xb62f49cf in QEventDispatcherGlib::processEvents (this=this@entry=0x8ecef78, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#49 0xb68d55ee in QGuiEventDispatcherGlib::processEvents (this=0x8ecef78, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#50 0xb62c3813 in QEventLoop::processEvents (this=this@entry=0xbf9344c8, flags=...) at kernel/qeventloop.cpp:149
#51 0xb62c3b39 in QEventLoop::exec (this=this@entry=0xbf9344c8, flags=...) at kernel/qeventloop.cpp:204
#52 0xb62c98ee in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1225
#53 0xb681ea24 in QApplication::exec () at kernel/qapplication.cpp:3828
#54 0x080520f6 in main (argc=1, argv=0xbf934654) at /build/buildd/muon-2.1.2/updater/main.cpp:59

Possible duplicates by query: bug 330054, bug 329935, bug 329528, bug 328995, bug 328347.

Reported using DrKonqi
Comment 1 Jekyll Wu 2014-01-26 01:36:26 UTC

*** This bug has been marked as a duplicate of bug 325109 ***