Bug 311441 - Project Neon IMAP crash when screen saver dissapears
Summary: Project Neon IMAP crash when screen saver dissapears
Status: RESOLVED DUPLICATE of bug 291961
Alias: None
Product: Akonadi
Classification: Unclassified
Component: IMAP resource (show other bugs)
Version: 4.9
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Kevin Ottens
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-09 22:41 UTC by Andrew
Modified: 2013-02-26 03:37 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew 2012-12-09 22:41:47 UTC
Application: akonadi_imap_resource (4.9)
KDE Platform Version: 4.9.90
Qt Version: 4.8.4
Operating System: Linux 3.7.0-4-generic x86_64
Distribution: Ubuntu 12.10

-- Information about the crash:
My computer had been unattended for a few days. The screensaver asked me to login, which i did, and then i found this crash window. I know this isn't super useful but the CRA has 3 stars so i thought i'd add it in case.

-- Backtrace:
Application: voice of type IMAP E-Mail Server (akonadi_imap_resource), signal: Aborted
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fec1c152780 (LWP 11380))]

Thread 3 (Thread 0x7fec09e2d700 (LWP 18896)):
#0  0x00007fec16b46f69 in __pthread_mutex_lock (mutex=0x7fec040253b0) at pthread_mutex_lock.c:92
#1  0x00007fec1604ec31 in g_mutex_lock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fec16011623 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fec16011cab in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007fec16011ea4 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007fec1b451fd6 in QEventDispatcherGlib::processEvents (this=0x7fec04001940, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x00007fec1b412568 in QEventLoop::processEvents (this=0x7fec09e2cd90, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007fec1b4126fc in QEventLoop::exec (this=0x7fec09e2cd90, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007fec1b2d71d7 in QThread::exec (this=0xec4d00) at thread/qthread.cpp:550
#9  0x00007fec19bef221 in KIMAP::SessionThread::run (this=0xec4d00) at /build/buildd/project-neon-kdepimlibs-2+git20121206+r12787/kimap/sessionthread.cpp:182
#10 0x00007fec1b2d9c4e in QThreadPrivate::start (arg=0xec4d00) at thread/qthread_unix.cpp:338
#11 0x00007fec16b44e9a in start_thread (arg=0x7fec09e2d700) at pthread_create.c:308
#12 0x00007fec172cacbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#13 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7fec0962c700 (LWP 19781)):
#0  0x00007fec172bf303 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fec16011d84 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fec16011ea4 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fec1b451fd6 in QEventDispatcherGlib::processEvents (this=0x7febfc002a20, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007fec1b412568 in QEventLoop::processEvents (this=0x7fec0962bd90, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fec1b4126fc in QEventLoop::exec (this=0x7fec0962bd90, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007fec1b2d71d7 in QThread::exec (this=0x1002960) at thread/qthread.cpp:550
#7  0x00007fec19bef221 in KIMAP::SessionThread::run (this=0x1002960) at /build/buildd/project-neon-kdepimlibs-2+git20121206+r12787/kimap/sessionthread.cpp:182
#8  0x00007fec1b2d9c4e in QThreadPrivate::start (arg=0x1002960) at thread/qthread_unix.cpp:338
#9  0x00007fec16b44e9a in start_thread (arg=0x7fec0962c700) at pthread_create.c:308
#10 0x00007fec172cacbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fec1c152780 (LWP 11380)):
[KCrash Handler]
#6  0x00007fec1720d425 in __GI_raise (sig=<optimized out>) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#7  0x00007fec17210b8b in __GI_abort () at abort.c:91
#8  0x00007fec1b2cc4b3 in qt_message_output (msgType=QtFatalMsg, buf=0xecdde8 "ASSERT failure in createItemSyncInstance: \"Calling items retrieval methods although no item retrieval is in progress\", file /build/buildd/project-neon-kdepimlibs-2+git20121206+r12787/akonadi/resourceb"...) at global/qglobal.cpp:2323
#9  0x00007fec1b2cc652 in qt_message(QtMsgType, const char *, typedef __va_list_tag __va_list_tag *) (msgType=QtFatalMsg, msg=0x7fec1b499ab0 "ASSERT failure in %s: \"%s\", file %s, line %d", ap=0x7fff469eb148) at global/qglobal.cpp:2369
#10 0x00007fec1b2cce1c in qFatal (msg=0x7fec1b499ab0 "ASSERT failure in %s: \"%s\", file %s, line %d") at global/qglobal.cpp:2552
#11 0x00007fec1b2cc0ab in qt_assert_x (where=0x7fec1bc8ea92 "createItemSyncInstance", what=0x7fec1bc8ea48 "Calling items retrieval methods although no item retrieval is in progress", file=0x7fec1bc8e9f0 "/build/buildd/project-neon-kdepimlibs-2+git20121206+r12787/akonadi/resourcebase.cpp", line=166) at global/qglobal.cpp:2026
#12 0x00007fec1bbf79fc in Akonadi::ResourceBasePrivate::createItemSyncInstanceIfMissing (this=0xe527c0) at /build/buildd/project-neon-kdepimlibs-2+git20121206+r12787/akonadi/resourcebase.cpp:165
#13 0x00007fec1bbf5c5e in Akonadi::ResourceBase::itemsRetrieved (this=0xe1f500, items=...) at /build/buildd/project-neon-kdepimlibs-2+git20121206+r12787/akonadi/resourcebase.cpp:978
#14 0x0000000000421077 in ResourceState::itemsRetrieved (this=0x10048c0, items=...) at /build/buildd/project-neon-kdepim-runtime-2+git20121205+r7859/resources/imap/resourcestate.cpp:331
#15 0x000000000044d071 in ResourceTask::itemsRetrieved (this=0x1002490, items=...) at /build/buildd/project-neon-kdepim-runtime-2+git20121205+r7859/resources/imap/resourcetask.cpp:244
#16 0x000000000045a613 in RetrieveItemsTask::onHeadersReceived (this=0x1002490, mailBox=..., uids=..., sizes=..., flags=..., messages=...) at /build/buildd/project-neon-kdepim-runtime-2+git20121205+r7859/resources/imap/retrieveitemstask.cpp:362
#17 0x000000000045aef9 in RetrieveItemsTask::qt_static_metacall (_o=0x1002490, _c=QMetaObject::InvokeMetaMethod, _id=3, _a=0x7fff469eb640) at /build/buildd/project-neon-kdepim-runtime-2+git20121205+r7859/obj-x86_64-linux-gnu/resources/imap/retrieveitemstask.moc:67
#18 0x00007fec1b433f62 in QMetaObject::activate (sender=0xff0580, m=0x69b120 <KIMAP::FetchJob::staticMetaObject>, local_signal_index=0, argv=0x7fff469eb640) at kernel/qobject.cpp:3543
#19 0x00007fec19bd8d7e in KIMAP::FetchJob::headersReceived (this=0xff0580, _t1=..., _t2=..., _t3=..., _t4=..., _t5=...) at /build/buildd/project-neon-kdepimlibs-2+git20121206+r12787/obj-x86_64-linux-gnu/kimap/moc_fetchjob.cpp:115
#20 0x00007fec19bd9a37 in KIMAP::FetchJobPrivate::emitPendings (this=0xec4fa0) at /build/buildd/project-neon-kdepimlibs-2+git20121206+r12787/kimap/fetchjob.cpp:57
#21 0x00007fec19bd6b24 in KIMAP::FetchJob::handleResponse (this=0xff0580, response=...) at /build/buildd/project-neon-kdepimlibs-2+git20121206+r12787/kimap/fetchjob.cpp:236
#22 0x00007fec19beaba1 in KIMAP::SessionPrivate::responseReceived (this=0xec4590, response=...) at /build/buildd/project-neon-kdepimlibs-2+git20121206+r12787/kimap/session.cpp:278
#23 0x00007fec19bebd48 in KIMAP::Session::qt_static_metacall (_o=0xf63080, _c=QMetaObject::InvokeMetaMethod, _id=7, _a=0x7febfc013f00) at /build/buildd/project-neon-kdepimlibs-2+git20121206+r12787/obj-x86_64-linux-gnu/kimap/moc_session.cpp:91
#24 0x00007fec1b42d5db in QMetaCallEvent::placeMetaCall (this=0x7febfc01c8a0, object=0xf63080) at kernel/qobject.cpp:524
#25 0x00007fec1b42e82b in QObject::event (this=0xf63080, e=0x7febfc01c8a0) at kernel/qobject.cpp:1194
#26 0x00007fec1a40809e in QApplicationPrivate::notify_helper (this=0xcb18e0, receiver=0xf63080, e=0x7febfc01c8a0) at kernel/qapplication.cpp:4562
#27 0x00007fec1a405411 in QApplication::notify (this=0x7fff469ec460, receiver=0xf63080, e=0x7febfc01c8a0) at kernel/qapplication.cpp:3944
#28 0x00007fec182a0d12 in KApplication::notify (this=0x7fff469ec460, receiver=0xf63080, event=0x7febfc01c8a0) at /build/buildd/project-neon-kdelibs-2+git20121206+r92236/kdeui/kernel/kapplication.cpp:311
#29 0x00007fec1b415168 in QCoreApplication::notifyInternal (this=0x7fff469ec460, receiver=0xf63080, event=0x7febfc01c8a0) at kernel/qcoreapplication.cpp:946
#30 0x00007fec1b418de1 in QCoreApplication::sendEvent (receiver=0xf63080, event=0x7febfc01c8a0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#31 0x00007fec1b4161e7 in QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0xc894d0) at kernel/qcoreapplication.cpp:1570
#32 0x00007fec1b415dc5 in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1463
#33 0x00007fec1b452717 in QCoreApplication::sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#34 0x00007fec1b4516fd in postEventSourceDispatch (s=0xcb2670) at kernel/qeventdispatcher_glib.cpp:279
#35 0x00007fec16011ab5 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#36 0x00007fec16011de8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#37 0x00007fec16011ea4 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#38 0x00007fec1b451fb3 in QEventDispatcherGlib::processEvents (this=0xc8acb0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#39 0x00007fec1a4e491e in QGuiEventDispatcherGlib::processEvents (this=0xc8acb0, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#40 0x00007fec1b412568 in QEventLoop::processEvents (this=0x7fff469ec390, flags=...) at kernel/qeventloop.cpp:149
#41 0x00007fec1b4126fc in QEventLoop::exec (this=0x7fff469ec390, flags=...) at kernel/qeventloop.cpp:204
#42 0x00007fec1b4157fe in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1218
#43 0x00007fec1a404ff8 in QApplication::exec () at kernel/qapplication.cpp:3823
#44 0x00007fec1bbf2133 in Akonadi::ResourceBase::init (r=0xe1f500) at /build/buildd/project-neon-kdepimlibs-2+git20121206+r12787/akonadi/resourcebase.cpp:451
#45 0x000000000041e5a5 in Akonadi::ResourceBase::init<ImapResource> (argc=3, argv=0x7fff469ec598) at /opt/project-neon/include/akonadi/resourcebase.h:188
#46 0x000000000041c300 in main (argc=3, argv=0x7fff469ec598) at /build/buildd/project-neon-kdepim-runtime-2+git20121205+r7859/resources/imap/imapresource.cpp:676

This bug may be a duplicate of or related to bug 291961.

Possible duplicates by query: bug 307621, bug 291961, bug 291369.

Reported using DrKonqi
Comment 1 Jekyll Wu 2013-02-26 03:37:06 UTC

*** This bug has been marked as a duplicate of bug 291691 ***
Comment 2 Jekyll Wu 2013-02-26 03:37:33 UTC

*** This bug has been marked as a duplicate of bug 291961 ***