Bug 328995 - KDE è terminato durante il passaggio dell'aggiornamento fonti da "server italia" a "server principale"
Summary: KDE è terminato durante il passaggio dell'aggiornamento fonti da "server ital...
Status: RESOLVED DUPLICATE of bug 325109
Alias: None
Product: Discover
Classification: Unclassified
Component: Updates (interactive) (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash
Target Milestone: ---
Assignee: Jonathan Thomas
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2013-12-19 08:46 UTC by sennacherib
Modified: 2016-03-02 13:27 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sennacherib 2013-12-19 08:46:33 UTC
Application: muon-updater (2.1.1)
KDE Platform Version: 4.11.2
Qt Version: 4.8.4
Operating System: Linux 3.11.0-14-generic x86_64
Distribution: Ubuntu 13.10

-- Information about the crash:
- What I was doing when the application crashed: I had firefox and dolphin opened. In KDE I was changing from "server in Italy" to "main server"

- Custom settings of the application:

-- Backtrace:
Application: Gestore Aggiornamenti Muon (muon-updater), signal: Aborted
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f2bca5f37c0 (LWP 4034))]

Thread 3 (Thread 0x7f2bb7754700 (LWP 4035)):
#0  0x00007f2bc501a0ea in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f2bc501a399 in g_mutex_lock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f2bc4fda286 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f2bc4fda708 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f2bc4fda7ac in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f2bc83d5a76 in QEventDispatcherGlib::processEvents (this=0x7f2bb00008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x00007f2bc83a75ef in QEventLoop::processEvents (this=this@entry=0x7f2bb7753d70, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007f2bc83a78e5 in QEventLoop::exec (this=this@entry=0x7f2bb7753d70, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007f2bc82a688f in QThread::exec (this=this@entry=0x11750c0) at thread/qthread.cpp:542
#9  0x00007f2bc8388d13 in QInotifyFileSystemWatcherEngine::run (this=0x11750c0) at io/qfilesystemwatcher_inotify.cpp:265
#10 0x00007f2bc82a8f2f in QThreadPrivate::start (arg=0x11750c0) at thread/qthread_unix.cpp:338
#11 0x00007f2bc54b2f6e in start_thread (arg=0x7f2bb7754700) at pthread_create.c:311
#12 0x00007f2bc7c5c9cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 2 (Thread 0x7f2ba7db5700 (LWP 4072)):
#0  0x00007f2bc7c4e6bd in read () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f2bc5019670 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f2bc4fda1cc in g_main_context_check () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f2bc4fda63b in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f2bc4fda7ac in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f2bc83d5a76 in QEventDispatcherGlib::processEvents (this=0x7f2ba00008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x00007f2bc83a75ef in QEventLoop::processEvents (this=this@entry=0x7f2ba7db4d70, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007f2bc83a78e5 in QEventLoop::exec (this=this@entry=0x7f2ba7db4d70, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007f2bc82a688f in QThread::exec (this=this@entry=0x1663e50) at thread/qthread.cpp:542
#9  0x00007f2bc8388d13 in QInotifyFileSystemWatcherEngine::run (this=0x1663e50) at io/qfilesystemwatcher_inotify.cpp:265
#10 0x00007f2bc82a8f2f in QThreadPrivate::start (arg=0x1663e50) at thread/qthread_unix.cpp:338
#11 0x00007f2bc54b2f6e in start_thread (arg=0x7f2ba7db5700) at pthread_create.c:311
#12 0x00007f2bc7c5c9cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 1 (Thread 0x7f2bca5f37c0 (LWP 4034)):
[KCrash Handler]
#6  0x00007f2bc7b98f77 in __GI_raise (sig=sig@entry=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:56
#7  0x00007f2bc7b9c5e8 in __GI_abort () at abort.c:90
#8  0x00007f2bc829e912 in qt_message_output (msgType=msgType@entry=QtFatalMsg, buf=0x1f29938 "ASSERT failure in QList<T>::at: \"index out of range\", file /usr/include/qt4/QtCore/qlist.h, line 469") at global/qglobal.cpp:2347
#9  0x00007f2bc829ec79 in qt_message(QtMsgType, const char *, typedef __va_list_tag __va_list_tag *) (msgType=msgType@entry=QtFatalMsg, msg=msg@entry=0x7f2bc8409aa8 "ASSERT failure in %s: \"%s\", file %s, line %d", ap=ap@entry=0x7fff95c9ba08) at global/qglobal.cpp:2393
#10 0x00007f2bc829f484 in qFatal (msg=msg@entry=0x7f2bc8409aa8 "ASSERT failure in %s: \"%s\", file %s, line %d") at global/qglobal.cpp:2576
#11 0x00007f2bc829f4ea in qt_assert_x (where=where@entry=0x7f2bb513c0ac "QList<T>::at", what=what@entry=0x7f2bb513c08a "index out of range", file=file@entry=0x7f2bb513bf70 "/usr/include/qt4/QtCore/qlist.h", line=line@entry=469) at global/qglobal.cpp:2029
#12 0x00007f2bb510b05a in at (i=67138, this=0x14bf018) at /usr/include/qt4/QtCore/qlist.h:469
#13 QApt::Backend::stateChanges (this=<optimized out>, oldState=..., excluded=...) at /build/buildd/qapt-2.0.65/src/backend.cpp:754
#14 0x00007f2bb59c2014 in ApplicationUpdates::calculateUpdates (this=this@entry=0x14befe0) at /build/buildd/muon-2.1.1/libmuon/backends/ApplicationBackend/ApplicationUpdates.cpp:448
#15 0x00007f2bb59c2668 in ApplicationUpdates::fetchingChanged (this=0x14befe0) at /build/buildd/muon-2.1.1/libmuon/backends/ApplicationBackend/ApplicationUpdates.cpp:441
#16 0x00007f2bc83bca58 in QMetaObject::activate (sender=sender@entry=0x14bb420, m=m@entry=0x7f2bca40c3c0 <AbstractResourcesBackend::staticMetaObject>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x0) at kernel/qobject.cpp:3539
#17 0x00007f2bca1e5940 in AbstractResourcesBackend::fetchingChanged (this=this@entry=0x14bb420) at /build/buildd/muon-2.1.1/obj-x86_64-linux-gnu/libmuon/moc_AbstractResourcesBackend.cpp:156
#18 0x00007f2bb59b3e93 in ApplicationBackend::setFetching (this=0x14bb420, f=<optimized out>) at /build/buildd/muon-2.1.1/libmuon/backends/ApplicationBackend/ApplicationBackend.cpp:643
#19 0x00007f2bb59b64c3 in ApplicationBackend::reload (this=0x14bb420) at /build/buildd/muon-2.1.1/libmuon/backends/ApplicationBackend/ApplicationBackend.cpp:175
#20 0x00007f2bb59c1154 in ApplicationUpdates::transactionFinished (this=0x14befe0) at /build/buildd/muon-2.1.1/libmuon/backends/ApplicationBackend/ApplicationUpdates.cpp:210
#21 0x00007f2bc83bca58 in QMetaObject::activate (sender=0x2c92240, m=m@entry=0x7f2bb534d9c0 <QApt::Transaction::staticMetaObject>, local_signal_index=local_signal_index@entry=8, argv=argv@entry=0x7fff95c9bf50) at kernel/qobject.cpp:3539
#22 0x00007f2bb5138441 in QApt::Transaction::finished (this=<optimized out>, _t1=QApt::ExitSuccess) at /build/buildd/qapt-2.0.65/obj-x86_64-linux-gnu/src/moc_transaction.cxx:338
#23 0x00007f2bb512b1af in QApt::Transaction::updateProperty (this=0x2c92240, type=4034, variant=...) at /build/buildd/qapt-2.0.65/src/transaction.cpp:546
#24 0x00007f2bb5138974 in QApt::Transaction::qt_static_metacall (_o=0x2c92240, _c=<optimized out>, _id=<optimized out>, _a=0x7fff95c9c170) at /build/buildd/qapt-2.0.65/obj-x86_64-linux-gnu/src/moc_transaction.cxx:164
#25 0x00007f2bc83bca58 in QMetaObject::activate (sender=sender@entry=0x129e870, m=m@entry=0x7f2bb534daa0 <OrgKubuntuQaptworkerTransactionInterface::staticMetaObject>, local_signal_index=local_signal_index@entry=4, argv=argv@entry=0x7fff95c9c170) at kernel/qobject.cpp:3539
#26 0x00007f2bb51393d6 in OrgKubuntuQaptworkerTransactionInterface::propertyChanged (this=this@entry=0x129e870, _t1=11, _t2=...) at /build/buildd/qapt-2.0.65/obj-x86_64-linux-gnu/src/moc_transactiondbus.cxx:246
#27 0x00007f2bb513977c in OrgKubuntuQaptworkerTransactionInterface::qt_static_metacall (_o=_o@entry=0x129e870, _c=_c@entry=QMetaObject::InvokeMetaMethod, _id=_id@entry=4, _a=_a@entry=0x7fff95c9c430) at /build/buildd/qapt-2.0.65/obj-x86_64-linux-gnu/src/moc_transactiondbus.cxx:111
#28 0x00007f2bb513a0f7 in OrgKubuntuQaptworkerTransactionInterface::qt_metacall (this=0x129e870, _c=QMetaObject::InvokeMetaMethod, _id=4, _a=0x7fff95c9c430) at /build/buildd/qapt-2.0.65/obj-x86_64-linux-gnu/src/moc_transactiondbus.cxx:164
#29 0x00007f2bc7457e36 in QDBusConnectionPrivate::deliverCall (this=0x116dea0, object=0x129e870, msg=..., metaTypes=..., slotIdx=9) at qdbusintegrator.cpp:951
#30 0x00007f2bc83c0dce in QObject::event (this=0x129e870, e=<optimized out>) at kernel/qobject.cpp:1194
#31 0x00007f2bc8d99dfc in QApplicationPrivate::notify_helper (this=this@entry=0xf43500, receiver=receiver@entry=0x129e870, e=e@entry=0x2c8d450) at kernel/qapplication.cpp:4567
#32 0x00007f2bc8da0470 in QApplication::notify (this=this@entry=0x7fff95c9cbe0, receiver=receiver@entry=0x129e870, e=e@entry=0x2c8d450) at kernel/qapplication.cpp:4353
#33 0x00007f2bc9aa3a6a in KApplication::notify (this=0x7fff95c9cbe0, receiver=0x129e870, event=0x2c8d450) at ../../kdeui/kernel/kapplication.cpp:311
#34 0x00007f2bc83a88bd in QCoreApplication::notifyInternal (this=0x7fff95c9cbe0, receiver=receiver@entry=0x129e870, event=event@entry=0x2c8d450) at kernel/qcoreapplication.cpp:946
#35 0x00007f2bc83abe1f in sendEvent (event=0x2c8d450, receiver=0x129e870) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#36 QCoreApplicationPrivate::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0xf07500) at kernel/qcoreapplication.cpp:1570
#37 0x00007f2bc83ac2c3 in QCoreApplication::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0) at kernel/qcoreapplication.cpp:1463
#38 0x00007f2bc83d6073 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#39 postEventSourceDispatch (s=0xf38ee0) at kernel/qeventdispatcher_glib.cpp:279
#40 0x00007f2bc4fda3b6 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#41 0x00007f2bc4fda708 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#42 0x00007f2bc4fda7ac in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#43 0x00007f2bc83d5a55 in QEventDispatcherGlib::processEvents (this=0xf08de0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#44 0x00007f2bc8e3b9d6 in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#45 0x00007f2bc83a75ef in QEventLoop::processEvents (this=this@entry=0x7fff95c9cae0, flags=...) at kernel/qeventloop.cpp:149
#46 0x00007f2bc83a78e5 in QEventLoop::exec (this=this@entry=0x7fff95c9cae0, flags=...) at kernel/qeventloop.cpp:204
#47 0x00007f2bc83ace5b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1218
#48 0x00007f2bc8d9834c in QApplication::exec () at kernel/qapplication.cpp:3828
#49 0x000000000040ce11 in main (argc=1, argv=0x7fff95c9cd18) at /build/buildd/muon-2.1.1/updater/main.cpp:59

Possible duplicates by query: bug 328347, bug 327912, bug 327104, bug 327032, bug 326774.

Reported using DrKonqi
Comment 1 Jekyll Wu 2013-12-19 16:53:07 UTC

*** This bug has been marked as a duplicate of bug 325109 ***