Bug 298609 - Kmail crashed while selecting allrady opened Mail in inbox
Summary: Kmail crashed while selecting allrady opened Mail in inbox
Status: RESOLVED DUPLICATE of bug 286307
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: 4.8.2
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-04-22 15:54 UTC by Marcus Menzel
Modified: 2012-04-25 14:10 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marcus Menzel 2012-04-22 15:54:36 UTC
Application: kontact (4.8.2)
KDE Platform Version: 4.8.2 (4.8.2)
Qt Version: 4.8.1
Operating System: Linux 3.0.0-17-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:
Reading mails in the inbox. 
kmail was running for several hours whithout user interaction, but checked every 15min two servers for new mails

- Custom settings of the application:
my mails contain more than 250 000 mails with a total size of ~5 GB in ~15-20 folders, moved from kmail1

The crash can be reproduced some of the time.

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f88fdf9e7c0 (LWP 2467))]

Thread 4 (Thread 0x7f88e27fb700 (LWP 2468)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f88fa7d9c2c in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#2  0x00007f88fa7d9d59 in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#3  0x00007f88f5fa6efc in start_thread (arg=0x7f88e27fb700) at pthread_create.c:304
#4  0x00007f88fb4e959d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f88e1ee2700 (LWP 2469)):
#0  0x00007f88fb4dd473 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f88f5ad4f68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f88f5ad5429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f88fbc585a6 in QEventDispatcherGlib::processEvents (this=0x24744d0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f88fbc27d82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f88fbc27fd7 in QEventLoop::exec (this=0x7f88e1ee1dc0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f88fbb27077 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007f88fbb2a09b in QThreadPrivate::start (arg=0x2473860) at thread/qthread_unix.cpp:298
#8  0x00007f88f5fa6efc in start_thread (arg=0x7f88e1ee2700) at pthread_create.c:304
#9  0x00007f88fb4e959d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f889289c700 (LWP 2504)):
#0  0x00007f88fb4dd473 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f88f5ad4f68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f88f5ad5429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f88fbc585a6 in QEventDispatcherGlib::processEvents (this=0x3e34460, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f88fbc27d82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f88fbc27fd7 in QEventLoop::exec (this=0x7f889289bd90, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f88fbb27077 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007f88fbc07aff in QInotifyFileSystemWatcherEngine::run (this=0x54ccef0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f88fbb2a09b in QThreadPrivate::start (arg=0x54ccef0) at thread/qthread_unix.cpp:298
#9  0x00007f88f5fa6efc in start_thread (arg=0x7f889289c700) at pthread_create.c:304
#10 0x00007f88fb4e959d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f88fdf9e7c0 (LWP 2467)):
[KCrash Handler]
#6  QNetworkAccessHttpBackend::replyDownloadMetaData (this=0x101928a0, hm=<optimized out>, sc=<optimized out>, rp=<optimized out>, pu=<optimized out>, db=<optimized out>, contentLength=-1) at access/qnetworkaccesshttpbackend.cpp:827
#7  0x00007f88f6e07829 in QNetworkAccessHttpBackend::qt_static_metacall (_o=0x101928a0, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#8  0x00007f88fbc42546 in QObject::event (this=0x101928a0, e=<optimized out>) at kernel/qobject.cpp:1195
#9  0x00007f88fc61d2e4 in notify_helper (e=0x7f888c2acc40, receiver=0x101928a0, this=0x2326fb0) at kernel/qapplication.cpp:4559
#10 QApplicationPrivate::notify_helper (this=0x2326fb0, receiver=0x101928a0, e=0x7f888c2acc40) at kernel/qapplication.cpp:4531
#11 0x00007f88fc622163 in QApplication::notify (this=0x7fffedf72840, receiver=0x101928a0, e=0x7f888c2acc40) at kernel/qapplication.cpp:4420
#12 0x00007f88fd34fbf6 in KApplication::notify (this=0x7fffedf72840, receiver=0x101928a0, event=0x7f888c2acc40) at ../../kdeui/kernel/kapplication.cpp:311
#13 0x00007f88fbc28f9c in QCoreApplication::notifyInternal (this=0x7fffedf72840, receiver=0x101928a0, event=0x7f888c2acc40) at kernel/qcoreapplication.cpp:876
#14 0x00007f88fbc2cd6a in sendEvent (event=0x7f888c2acc40, receiver=0x101928a0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#15 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x22ec380) at kernel/qcoreapplication.cpp:1500
#16 0x00007f88fbc58113 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#17 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:279
#18 0x00007f88f5ad4a5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#19 0x00007f88f5ad5258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#20 0x00007f88f5ad5429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#21 0x00007f88fbc5853f in QEventDispatcherGlib::processEvents (this=0x22edc10, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#22 0x00007f88fc6c24ee in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#23 0x00007f88fbc27d82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#24 0x00007f88fbc27fd7 in QEventLoop::exec (this=0x7fffedf727d0, flags=...) at kernel/qeventloop.cpp:204
#25 0x00007f88fbc2d067 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#26 0x0000000000403629 in ?? ()
#27 0x00007f88fb42730d in __libc_start_main (main=0x402b40, argc=1, ubp_av=0x7fffedf72e68, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fffedf72e58) at libc-start.c:226
#28 0x0000000000403b71 in _start ()

This bug may be a duplicate of or related to bug 296613, bug 289879, bug 287656.

Possible duplicates by query: bug 298427, bug 298350, bug 298320, bug 297907, bug 297825.

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2012-04-25 14:10:24 UTC

*** This bug has been marked as a duplicate of bug 286307 ***