Bug 298350 - Kmail crash when click on href
Summary: Kmail crash when click on href
Status: RESOLVED DUPLICATE of bug 286307
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: 4.8.2
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-04-18 11:37 UTC by admin
Modified: 2012-04-18 22:29 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description admin 2012-04-18 11:37:54 UTC
Application: kontact (4.8.2)
KDE Platform Version: 4.8.2 (4.8.2)
Qt Version: 4.8.1
Operating System: Linux 3.0.0-19-generic-pae i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:
Click on href inside html message
Href did not open (firefox)

The crash can be reproduced some of the time.

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[Current thread is 1 (Thread 0xb265a730 (LWP 14695))]

Thread 3 (Thread 0xb015eb70 (LWP 14697)):
#0  0xb777a424 in __kernel_vsyscall ()
#1  0xb3c36a5c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i386-linux-gnu/libpthread.so.0
#2  0xb60ce09c in pthread_cond_wait () from /lib/i386-linux-gnu/libc.so.6
#3  0xb5873883 in ?? () from /usr/lib/i386-linux-gnu/libQtWebKit.so.4
#4  0xb587399f in ?? () from /usr/lib/i386-linux-gnu/libQtWebKit.so.4
#5  0xb3c32d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#6  0xb60c046e in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 2 (Thread 0xaf835b70 (LWP 14698)):
#0  0xb3c35d44 in __pthread_mutex_unlock_usercnt () from /lib/i386-linux-gnu/libpthread.so.0
#1  0xb60ce2f4 in pthread_mutex_unlock () from /lib/i386-linux-gnu/libc.so.6
#2  0xb3b5a87f in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb3b5b637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb3b5bc2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xb6406a97 in QEventDispatcherGlib::processEvents (this=0x91b2ac8, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0xb63d25ed in QEventLoop::processEvents (this=0xaf8352b0, flags=...) at kernel/qeventloop.cpp:149
#7  0xb63d2889 in QEventLoop::exec (this=0xaf8352b0, flags=...) at kernel/qeventloop.cpp:204
#8  0xb62bb9dc in QThread::exec (this=0x91b26a0) at thread/qthread.cpp:501
#9  0xb62bbacb in QThread::run (this=0x91b26a0) at thread/qthread.cpp:568
#10 0xb62bee70 in QThreadPrivate::start (arg=0x91b26a0) at thread/qthread_unix.cpp:298
#11 0xb3c32d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0xb60c046e in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb265a730 (LWP 14695)):
[KCrash Handler]
#7  QNetworkAccessHttpBackend::replyDownloadMetaData (this=0x9fcc558, hm=) at access/qnetworkaccesshttpbackend.cpp:827
#8  0xb3e3648d in QNetworkAccessHttpBackend::qt_static_metacall (_o=0x9fcc558, _c=QMetaObject::InvokeMetaMethod, _id=6, _a=0x9ae13a8) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#9  0xb63e5ce1 in QMetaCallEvent::placeMetaCall (this=0x9ae1378, object=0x9fcc558) at kernel/qobject.cpp:525
#10 0xb63eed5b in QObject::event (this=0x9fcc558, e=0x9ae1378) at kernel/qobject.cpp:1195
#11 0xb69389f4 in notify_helper (e=0x9ae1378, receiver=0x9fcc558, this=0x9063a08) at kernel/qapplication.cpp:4559
#12 QApplicationPrivate::notify_helper (this=0x9063a08, receiver=0x9fcc558, e=0x9ae1378) at kernel/qapplication.cpp:4531
#13 0xb693de2d in QApplication::notify (this=0x9ae1378, receiver=0x9fcc558, e=0x9ae1378) at kernel/qapplication.cpp:4288
#14 0xb74b6371 in KApplication::notify (this=0xbff83c14, receiver=0x9fcc558, event=0x9ae1378) at ../../kdeui/kernel/kapplication.cpp:311
#15 0xb63d3a5e in QCoreApplication::notifyInternal (this=0xbff83c14, receiver=0x9fcc558, event=0x9ae1378) at kernel/qcoreapplication.cpp:876
#16 0xb63d7bb8 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#17 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x9034ab8) at kernel/qcoreapplication.cpp:1500
#18 0xb63d7eec in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1393
#19 0xb6406644 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#20 postEventSourceDispatch (s=0x9068490) at kernel/qeventdispatcher_glib.cpp:279
#21 0xb3b5b25f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#22 0xb3b5b990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#23 0xb3b5bc2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#24 0xb6406a37 in QEventDispatcherGlib::processEvents (this=0x9035800, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#25 0xb69ee28a in QGuiEventDispatcherGlib::processEvents (this=0x9035800, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#26 0xb63d25ed in QEventLoop::processEvents (this=0xbff83b74, flags=...) at kernel/qeventloop.cpp:149
#27 0xb63d2889 in QEventLoop::exec (this=0xbff83b74, flags=...) at kernel/qeventloop.cpp:204
#28 0xb63d7f9a in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#29 0xb6936854 in QApplication::exec () at kernel/qapplication.cpp:3820
#30 0x0804ac91 in main (argc=) at ../../../kontact/src/main.cpp:218

Possible duplicates by query: bug 298320, bug 297907, bug 297825, bug 297500, bug 297468.

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2012-04-18 22:29:54 UTC

*** This bug has been marked as a duplicate of bug 286307 ***