Bug 297907 - kmail crashes when opening mail
Summary: kmail crashes when opening mail
Status: RESOLVED DUPLICATE of bug 286307
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: 4.8.2
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-04-11 16:07 UTC by Mathias Homann
Modified: 2012-04-12 07:57 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mathias Homann 2012-04-11 16:07:02 UTC
Application: kontact (4.8.2)
KDE Platform Version: 4.8.2 (4.8.2) "release 491"
Qt Version: 4.8.1
Operating System: Linux 3.1.9-1.4-desktop x86_64
Distribution: "openSUSE 12.1 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:

tried to read my email, going to "next unread" by keyboard shortcut

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f9d76b55760 (LWP 8646))]

Thread 10 (Thread 0x7f9d5e148700 (LWP 8647)):
#0  0x00007f9d6e9f0e6c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f9d73380c12 in ?? () from /usr/lib64/libQtWebKit.so.4
#2  0x00007f9d73380c49 in ?? () from /usr/lib64/libQtWebKit.so.4
#3  0x00007f9d6e9ecf05 in start_thread () from /lib64/libpthread.so.0
#4  0x00007f9d7407210d in clone () from /lib64/libc.so.6

Thread 9 (Thread 0x7f9d5d847700 (LWP 8648)):
#0  0x00007f9d74068ff3 in poll () from /lib64/libc.so.6
#1  0x00007f9d6e4dda98 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f9d6e4ddf59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f9d747e02e6 in QEventDispatcherGlib::processEvents (this=0x7f9d580008c0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f9d747b0012 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f9d747b0267 in QEventLoop::exec (this=0x7f9d5d846e20, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f9d746b0547 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007f9d746b356b in QThreadPrivate::start (arg=0x8dfde0) at thread/qthread_unix.cpp:298
#8  0x00007f9d6e9ecf05 in start_thread () from /lib64/libpthread.so.0
#9  0x00007f9d7407210d in clone () from /lib64/libc.so.6

Thread 8 (Thread 0x7f9d10788700 (LWP 8653)):
#0  0x00007f9d6e9f11eb in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f9d746b39df in wait (time=30000, this=0x10bdf40) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x10bdee8, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f9d746a6def in QThreadPoolThread::run (this=0x10d13c0) at concurrent/qthreadpool.cpp:141
#4  0x00007f9d746b356b in QThreadPrivate::start (arg=0x10d13c0) at thread/qthread_unix.cpp:298
#5  0x00007f9d6e9ecf05 in start_thread () from /lib64/libpthread.so.0
#6  0x00007f9d7407210d in clone () from /lib64/libc.so.6

Thread 7 (Thread 0x7f9d027ff700 (LWP 8680)):
#0  0x00007f9d74068ff3 in poll () from /lib64/libc.so.6
#1  0x00007f9d6e4dda98 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f9d6e4ddf59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f9d747e02e6 in QEventDispatcherGlib::processEvents (this=0x7f9cfc0008c0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f9d747b0012 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f9d747b0267 in QEventLoop::exec (this=0x7f9d027fedf0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f9d746b0547 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007f9d7478fdff in QInotifyFileSystemWatcherEngine::run (this=0x1441b10) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f9d746b356b in QThreadPrivate::start (arg=0x1441b10) at thread/qthread_unix.cpp:298
#9  0x00007f9d6e9ecf05 in start_thread () from /lib64/libpthread.so.0
#10 0x00007f9d7407210d in clone () from /lib64/libc.so.6

Thread 6 (Thread 0x7f9cfb584700 (LWP 8741)):
#0  0x00007f9d6e9f11eb in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f9d746b39df in wait (time=30000, this=0x2ed0480) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x2ec5ec8, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f9d746a6def in QThreadPoolThread::run (this=0x2ed11d0) at concurrent/qthreadpool.cpp:141
#4  0x00007f9d746b356b in QThreadPrivate::start (arg=0x2ed11d0) at thread/qthread_unix.cpp:298
#5  0x00007f9d6e9ecf05 in start_thread () from /lib64/libpthread.so.0
#6  0x00007f9d7407210d in clone () from /lib64/libc.so.6

Thread 5 (Thread 0x7f9cf189d700 (LWP 8753)):
#0  0x00007f9d6e9f11eb in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f9d746b39df in wait (time=30000, this=0x7f9cec005f40) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x7f9cec005ee8, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f9d746a6def in QThreadPoolThread::run (this=0x7f9cec0061e0) at concurrent/qthreadpool.cpp:141
#4  0x00007f9d746b356b in QThreadPrivate::start (arg=0x7f9cec0061e0) at thread/qthread_unix.cpp:298
#5  0x00007f9d6e9ecf05 in start_thread () from /lib64/libpthread.so.0
#6  0x00007f9d7407210d in clone () from /lib64/libc.so.6

Thread 4 (Thread 0x7f9cf109c700 (LWP 8755)):
#0  0x00007f9d6e9f11eb in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f9d746b39df in wait (time=30000, this=0x7f9cec005f40) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x7f9cec005ee8, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f9d746a6def in QThreadPoolThread::run (this=0x7f9cec00a360) at concurrent/qthreadpool.cpp:141
#4  0x00007f9d746b356b in QThreadPrivate::start (arg=0x7f9cec00a360) at thread/qthread_unix.cpp:298
#5  0x00007f9d6e9ecf05 in start_thread () from /lib64/libpthread.so.0
#6  0x00007f9d7407210d in clone () from /lib64/libc.so.6

Thread 3 (Thread 0x7f9cf089b700 (LWP 8757)):
#0  0x00007f9d6e9f11eb in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f9d746b39df in wait (time=30000, this=0x7f9cec005f40) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x7f9cec005ee8, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f9d746a6def in QThreadPoolThread::run (this=0x7f9cec00e4c0) at concurrent/qthreadpool.cpp:141
#4  0x00007f9d746b356b in QThreadPrivate::start (arg=0x7f9cec00e4c0) at thread/qthread_unix.cpp:298
#5  0x00007f9d6e9ecf05 in start_thread () from /lib64/libpthread.so.0
#6  0x00007f9d7407210d in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7f9ce3fff700 (LWP 8758)):
#0  0x00007f9d6e9f11eb in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f9d746b39df in wait (time=30000, this=0x7f9cec005f40) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x7f9cec005ee8, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f9d746a6def in QThreadPoolThread::run (this=0x7f9cec0126a0) at concurrent/qthreadpool.cpp:141
#4  0x00007f9d746b356b in QThreadPrivate::start (arg=0x7f9cec0126a0) at thread/qthread_unix.cpp:298
#5  0x00007f9d6e9ecf05 in start_thread () from /lib64/libpthread.so.0
#6  0x00007f9d7407210d in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f9d76b55760 (LWP 8646)):
[KCrash Handler]
#6  QNetworkAccessHttpBackend::replyDownloadMetaData (this=0x3cf49f0, hm=<optimized out>, sc=<optimized out>, rp=<optimized out>, pu=<optimized out>, db=<optimized out>, contentLength=-1) at access/qnetworkaccesshttpbackend.cpp:827
#7  0x00007f9d6f9b7909 in QNetworkAccessHttpBackend::qt_static_metacall (_o=0x3cf49f0, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#8  0x00007f9d747ca2b6 in QObject::event (this=0x3cf49f0, e=<optimized out>) at kernel/qobject.cpp:1204
#9  0x00007f9d751c50d4 in notify_helper (e=0x7f9cec008d90, receiver=0x3cf49f0, this=0x639710) at kernel/qapplication.cpp:4554
#10 QApplicationPrivate::notify_helper (this=0x639710, receiver=0x3cf49f0, e=0x7f9cec008d90) at kernel/qapplication.cpp:4526
#11 0x00007f9d751c9f53 in QApplication::notify (this=0x7fff5681b060, receiver=0x3cf49f0, e=0x7f9cec008d90) at kernel/qapplication.cpp:4415
#12 0x00007f9d75f09886 in KApplication::notify (this=0x7fff5681b060, receiver=0x3cf49f0, event=0x7f9cec008d90) at /usr/src/debug/kdelibs-4.8.2/kdeui/kernel/kapplication.cpp:311
#13 0x00007f9d747b122c in QCoreApplication::notifyInternal (this=0x7fff5681b060, receiver=0x3cf49f0, event=0x7f9cec008d90) at kernel/qcoreapplication.cpp:876
#14 0x00007f9d747b4aca in sendEvent (event=0x7f9cec008d90, receiver=0x3cf49f0) at kernel/qcoreapplication.h:231
#15 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x60da60) at kernel/qcoreapplication.cpp:1500
#16 0x00007f9d747dfe53 in sendPostedEvents () at kernel/qcoreapplication.h:236
#17 postEventSourceDispatch (s=0x63b400) at kernel/qeventdispatcher_glib.cpp:279
#18 0x00007f9d6e4dd58d in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#19 0x00007f9d6e4ddd88 in ?? () from /usr/lib64/libglib-2.0.so.0
#20 0x00007f9d6e4ddf59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#21 0x00007f9d747e027f in QEventDispatcherGlib::processEvents (this=0x60d320, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#22 0x00007f9d7526876e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#23 0x00007f9d747b0012 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#24 0x00007f9d747b0267 in QEventLoop::exec (this=0x7fff5681aff0, flags=...) at kernel/qeventloop.cpp:204
#25 0x00007f9d747b4dc5 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#26 0x0000000000403919 in ?? ()
#27 0x00007f9d73fb823d in __libc_start_main () from /lib64/libc.so.6
#28 0x0000000000403e51 in _start ()

Possible duplicates by query: bug 297825, bug 297500, bug 297468, bug 297174, bug 297059.

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2012-04-12 07:57:32 UTC

*** This bug has been marked as a duplicate of bug 286307 ***