Bug 296613 - Kontact crash switching beetween emails
Summary: Kontact crash switching beetween emails
Status: RESOLVED DUPLICATE of bug 286307
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-23 11:20 UTC by dharman
Modified: 2012-03-26 22:19 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description dharman 2012-03-23 11:20:49 UTC
Application: kontact (4.8.0)
KDE Platform Version: 4.8.1 (4.8.1)
Qt Version: 4.8.0
Operating System: Linux 3.0.0-16-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:
1)Select new unread email 
2)Select another unread email
3)Sometimes (frequently but not always) Kontact crash!

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[Current thread is 1 (Thread 0xb773f730 (LWP 27175))]

Thread 4 (Thread 0xb5ca9b70 (LWP 27177)):
#0  0x00d70416 in __kernel_vsyscall ()
#1  0x00bcca5c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i386-linux-gnu/libpthread.so.0
#2  0x0023809c in pthread_cond_wait () from /lib/i386-linux-gnu/libc.so.6
#3  0x073af883 in ?? () from /usr/lib/i386-linux-gnu/libQtWebKit.so.4
#4  0x073af99f in ?? () from /usr/lib/i386-linux-gnu/libQtWebKit.so.4
#5  0x00bc8d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#6  0x0022a46e in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 3 (Thread 0xb5380b70 (LWP 27178)):
#0  0x00d65d10 in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0x04885e35 in do_gettime (frac=0xb5380030, sec=0xb5380028) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0x0496fb56 in QTimerInfoList::updateCurrentTime (this=0x8435274) at kernel/qeventdispatcher_unix.cpp:343
#4  0x0496feaa in QTimerInfoList::timerWait (this=0x8435274, tm=...) at kernel/qeventdispatcher_unix.cpp:450
#5  0x0496e6c3 in timerSourcePrepareHelper (src=<optimized out>, timeout=0xb538011c) at kernel/qeventdispatcher_glib.cpp:136
#6  0x0288188c in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#7  0x02882637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0x02882c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0x0496f217 in QEventDispatcherGlib::processEvents (this=0x8433a30, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#10 0x0493ad6d in QEventLoop::processEvents (this=0xb53802b0, flags=...) at kernel/qeventloop.cpp:149
#11 0x0493b009 in QEventLoop::exec (this=0xb53802b0, flags=...) at kernel/qeventloop.cpp:204
#12 0x048249dc in QThread::exec (this=0x8433640) at thread/qthread.cpp:501
#13 0x04824acb in QThread::run (this=0x8433640) at thread/qthread.cpp:568
#14 0x04827e70 in QThreadPrivate::start (arg=0x8433640) at thread/qthread_unix.cpp:298
#15 0x00bc8d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#16 0x0022a46e in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 2 (Thread 0xb229fb70 (LWP 27246)):
#0  0x0288188c in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#1  0x02882637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0x02882c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x0496f217 in QEventDispatcherGlib::processEvents (this=0x9034b28, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x0493ad6d in QEventLoop::processEvents (this=0xb229f280, flags=...) at kernel/qeventloop.cpp:149
#5  0x0493b009 in QEventLoop::exec (this=0xb229f280, flags=...) at kernel/qeventloop.cpp:204
#6  0x048249dc in QThread::exec (this=0x8623730) at thread/qthread.cpp:501
#7  0x049182dd in QInotifyFileSystemWatcherEngine::run (this=0x8623730) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x04827e70 in QThreadPrivate::start (arg=0x8623730) at thread/qthread_unix.cpp:298
#9  0x00bc8d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#10 0x0022a46e in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb773f730 (LWP 27175)):
[KCrash Handler]
#7  0x05918f0d in QNetworkAccessHttpBackend::replyDownloadMetaData (this=0xa4a6300, hm=) at access/qnetworkaccesshttpbackend.cpp:827
#8  0x059afd0d in QNetworkAccessHttpBackend::qt_static_metacall (_o=0xa4a6300, _c=QMetaObject::InvokeMetaMethod, _id=6, _a=0xae914068) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#9  0x0494e461 in QMetaCallEvent::placeMetaCall (this=0xae914020, object=0xa4a6300) at kernel/qobject.cpp:525
#10 0x049574db in QObject::event (this=0xa4a6300, e=0xae914020) at kernel/qobject.cpp:1195
#11 0x00eab844 in notify_helper (e=0xae914020, receiver=0xa4a6300, this=0x82da538) at kernel/qapplication.cpp:4555
#12 QApplicationPrivate::notify_helper (this=0x82da538, receiver=0xa4a6300, e=0xae914020) at kernel/qapplication.cpp:4527
#13 0x00eb0c7d in QApplication::notify (this=0xae914020, receiver=0xa4a6300, e=0xae914020) at kernel/qapplication.cpp:4284
#14 0x0084d051 in KApplication::notify (this=0xbffb4e74, receiver=0xa4a6300, event=0xae914020) at ../../kdeui/kernel/kapplication.cpp:311
#15 0x0493c1de in QCoreApplication::notifyInternal (this=0xbffb4e74, receiver=0xa4a6300, event=0xae914020) at kernel/qcoreapplication.cpp:876
#16 0x04940338 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#17 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x82acab8) at kernel/qcoreapplication.cpp:1500
#18 0x0494066c in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1393
#19 0x0496edc4 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#20 postEventSourceDispatch (s=0x82de1f0) at kernel/qeventdispatcher_glib.cpp:279
#21 0x0288225f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#22 0x02882990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#23 0x02882c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#24 0x0496f1b7 in QEventDispatcherGlib::processEvents (this=0x82ad800, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#25 0x00f6106a in QGuiEventDispatcherGlib::processEvents (this=0x82ad800, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#26 0x0493ad6d in QEventLoop::processEvents (this=0xbffb4dd4, flags=...) at kernel/qeventloop.cpp:149
#27 0x0493b009 in QEventLoop::exec (this=0xbffb4dd4, flags=...) at kernel/qeventloop.cpp:204
#28 0x0494071a in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#29 0x00ea96a4 in QApplication::exec () at kernel/qapplication.cpp:3816
#30 0x0804ac91 in main (argc=) at ../../../kontact/src/main.cpp:218

This bug may be a duplicate of or related to bug 295978.

Possible duplicates by query: bug 296485, bug 296042, bug 296009, bug 295978, bug 295786.

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2012-03-26 22:19:49 UTC

*** This bug has been marked as a duplicate of bug 286307 ***