Bug 287656 - Kmail crash while reading email
Summary: Kmail crash while reading email
Status: RESOLVED DUPLICATE of bug 286307
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-11-27 03:29 UTC by Alan House
Modified: 2011-11-27 09:50 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alan House 2011-11-27 03:29:44 UTC
Application: kontact (4.7.3)
KDE Platform Version: 4.7.3 (4.7.3) (Compiled from sources)
Qt Version: 4.8.0
Operating System: Linux 3.1.2-1.fc16.x86_64 x86_64
Distribution: "Fedora release 16 (Verne)"

-- Information about the crash:
- What I was doing when the application crashed:

Reading email newsletter. Crash occured after I selected a new message then went back to an old message (Previous).

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
82	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[Current thread is 1 (Thread 0x7fe6fc259840 (LWP 23973))]

Thread 3 (Thread 0x7fe6f19b9700 (LWP 23977)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:165
#1  0x0000003c1a7973cc in WTF::TCMalloc_PageHeap::scavengerThread (this=0x3c1b190f80) at ../../../Source/JavaScriptCore/wtf/FastMalloc.cpp:2495
#2  0x0000003c1a7974f9 in WTF::TCMalloc_PageHeap::runScavengerThread (context=<optimized out>) at ../../../Source/JavaScriptCore/wtf/FastMalloc.cpp:1618
#3  0x0000003529007d90 in start_thread (arg=0x7fe6f19b9700) at pthread_create.c:309
#4  0x00000035284eed8d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 2 (Thread 0x7fe6f10b8700 (LWP 23978)):
#0  0x00007fff0fb5498f in clock_gettime ()
#1  0x00000035298041f1 in __GI_clock_gettime (clock_id=1, tp=0x7fe6f10b7b00) at ../sysdeps/unix/clock_gettime.c:100
#2  0x0000003c0ecd2004 in do_gettime (frac=0x7fe6f10b7b18, sec=0x7fe6f10b7b10) at tools/qelapsedtimer_unix.cpp:123
#3  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#4  0x0000003c0eda6f9d in QTimerInfoList::updateCurrentTime (this=0x7fe6ec0020d0) at kernel/qeventdispatcher_unix.cpp:343
#5  0x0000003c0eda6cb1 in timerSourceCheckHelper (src=<optimized out>) at kernel/qeventdispatcher_glib.cpp:150
#6  timerSourceCheckHelper (src=<optimized out>) at kernel/qeventdispatcher_glib.cpp:144
#7  0x000000352b044754 in g_main_context_check (context=0x7fe6ec0009a0, max_priority=2147483647, fds=<optimized out>, n_fds=<optimized out>) at gmain.c:2943
#8  0x000000352b044fa2 in g_main_context_iterate (context=0x7fe6ec0009a0, block=<optimized out>, dispatch=1, self=<optimized out>) at gmain.c:3070
#9  0x000000352b04544c in g_main_context_iteration (context=0x7fe6ec0009a0, may_block=1) at gmain.c:3136
#10 0x0000003c0eda6896 in QEventDispatcherGlib::processEvents (this=0x7fe6ec0008c0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:426
#11 0x0000003c0ed76c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#12 0x0000003c0ed76ed7 in QEventLoop::exec (this=0x7fe6f10b7d40, flags=...) at kernel/qeventloop.cpp:204
#13 0x0000003c0ec78ad7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#14 0x0000003c0ec7bb1b in QThreadPrivate::start (arg=0x160fc80) at thread/qthread_unix.cpp:298
#15 0x0000003529007d90 in start_thread (arg=0x7fe6f10b8700) at pthread_create.c:309
#16 0x00000035284eed8d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 1 (Thread 0x7fe6fc259840 (LWP 23973)):
[KCrash Handler]
#6  QNetworkAccessHttpBackend::replyDownloadMetaData (this=0x4bea190, hm=<optimized out>, sc=<optimized out>, rp=<optimized out>, pu=<optimized out>, db=<optimized out>, contentLength=-1) at access/qnetworkaccesshttpbackend.cpp:827
#7  0x0000003c100f4ef9 in QNetworkAccessHttpBackend::qt_static_metacall (_o=0x4bea190, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#8  0x0000003c0ed909e6 in QObject::event (this=0x4bea190, e=<optimized out>) at kernel/qobject.cpp:1194
#9  0x0000003c0f3c96f4 in notify_helper (e=0x7fe68400a610, receiver=0x4bea190, this=0x143fd20) at kernel/qapplication.cpp:4518
#10 QApplicationPrivate::notify_helper (this=0x143fd20, receiver=0x4bea190, e=0x7fe68400a610) at kernel/qapplication.cpp:4490
#11 0x0000003c0f3ce573 in QApplication::notify (this=0x7fff0fa15f00, receiver=0x4bea190, e=0x7fe68400a610) at kernel/qapplication.cpp:4379
#12 0x0000003c11850396 in KApplication::notify (this=0x7fff0fa15f00, receiver=0x4bea190, event=0x7fe68400a610) at /usr/src/debug/kdelibs-4.7.3/kdeui/kernel/kapplication.cpp:311
#13 0x0000003c0ed77b4c in QCoreApplication::notifyInternal (this=0x7fff0fa15f00, receiver=0x4bea190, event=0x7fe68400a610) at kernel/qcoreapplication.cpp:876
#14 0x0000003c0ed7b5da in sendEvent (event=0x7fe68400a610, receiver=0x4bea190) at kernel/qcoreapplication.h:231
#15 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x1411050) at kernel/qcoreapplication.cpp:1500
#16 0x0000003c0eda6403 in sendPostedEvents () at kernel/qcoreapplication.h:236
#17 postEventSourceDispatch (s=0x144a0f0) at kernel/qeventdispatcher_glib.cpp:279
#18 0x000000352b044a7d in g_main_dispatch (context=0x144a000) at gmain.c:2425
#19 g_main_context_dispatch (context=0x144a000) at gmain.c:2995
#20 0x000000352b045278 in g_main_context_iterate (context=0x144a000, block=<optimized out>, dispatch=1, self=<optimized out>) at gmain.c:3073
#21 0x000000352b04544c in g_main_context_iteration (context=0x144a000, may_block=1) at gmain.c:3136
#22 0x0000003c0eda682f in QEventDispatcherGlib::processEvents (this=0x1412510, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#23 0x0000003c0f46c43e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:207
#24 0x0000003c0ed76c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#25 0x0000003c0ed76ed7 in QEventLoop::exec (this=0x7fff0fa15e90, flags=...) at kernel/qeventloop.cpp:204
#26 0x0000003c0ed7b8d5 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#27 0x00000000004037b9 in main (argc=1, argv=0x7fff0fa16528) at /usr/src/debug/kdepim-4.7.3/kontact/src/main.cpp:218

Possible duplicates by query: bug 287479, bug 286962, bug 286307.

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2011-11-27 09:50:53 UTC

*** This bug has been marked as a duplicate of bug 286307 ***