Bug 298320 - kontact crashes while deleting email
Summary: kontact crashes while deleting email
Status: RESOLVED DUPLICATE of bug 286307
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: 4.8.1
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-04-17 19:07 UTC by Roel
Modified: 2012-04-18 22:30 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Roel 2012-04-17 19:07:58 UTC
Application: kontact (4.8.1)
KDE Platform Version: 4.8.1 (4.8.1)
Qt Version: 4.8.0
Operating System: Linux 3.3.1-5.fc16.x86_64 x86_64
Distribution (Platform): Fedora RPMs

-- Information about the crash:
I was deleting a lot of emails, one by one, and kontact crashes after you delete a yet unknown number of emails (I can repeat this every time i delete a lot of messages in succession)

The crash can be reproduced some of the time.

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
82	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[Current thread is 1 (Thread 0x7f33277e4840 (LWP 1928))]

Thread 9 (Thread 0x7f331b08e700 (LWP 1936)):
#0  0x000000390cebd7bd in nanosleep () at ../sysdeps/unix/syscall-template.S:82
#1  0x000000390cebd65c in __sleep (seconds=0) at ../sysdeps/unix/sysv/linux/sleep.c:138
#2  0x000000319c1b8547 in WTF::TCMalloc_PageHeap::scavengerThread (this=0x319cb7cc20) at ../../../Source/JavaScriptCore/wtf/FastMalloc.cpp:2499
#3  0x000000319c1b8819 in WTF::TCMalloc_PageHeap::runScavengerThread (context=<optimized out>) at ../../../Source/JavaScriptCore/wtf/FastMalloc.cpp:1618
#4  0x000000390d607d90 in start_thread (arg=0x7f331b08e700) at pthread_create.c:309
#5  0x000000390cef0f5d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 8 (Thread 0x7f331a77d700 (LWP 1938)):
#0  0x000000390cee85c3 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x000000390ee44fd8 in g_main_context_poll (n_fds=1, fds=0x7f33140013e0, priority=<optimized out>, timeout=8855, context=0x7f33140009a0) at gmain.c:3402
#2  g_main_context_iterate (context=0x7f33140009a0, block=<optimized out>, dispatch=1, self=<optimized out>) at gmain.c:3084
#3  0x000000390ee4549c in g_main_context_iteration (context=0x7f33140009a0, may_block=1) at gmain.c:3152
#4  0x000000327ffa7dc6 in QEventDispatcherGlib::processEvents (this=0x7f33140008c0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:426
#5  0x000000327ff78182 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x000000327ff783d7 in QEventLoop::exec (this=0x7f331a77cd40, flags=...) at kernel/qeventloop.cpp:204
#7  0x000000327fe78b27 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#8  0x000000327fe7bb6b in QThreadPrivate::start (arg=0xba1ce0) at thread/qthread_unix.cpp:298
#9  0x000000390d607d90 in start_thread (arg=0x7f331a77d700) at pthread_create.c:309
#10 0x000000390cef0f5d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 7 (Thread 0x7f32c234d700 (LWP 2510)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:216
#1  0x000000327fe7bfdf in wait (time=30000, this=0x141d0e0) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x141d088, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x000000327fe6f5af in QThreadPoolThread::run (this=0x142f550) at concurrent/qthreadpool.cpp:141
#4  0x000000327fe7bb6b in QThreadPrivate::start (arg=0x142f550) at thread/qthread_unix.cpp:298
#5  0x000000390d607d90 in start_thread (arg=0x7f32c234d700) at pthread_create.c:309
#6  0x000000390cef0f5d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 6 (Thread 0x7f32bbfff700 (LWP 2515)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:216
#1  0x000000327fe7bfdf in wait (time=30000, this=0x23dcc10) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x23dcb88, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x000000327fe6f5af in QThreadPoolThread::run (this=0x23ddb00) at concurrent/qthreadpool.cpp:141
#4  0x000000327fe7bb6b in QThreadPrivate::start (arg=0x23ddb00) at thread/qthread_unix.cpp:298
#5  0x000000390d607d90 in start_thread (arg=0x7f32bbfff700) at pthread_create.c:309
#6  0x000000390cef0f5d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 5 (Thread 0x7f32bb7fe700 (LWP 2548)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:216
#1  0x000000327fe7bfdf in wait (time=30000, this=0x7f32c4002510) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x7f32c40037f8, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x000000327fe6f5af in QThreadPoolThread::run (this=0x7f32a8011a20) at concurrent/qthreadpool.cpp:141
#4  0x000000327fe7bb6b in QThreadPrivate::start (arg=0x7f32a8011a20) at thread/qthread_unix.cpp:298
#5  0x000000390d607d90 in start_thread (arg=0x7f32bb7fe700) at pthread_create.c:309
#6  0x000000390cef0f5d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 4 (Thread 0x7f32ba7fc700 (LWP 2648)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:216
#1  0x000000327fe7bfdf in wait (time=30000, this=0x7f32c4002510) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x7f32c40037f8, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x000000327fe6f5af in QThreadPoolThread::run (this=0x7f32b4007210) at concurrent/qthreadpool.cpp:141
#4  0x000000327fe7bb6b in QThreadPrivate::start (arg=0x7f32b4007210) at thread/qthread_unix.cpp:298
#5  0x000000390d607d90 in start_thread (arg=0x7f32ba7fc700) at pthread_create.c:309
#6  0x000000390cef0f5d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 3 (Thread 0x7f32d0ea7700 (LWP 2649)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:216
#1  0x000000327fe7bfdf in wait (time=30000, this=0x7f32c4002510) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x7f32c40037f8, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x000000327fe6f5af in QThreadPoolThread::run (this=0x7f32b400ca90) at concurrent/qthreadpool.cpp:141
#4  0x000000327fe7bb6b in QThreadPrivate::start (arg=0x7f32b400ca90) at thread/qthread_unix.cpp:298
#5  0x000000390d607d90 in start_thread (arg=0x7f32d0ea7700) at pthread_create.c:309
#6  0x000000390cef0f5d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 2 (Thread 0x7f32baffd700 (LWP 2650)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:216
#1  0x000000327fe7bfdf in wait (time=30000, this=0x7f32c4002510) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x7f32c40037f8, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x000000327fe6f5af in QThreadPoolThread::run (this=0x7f32a800d9b0) at concurrent/qthreadpool.cpp:141
#4  0x000000327fe7bb6b in QThreadPrivate::start (arg=0x7f32a800d9b0) at thread/qthread_unix.cpp:298
#5  0x000000390d607d90 in start_thread (arg=0x7f32baffd700) at pthread_create.c:309
#6  0x000000390cef0f5d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 1 (Thread 0x7f33277e4840 (LWP 1928)):
[KCrash Handler]
#6  QNetworkAccessHttpBackend::replyDownloadMetaData (this=0x25a5730, hm=<optimized out>, sc=<optimized out>, rp=<optimized out>, pu=<optimized out>, db=<optimized out>, contentLength=-1) at access/qnetworkaccesshttpbackend.cpp:827
#7  0x00000031954f6409 in QNetworkAccessHttpBackend::qt_static_metacall (_o=0x25a5730, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#8  0x000000327ff91f16 in QObject::event (this=0x25a5730, e=<optimized out>) at kernel/qobject.cpp:1195
#9  0x00000030fd3c9994 in notify_helper (e=0x7f32b4019c00, receiver=0x25a5730, this=0xb97bc0) at kernel/qapplication.cpp:4550
#10 QApplicationPrivate::notify_helper (this=0xb97bc0, receiver=0x25a5730, e=0x7f32b4019c00) at kernel/qapplication.cpp:4522
#11 0x00000030fd3ce813 in QApplication::notify (this=0x7fff0f09b7f0, receiver=0x25a5730, e=0x7f32b4019c00) at kernel/qapplication.cpp:4411
#12 0x0000003195a51d56 in KApplication::notify (this=0x7fff0f09b7f0, receiver=0x25a5730, event=0x7f32b4019c00) at /usr/src/debug/kdelibs-4.8.1/kdeui/kernel/kapplication.cpp:311
#13 0x000000327ff7904c in QCoreApplication::notifyInternal (this=0x7fff0f09b7f0, receiver=0x25a5730, event=0x7f32b4019c00) at kernel/qcoreapplication.cpp:876
#14 0x000000327ff7cada in sendEvent (event=0x7f32b4019c00, receiver=0x25a5730) at kernel/qcoreapplication.h:231
#15 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0xb60600) at kernel/qcoreapplication.cpp:1500
#16 0x000000327ffa7933 in sendPostedEvents () at kernel/qcoreapplication.h:236
#17 postEventSourceDispatch (s=0xba76a0) at kernel/qeventdispatcher_glib.cpp:279
#18 0x000000390ee44acd in g_main_dispatch (context=0xba5de0) at gmain.c:2441
#19 g_main_context_dispatch (context=0xba5de0) at gmain.c:3011
#20 0x000000390ee452c8 in g_main_context_iterate (context=0xba5de0, block=<optimized out>, dispatch=1, self=<optimized out>) at gmain.c:3089
#21 0x000000390ee4549c in g_main_context_iteration (context=0xba5de0, may_block=1) at gmain.c:3152
#22 0x000000327ffa7d5f in QEventDispatcherGlib::processEvents (this=0xb9b1b0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#23 0x00000030fd46c66e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:207
#24 0x000000327ff78182 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#25 0x000000327ff783d7 in QEventLoop::exec (this=0x7fff0f09b780, flags=...) at kernel/qeventloop.cpp:204
#26 0x000000327ff7cdd5 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#27 0x00000000004036e9 in main (argc=3, argv=0x7fff0f09be18) at /usr/src/debug/kdepim-4.8.1/kontact/src/main.cpp:218

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2012-04-18 22:30:57 UTC

*** This bug has been marked as a duplicate of bug 286307 ***