Bug 298427 - Kontact
Summary: Kontact
Status: RESOLVED DUPLICATE of bug 286307
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: 4.8.2
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-04-19 16:47 UTC by rudolfwetzels
Modified: 2012-04-20 12:16 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description rudolfwetzels 2012-04-19 16:47:04 UTC
Application: kontact (4.8.2)
KDE Platform Version: 4.8.2 (4.8.2) "release 491" (Compiled from sources)
Qt Version: 4.8.1
Operating System: Linux 3.1.9-1.4-desktop x86_64
Distribution: "openSUSE 12.1 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:Kontact crashes very often when opening mail and delete the mails

The crash can be reproduced every time.

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fbeaa414760 (LWP 4707))]

Thread 3 (Thread 0x7fbe92068700 (LWP 4708)):
#0  0x00007fbea2299e6c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fbea6c29c12 in ?? () from /usr/lib64/libQtWebKit.so.4
#2  0x00007fbea6c29c49 in ?? () from /usr/lib64/libQtWebKit.so.4
#3  0x00007fbea2295f05 in start_thread () from /lib64/libpthread.so.0
#4  0x00007fbea791b10d in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7fbe91757700 (LWP 4709)):
#0  0x00007fff5e9208de in ?? ()
#1  0x00007fbe9fd71d9a in clock_gettime () from /lib64/librt.so.1
#2  0x00007fbea7fb2f64 in do_gettime (frac=0x7fbe91756bc8, sec=0x7fbe91756bc0) at tools/qelapsedtimer_unix.cpp:123
#3  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#4  0x00007fbea8089a4d in QTimerInfoList::updateCurrentTime (this=0x7fbe8c0020d0) at kernel/qeventdispatcher_unix.cpp:343
#5  0x00007fbea8089d83 in QTimerInfoList::timerWait (this=0x7fbe8c0020d0, tm=...) at kernel/qeventdispatcher_unix.cpp:450
#6  0x00007fbea80887bc in timerSourcePrepareHelper (src=<optimized out>, timeout=0x7fbe91756c8c) at kernel/qeventdispatcher_glib.cpp:136
#7  0x00007fbea1d85b22 in g_main_context_prepare () from /usr/lib64/libglib-2.0.so.0
#8  0x00007fbea1d8692d in ?? () from /usr/lib64/libglib-2.0.so.0
#9  0x00007fbea1d86f59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#10 0x00007fbea80892e6 in QEventDispatcherGlib::processEvents (this=0x7fbe8c0008c0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:426
#11 0x00007fbea8059012 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#12 0x00007fbea8059267 in QEventLoop::exec (this=0x7fbe91756e20, flags=...) at kernel/qeventloop.cpp:204
#13 0x00007fbea7f59547 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#14 0x00007fbea7f5c56b in QThreadPrivate::start (arg=0x69c4f0) at thread/qthread_unix.cpp:298
#15 0x00007fbea2295f05 in start_thread () from /lib64/libpthread.so.0
#16 0x00007fbea791b10d in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7fbeaa414760 (LWP 4707)):
[KCrash Handler]
#6  QList (l=..., this=0x7fff5e878b30) at ../../src/corelib/tools/qlist.h:122
#7  QNetworkCacheMetaData::rawHeaders (this=0x7fff5e878e40) at access/qabstractnetworkcache.cpp:240
#8  0x00007fbea31d391c in QNetworkAccessHttpBackend::fetchCacheMetaData (this=0x3638870, oldMetaData=...) at access/qnetworkaccesshttpbackend.cpp:1019
#9  0x00007fbea31d5074 in QNetworkAccessHttpBackend::replyDownloadMetaData (this=0x3638870, hm=<optimized out>, sc=<optimized out>, rp=<optimized out>, pu=<optimized out>, db=<optimized out>, contentLength=-1) at access/qnetworkaccesshttpbackend.cpp:828
#10 0x00007fbea3260909 in QNetworkAccessHttpBackend::qt_static_metacall (_o=0x3638870, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#11 0x00007fbea80732b6 in QObject::event (this=0x3638870, e=<optimized out>) at kernel/qobject.cpp:1204
#12 0x00007fbea8a6e0d4 in notify_helper (e=0x7fbe18056180, receiver=0x3638870, this=0x63a100) at kernel/qapplication.cpp:4554
#13 QApplicationPrivate::notify_helper (this=0x63a100, receiver=0x3638870, e=0x7fbe18056180) at kernel/qapplication.cpp:4526
#14 0x00007fbea8a72f53 in QApplication::notify (this=0x7fff5e8798c0, receiver=0x3638870, e=0x7fbe18056180) at kernel/qapplication.cpp:4415
#15 0x00007fbea97b2886 in KApplication::notify (this=0x7fff5e8798c0, receiver=0x3638870, event=0x7fbe18056180) at /usr/src/debug/kdelibs-4.8.2/kdeui/kernel/kapplication.cpp:311
#16 0x00007fbea805a22c in QCoreApplication::notifyInternal (this=0x7fff5e8798c0, receiver=0x3638870, event=0x7fbe18056180) at kernel/qcoreapplication.cpp:876
#17 0x00007fbea805daca in sendEvent (event=0x7fbe18056180, receiver=0x3638870) at kernel/qcoreapplication.h:231
#18 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x60da60) at kernel/qcoreapplication.cpp:1500
#19 0x00007fbea8088e53 in sendPostedEvents () at kernel/qcoreapplication.h:236
#20 postEventSourceDispatch (s=0x647700) at kernel/qeventdispatcher_glib.cpp:279
#21 0x00007fbea1d8658d in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#22 0x00007fbea1d86d88 in ?? () from /usr/lib64/libglib-2.0.so.0
#23 0x00007fbea1d86f59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#24 0x00007fbea808927f in QEventDispatcherGlib::processEvents (this=0x60d320, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#25 0x00007fbea8b1176e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#26 0x00007fbea8059012 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#27 0x00007fbea8059267 in QEventLoop::exec (this=0x7fff5e879850, flags=...) at kernel/qeventloop.cpp:204
#28 0x00007fbea805ddc5 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#29 0x0000000000403919 in main (argc=1, argv=0x7fff5e879ee8) at /usr/src/debug/kdepim-4.8.2/kontact/src/main.cpp:218

Possible duplicates by query: bug 297174, bug 296624, bug 296617, bug 296485, bug 296009.

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2012-04-20 12:16:30 UTC

*** This bug has been marked as a duplicate of bug 286307 ***