Bug 289879 - kmail crashed while reading email
Summary: kmail crashed while reading email
Status: RESOLVED DUPLICATE of bug 286307
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-12-26 19:44 UTC by Alan House
Modified: 2011-12-27 12:03 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alan House 2011-12-26 19:44:01 UTC
Application: kontact (4.7.4)
KDE Platform Version: 4.7.4 (4.7.4) (Compiled from sources)
Qt Version: 4.8.0
Operating System: Linux 3.1.6-1.fc16.x86_64 x86_64
Distribution: "Fedora release 16 (Verne)"

-- Information about the crash:
- What I was doing when the application crashed:

This time it crashes when reading the same email (walgreen's new ad).

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
82	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[Current thread is 1 (Thread 0x7fb2cb533840 (LWP 16956))]

Thread 7 (Thread 0x7fb2beaa3700 (LWP 16957)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:165
#1  0x00000039ef9973cc in WTF::TCMalloc_PageHeap::scavengerThread (this=0x39f0390f80) at ../../../Source/JavaScriptCore/wtf/FastMalloc.cpp:2495
#2  0x00000039ef9974f9 in WTF::TCMalloc_PageHeap::runScavengerThread (context=<optimized out>) at ../../../Source/JavaScriptCore/wtf/FastMalloc.cpp:1618
#3  0x00000039c5e07d90 in start_thread (arg=0x7fb2beaa3700) at pthread_create.c:309
#4  0x00000039c52ef48d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 6 (Thread 0x7fb2be1a2700 (LWP 16958)):
#0  0x00000039c52e6af3 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00000039c7e44f88 in g_main_context_poll (n_fds=1, fds=0x7fb2b80013e0, priority=<optimized out>, timeout=2705, context=0x7fb2b80009a0) at gmain.c:3386
#2  g_main_context_iterate (context=0x7fb2b80009a0, block=<optimized out>, dispatch=1, self=<optimized out>) at gmain.c:3068
#3  0x00000039c7e4544c in g_main_context_iteration (context=0x7fb2b80009a0, may_block=1) at gmain.c:3136
#4  0x00000039ccfa7db6 in QEventDispatcherGlib::processEvents (this=0x7fb2b80008c0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:426
#5  0x00000039ccf78172 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00000039ccf783c7 in QEventLoop::exec (this=0x7fb2be1a1d40, flags=...) at kernel/qeventloop.cpp:204
#7  0x00000039cce78b27 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#8  0x00000039cce7bb6b in QThreadPrivate::start (arg=0xe04170) at thread/qthread_unix.cpp:298
#9  0x00000039c5e07d90 in start_thread (arg=0x7fb2be1a2700) at pthread_create.c:309
#10 0x00000039c52ef48d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 5 (Thread 0x7fb271a18700 (LWP 17163)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:216
#1  0x00000039cce7bfdf in wait (time=30000, this=0x7fb26c005ec0) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x7fb26c005e68, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x00000039cce6f5af in QThreadPoolThread::run (this=0x7fb26c006140) at concurrent/qthreadpool.cpp:141
#4  0x00000039cce7bb6b in QThreadPrivate::start (arg=0x7fb26c006140) at thread/qthread_unix.cpp:298
#5  0x00000039c5e07d90 in start_thread (arg=0x7fb271a18700) at pthread_create.c:309
#6  0x00000039c52ef48d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 4 (Thread 0x7fb270a16700 (LWP 17165)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:216
#1  0x00000039cce7bfdf in wait (time=30000, this=0x7fb26c005ec0) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x7fb26c005e68, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x00000039cce6f5af in QThreadPoolThread::run (this=0x7fb26c00e150) at concurrent/qthreadpool.cpp:141
#4  0x00000039cce7bb6b in QThreadPrivate::start (arg=0x7fb26c00e150) at thread/qthread_unix.cpp:298
#5  0x00000039c5e07d90 in start_thread (arg=0x7fb270a16700) at pthread_create.c:309
#6  0x00000039c52ef48d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 3 (Thread 0x7fb26bdf7700 (LWP 17166)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:216
#1  0x00000039cce7bfdf in wait (time=30000, this=0x7fb26c005ec0) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x7fb26c005e68, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x00000039cce6f5af in QThreadPoolThread::run (this=0x7fb26c0121f0) at concurrent/qthreadpool.cpp:141
#4  0x00000039cce7bb6b in QThreadPrivate::start (arg=0x7fb26c0121f0) at thread/qthread_unix.cpp:298
#5  0x00000039c5e07d90 in start_thread (arg=0x7fb26bdf7700) at pthread_create.c:309
#6  0x00000039c52ef48d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 2 (Thread 0x7fb26b5f6700 (LWP 17167)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:216
#1  0x00000039cce7bfdf in wait (time=30000, this=0x7fb26c005ec0) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x7fb26c005e68, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x00000039cce6f5af in QThreadPoolThread::run (this=0x7fb26c016150) at concurrent/qthreadpool.cpp:141
#4  0x00000039cce7bb6b in QThreadPrivate::start (arg=0x7fb26c016150) at thread/qthread_unix.cpp:298
#5  0x00000039c5e07d90 in start_thread (arg=0x7fb26b5f6700) at pthread_create.c:309
#6  0x00000039c52ef48d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 1 (Thread 0x7fb2cb533840 (LWP 16956)):
[KCrash Handler]
#6  QNetworkAccessHttpBackend::replyDownloadMetaData (this=0x88d6340, hm=<optimized out>, sc=<optimized out>, rp=<optimized out>, pu=<optimized out>, db=<optimized out>, contentLength=-1) at access/qnetworkaccesshttpbackend.cpp:827
#7  0x00000039d16f6409 in QNetworkAccessHttpBackend::qt_static_metacall (_o=0x88d6340, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#8  0x00000039ccf91f06 in QObject::event (this=0x88d6340, e=<optimized out>) at kernel/qobject.cpp:1195
#9  0x00000039cd9c9994 in notify_helper (e=0x7fb26c002720, receiver=0x88d6340, this=0xe050c0) at kernel/qapplication.cpp:4550
#10 QApplicationPrivate::notify_helper (this=0xe050c0, receiver=0x88d6340, e=0x7fb26c002720) at kernel/qapplication.cpp:4522
#11 0x00000039cd9ce813 in QApplication::notify (this=0x7fffd2b058b0, receiver=0x88d6340, e=0x7fb26c002720) at kernel/qapplication.cpp:4411
#12 0x00000039d5a50766 in KApplication::notify (this=0x7fffd2b058b0, receiver=0x88d6340, event=0x7fb26c002720) at /usr/src/debug/kdelibs-4.7.4/kdeui/kernel/kapplication.cpp:311
#13 0x00000039ccf7903c in QCoreApplication::notifyInternal (this=0x7fffd2b058b0, receiver=0x88d6340, event=0x7fb26c002720) at kernel/qcoreapplication.cpp:876
#14 0x00000039ccf7caca in sendEvent (event=0x7fb26c002720, receiver=0x88d6340) at kernel/qcoreapplication.h:231
#15 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0xdc7050) at kernel/qcoreapplication.cpp:1500
#16 0x00000039ccfa7923 in sendPostedEvents () at kernel/qcoreapplication.h:236
#17 postEventSourceDispatch (s=0xdfde20) at kernel/qeventdispatcher_glib.cpp:279
#18 0x00000039c7e44a7d in g_main_dispatch (context=0xdfc5e0) at gmain.c:2425
#19 g_main_context_dispatch (context=0xdfc5e0) at gmain.c:2995
#20 0x00000039c7e45278 in g_main_context_iterate (context=0xdfc5e0, block=<optimized out>, dispatch=1, self=<optimized out>) at gmain.c:3073
#21 0x00000039c7e4544c in g_main_context_iteration (context=0xdfc5e0, may_block=1) at gmain.c:3136
#22 0x00000039ccfa7d4f in QEventDispatcherGlib::processEvents (this=0xdc8510, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#23 0x00000039cda6c5fe in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:207
#24 0x00000039ccf78172 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#25 0x00000039ccf783c7 in QEventLoop::exec (this=0x7fffd2b05840, flags=...) at kernel/qeventloop.cpp:204
#26 0x00000039ccf7cdc5 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#27 0x00000000004037b9 in main (argc=1, argv=0x7fffd2b05ed8) at /usr/src/debug/kdepim-4.7.4/kontact/src/main.cpp:218

Possible duplicates by query: bug 288942, bug 288935, bug 288604, bug 288504, bug 288423.

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2011-12-27 12:03:09 UTC

*** This bug has been marked as a duplicate of bug 286307 ***