Bug 156484 - JJ: Conflicts between effects should be handled
Summary: JJ: Conflicts between effects should be handled
Status: RESOLVED FIXED
Alias: None
Product: kwin
Classification: Plasma
Component: compositing (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR normal with 3 votes (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords: junior-jobs
: 165856 185823 221311 298031 308807 316498 327503 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-01-23 17:48 UTC by Martin Flöser
Modified: 2015-07-06 20:46 UTC (History)
10 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.something


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Flöser 2008-01-23 17:48:19 UTC
Version:            (using KDE 4.0.0)
Installed from:    Ubuntu Packages
OS:                Linux

I just played around with the different zoom effects and noticed a strange behaviour. To reproduce:
- activate magnifier and zoom in
- now activate another zoom effect, e.g. looking glass
- zoom in even more
- return no normal view
=> magnifier is still there and cannot be removed. You have to deactivate the effect.

The behaviour can also be reproduced with other combinations or other ordering. E.g. first looking glass than magnifier.

Idea for solution: if one of the zoom effects is reloaded or activated all other activated zoom effects should be reloaded. Or only one of the zoom effect is allowed to be selected.
Comment 1 Lubos Lunak 2008-06-29 15:06:01 UTC
JJ: EffectsHandler should get something like "void grab( QString )", "void ungrab( QString )", "bool isGrabbed( QString ) const" and KWin core would keep the list of grabbed activities (or whatever it should be called). I think there should be a refcount rathen than plain set/unset.
Comment 2 Lubos Lunak 2008-07-30 14:32:33 UTC
*** Bug 165856 has been marked as a duplicate of this bug. ***
Comment 3 lucas 2008-12-15 13:40:50 UTC
*** Bug 165295 has been marked as a duplicate of this bug. ***
Comment 4 Martin Flöser 2009-02-03 16:10:34 UTC
*** Bug 183012 has been marked as a duplicate of this bug. ***
Comment 5 Martin Flöser 2009-03-15 14:19:32 UTC
*** Bug 185823 has been marked as a duplicate of this bug. ***
Comment 6 Martin Flöser 2010-01-05 09:39:33 UTC
*** Bug 221311 has been marked as a duplicate of this bug. ***
Comment 7 Martin Flöser 2011-01-01 09:30:30 UTC
*** Bug 261768 has been marked as a duplicate of this bug. ***
Comment 8 Martin Flöser 2012-04-13 08:59:33 UTC
*** Bug 298031 has been marked as a duplicate of this bug. ***
Comment 9 Martin Flöser 2012-10-22 15:38:03 UTC
*** Bug 308807 has been marked as a duplicate of this bug. ***
Comment 10 Martin Flöser 2013-03-11 06:50:21 UTC
*** Bug 316498 has been marked as a duplicate of this bug. ***
Comment 11 Martin Flöser 2013-11-12 18:24:36 UTC
*** Bug 327503 has been marked as a duplicate of this bug. ***
Comment 12 Thomas Lübking 2015-07-06 20:46:41 UTC
Fixed in some KWin 5.earlyversion