Bug 261768 - Make transition from present windows grid to minimized window more smooth
Summary: Make transition from present windows grid to minimized window more smooth
Status: RESOLVED FIXED
Alias: None
Product: kwin
Classification: Plasma
Component: compositing (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-01-01 06:01 UTC by Kai Uwe Broulik
Modified: 2011-01-01 20:00 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
pre-unminimize (575 bytes, patch)
2011-01-01 16:14 UTC, Thomas Lübking
Details
general pre-unminimize patch (3.36 KB, patch)
2011-01-01 17:25 UTC, Thomas Lübking
Details
only minimizers... (1.64 KB, patch)
2011-01-01 18:02 UTC, Thomas Lübking
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kai Uwe Broulik 2011-01-01 06:01:32 UTC
Version:           unspecified (using KDE 4.5.90) 
OS:                Linux

When triggering the present window grid there are also all minimized windows shown and most of the time they also have a preview/live picture. When clicking on a minimized window, the grid disappears and then the window “jumps” out of the taskbar and then is visible/active.
It would be better to have the window coming directly from the grid, i.e. being resized to the full size directly instead of it being restored afterwards.

Reproducible: Always
Comment 1 Martin Flöser 2011-01-01 09:30:30 UTC
Just another case of effect conflict handling. Present Windows would have to set an unminimize grab which is honoured by all minimizing effects.

*** This bug has been marked as a duplicate of bug 156484 ***
Comment 2 Thomas Lübking 2011-01-01 16:14:16 UTC
Created attachment 55441 [details]
pre-unminimize

i don't think this is a dupe and intercom actually required in this particular case. see patch - it should be sufficient to jsut silently unminimize the window before activating it. Since minimize effects stay out (FS effect), it's just as if the window had been unminimized for showing up in PW (what's in a way true) and is now just not re-minimized...
Comment 3 Thomas Lübking 2011-01-01 16:14:45 UTC
ps: cover/flip switch could do that as well, i think?!
Comment 4 Martin Flöser 2011-01-01 16:45:29 UTC
I am not sure if the patch would work. I remember that when I tried the mouse 
interactions in present windows (un)minimizing triggered the minimize 
animations.

So a real solution would be better. Maybe it's enough to just look for 
fullscreen effects in minimize effect - that should cover also 
flip/cover/whatever.
Comment 5 Thomas Lübking 2011-01-01 17:25:36 UTC
Created attachment 55446 [details]
general pre-unminimize patch

*blast* you're right. /my/ effects of course _do_ honour the fullscreen state ;-P

patch for present windows/coverswitch/flipswitch/minimize/magiclamp attached. did i miss one?
Comment 6 Martin Flöser 2011-01-01 17:31:57 UTC
> patch for present windows/coverswitch/flipswitch/minimize/magiclamp
> attached. did i miss one?
Does it need the changes in pw/cover/flip at all? All those effects should 
stay as fullscreen effect till the stop animation finishes. So when selecting 
a minimzed window through alt+tab the window gets activated, causing an 
unminimzing, but the fullscreen effect is still in place and by that not 
triggering minimize/magic lamp.

And yes you forgot at least one effect: Desktop Grid ;-)
Comment 7 Thomas Lübking 2011-01-01 18:02:13 UTC
Created attachment 55448 [details]
only minimizers...

(In reply to comment #6)
> Does it need the changes in pw/cover/flip at all?
No. I thought to have seen an unminize animation, but setting things to "slow" i cannot see it and i'm not really sure there was one.

So only the minimizers now (minimize & ML - grep says that's all) - the patch name is now nonsense, oc :)
Comment 8 Kai Uwe Broulik 2011-01-01 18:03:53 UTC
It may be of note that I am using that wonderlamp minimize effect. So that you don‘t fix it for the default minimizer but forget it for that special effect ;)
Comment 9 Thomas Lübking 2011-01-01 18:09:19 UTC
http://www.dict.cc/?s=wunderlampe

;-P
Comment 10 Kai Uwe Broulik 2011-01-01 18:11:40 UTC
Er… whatever :D
Comment 11 Martin Flöser 2011-01-01 18:32:36 UTC
>  --> (http://bugs.kde.org/attachment.cgi?id=55448)
> only minimizers...
Looks good. Can go into trunk and also branch (we are still before RC2).
Comment 12 Thomas Lübking 2011-01-01 19:57:05 UTC
SVN commit 1210684 by luebking:

don't use un/minimization while in fullscreen effect
BUG: 261768


 M  +4 -0      magiclamp/magiclamp.cpp  
 M  +4 -0      minimizeanimation/minimizeanimation.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1210684
Comment 13 Thomas Lübking 2011-01-01 20:00:52 UTC
SVN commit 1210686 by luebking:

backport of 1210684
don't use un/minimization while in fullscreen effect
CCBUG: 261768


 M  +4 -0      magiclamp/magiclamp.cpp  
 M  +4 -0      minimizeanimation/minimizeanimation.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1210686