Bug 185823 - double unminimizing in cover and flip switch
Summary: double unminimizing in cover and flip switch
Status: RESOLVED DUPLICATE of bug 156484
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-02-28 20:06 UTC by Ignat Semenov
Modified: 2009-03-15 14:19 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ignat Semenov 2009-02-28 20:06:39 UTC
Version:            (using Devel)
OS:                Linux
Installed from:    Compiled sources

When switching windows with Cover or Flip switch, if there is a minimized window, and it is selected, then the window unminimizes twice. One unminimizing animation occurs to the window in flip or cover switch effect, and another one is from the task manager to the desktop. These two animations go in parallel and finish in one window. This doesn't look very nice as with high animation speed it looks like flicker, and with low speeds you can actually notice the two animations and this doesn't make a lot of sense.
The desired behavior is to have only one animation or (what would be even better) no unminimizing animation at all, the window just zooming in from cover or flip switch.
Comment 1 Martin Flöser 2009-03-15 14:19:32 UTC

*** This bug has been marked as a duplicate of bug 156484 ***