Bug 221311 - KWin effects overlaps each others making bad combination
Summary: KWin effects overlaps each others making bad combination
Status: RESOLVED DUPLICATE of bug 156484
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Unspecified
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-01-05 00:51 UTC by Fri13
Modified: 2010-01-05 09:39 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Fri13 2010-01-05 00:51:15 UTC
Version:            (using Devel)
Installed from:    Compiled sources

Some KWin effects are affecting software what they not suppose.

Example. Effects "Scale In" and "Sliding popups" are being applied together for KickOff if they both are enabled.

The "Scale in" effect does not have a "Scale out" effect (mayby other bug report for that) so the user likes to use other effects as well to give visual effect like "Fade". 

With KDE SC 4.4 (beta2) the "Sliding popups" makes plasma notifications and KickOff look nice. But it does look very weird when the Kickoff gets opened with "Fade", "Scale In" and "Fade" effects, all together, but KickOff gets closed only by "Sliding pop-ups" animation.

I think there should not be possible have the "Scale In" effect applied to the KickOff. "Fade" and "Sliding Popups" animations looks good. The other closing animations like "Explosion" does make KickOff as well look weird. Mayby reason for that is that I do not count KickOff as Application Program/Typical window but just as the menu and it should be more like plasma notifications with extended animations.
Comment 1 Martin Flöser 2010-01-05 09:39:33 UTC

*** This bug has been marked as a duplicate of bug 156484 ***