Bug 298031 - Conflicting KWin plugins
Summary: Conflicting KWin plugins
Status: RESOLVED DUPLICATE of bug 156484
Alias: None
Product: kwin
Classification: Plasma
Component: effects-various (show other bugs)
Version: unspecified
Platform: Archlinux Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-04-13 08:48 UTC by invertedrat
Modified: 2012-04-13 08:59 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description invertedrat 2012-04-13 08:48:54 UTC
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:11.0) Gecko/20100101 Firefox/11.0
Build Identifier: 

It could be useful for KWin plugins to be able to conflict with one another. For example, if you enable both Minimize Animation and Magic Lamp, windows flicker when minimizing/restoring.

Reproducible: Always

Steps to Reproduce:
Enable two plugins that perform the same function.
Actual Results:  
Both plugins get activated, possible causing unwanted activity.

Expected Results:  
A dialog box informing of a conflict.
Comment 1 Martin Flöser 2012-04-13 08:59:33 UTC
Not trivial, at least it's the oldest bug against KWin I ever reported :-)

*** This bug has been marked as a duplicate of bug 156484 ***