Bug 308807 - The sliding popups (plasma popups) effect is broken after having used the zoom plugin.
Summary: The sliding popups (plasma popups) effect is broken after having used the zoo...
Status: RESOLVED DUPLICATE of bug 156484
Alias: None
Product: kwin
Classification: Plasma
Component: effects-various (show other bugs)
Version: 4.9.2
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-10-22 11:38 UTC by jens
Modified: 2012-10-22 20:58 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jens 2012-10-22 11:38:19 UTC
The slide-in effect seen e.g. in Kick-Off, KRunner of the networkmanagement plasmoid looks strange when having used the zoom effect. It looks like the content of the plasmoid is still zoomed during the effect and resized once the effect is completed.    

Reproducible: Always

Steps to Reproduce:
1. Zoom in (Meta+ +)
2. Zoom out (Meta+ - or Meta+0)
3. Open krunner (alt+F2) 
Actual Results:  
During slide-in the krunner looks zoomed and resizes to normal when the effect is finished.

Expected Results:  
The slide-in effect should look like when you never have toched the zoom function, eg after a fresh login.

I use the Opensuse 9.2 rpm's with Opensuse 12.2 and the nvidia proprietary driver (official repository, 304.43)
Comment 1 Martin Flöser 2012-10-22 15:38:03 UTC
thanks for the report. Unfortunately especially the zoom effect is known to conflict with quite some effects.

*** This bug has been marked as a duplicate of bug 156484 ***
Comment 2 Thomas Lübking 2012-10-22 19:22:11 UTC
> During slide-in the krunner looks zoomed and resizes to normal when the effect is finished.

Does it also happen if you turn off OpenGL 2 shaders in "kcmshell4 kwincompositing", 3rd tab?
Comment 3 jens 2012-10-22 20:18:56 UTC
Just tested, no. The sliding effect does indeed appears normal after zooming in and out when turning off OpenGL2 shaders. What does this mean?
Comment 4 Martin Flöser 2012-10-22 20:24:00 UTC
(In reply to comment #3)
> What does this mean?
most likely that it is more a duplicate of bug #300349 - state is not correctly reset.
Comment 5 jens 2012-10-22 20:29:46 UTC
Thanks for the info. I'm looking forward to kde 4.10 :)
Comment 6 Martin Flöser 2012-10-22 20:32:41 UTC
> I'm looking forward to kde 4.10 :)
unfortunately feature freeze is approaching...
Comment 7 jens 2012-10-22 20:58:07 UTC
On Monday 22 October 2012 20:32:41 you wrote:
> https://bugs.kde.org/show_bug.cgi?id=308807
> 
> --- Comment #6 from Martin Gräßlin <mgraesslin@kde.org> ---
> 
> > I'm looking forward to kde 4.10 :)
> 
> unfortunately feature freeze is approaching...

No problem, I just said that because the milestone was (still) set to 4.10 :)
Thanks a lot for your great work on kwin and kde in general!