Bug 165856 - Cover switch and box switch effect should use different keybindings or be mutually exclusive
Summary: Cover switch and box switch effect should use different keybindings or be mut...
Status: RESOLVED DUPLICATE of bug 156484
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-07-06 13:20 UTC by Frederik Himpe
Modified: 2008-07-30 14:32 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Frederik Himpe 2008-07-06 13:20:22 UTC
Version:           4.0.84 (using Devel)
Installed from:    Compiled sources

Currently it's possible to select both the cover switch and box switch desktop effect, and they both use by default the Alt-Tab keybinding. The result is that pressing alt-tab shows both effects on top of each other, which is ugly and useless. Either Cover switch should use a different keybinding (currently there is no way to change it's keybinding. Compiz is using Win+Tab for cover switch), either both effects should be mutually exclusive so it's impossible to enable both at the same time.
Comment 1 Piotr Pełzowski 2008-07-18 19:21:29 UTC
I don't thing that keybindings should be changed. "Both effects should be mutually exclusive so it's impossible to enable both at the same time." it is much better IMO. But maybe it is not needed...

I've found this bug because there is no way to turn of Box Switch. When I turn on Cover switch and turn off Box Switch and press "apply" it won't work as expected. Both effects will be turned on. There is no way to turn off Box Switch on this computer (KDE4.1RC1 openSUSE packages). If it would work there won't be a problem also with this Bug 165856 IMO. 

Should I open another bug for this problem with always turned on Box Switch?
Comment 2 Martin Flöser 2008-07-18 19:29:30 UTC
>I've found this bug because there is no way to turn of Box Switch. When I turn on Cover 
switch and turn off Box Switch and press "apply" it won't work as expected. Both effects will be turned on. There is no way to turn off Box Switch on this computer (KDE4.1RC1 openSUSE packages). If it would work there won't be a problem also with this Bug 165856 IMO. 

This is a current bug in RC 1. Please take a look at bug #166720 for a temporary workaround to disable boxswitch.
Comment 3 Lubos Lunak 2008-07-30 14:32:31 UTC

*** This bug has been marked as a duplicate of 156484 ***