Bug 327503 - Fall Apart effect has a visual glitch
Summary: Fall Apart effect has a visual glitch
Status: RESOLVED DUPLICATE of bug 156484
Alias: None
Product: kwin
Classification: Plasma
Component: effects-window-management (show other bugs)
Version: 4.11.2
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-11-12 15:03 UTC by Lilian A. Moraru
Modified: 2013-11-12 18:33 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
KWin Support Information output (5.01 KB, text/plain)
2013-11-12 18:02 UTC, Lilian A. Moraru
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lilian A. Moraru 2013-11-12 15:03:31 UTC
The "Fall Apart" effect has a little visual glitch.
After the window falls apart, the small pieces of the window appear back on the screen and fall apart again.
Video demonstration: http://www.youtube.com/watch?v=8d3iz9rz0Sc

Reproducible: Always
Comment 1 Thomas Lübking 2013-11-12 16:38:41 UTC
For sure time colliding with another close effect (fade or sth.) - ie. same thing as with minimize ./. magic lamp.

Please nevertheless attach the ouput of "qdbus org.kde.kwin /KWin supportInformation" (and of course try reproducing with disabled fade effect)
Comment 2 Lilian A. Moraru 2013-11-12 18:02:32 UTC
Created attachment 83522 [details]
KWin Support Information output

Yes, disabling the "Fade" effect resolves the issue.
I attached a txt file since KDE Paste says "Your paste triggered our spam filter and has been dropped" and doesn't allow me to put this.
Comment 3 Martin Flöser 2013-11-12 18:24:36 UTC

*** This bug has been marked as a duplicate of bug 156484 ***
Comment 4 Thomas Lübking 2013-11-12 18:33:25 UTC
FYI: you can edit the fade effect (it's a script) in /usr/share/apps/kwin/effects/kwin4_effect_fade/contents/code/main.js and extend the fade(Out) time to 1000 (the duration of the fall apart effect) - it's just really long otherwise. (the 600ms present are already a "trick" to cover some other effect)

You may want to raise the curve shape to OutQuint to compensate the extension a bit more.