Bug 108419 - Ability to sort entries in the sub-menus
Summary: Ability to sort entries in the sub-menus
Status: RESOLVED FIXED
Alias: None
Product: kmenuedit
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR wishlist with 166 votes (vote)
Target Milestone: ---
Assignee: Julien Borderie
URL:
Keywords:
: 114651 117258 136225 166754 190038 223600 229520 248616 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-07-02 00:14 UTC by Christian Nolte
Modified: 2013-02-18 22:15 UTC (History)
16 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.11.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christian Nolte 2005-07-02 00:14:30 UTC
Version:           0.7 (using KDE KDE 3.4.1)
Installed from:    Fedora RPMs

kmenuedit should have a function to autmatically sort the entries made in any of the submenus. This could be done via right-clicking the sub-menu, with the then shown option to sort the entries forwards and backwards. It is very inconvenient to sort them manually.
Comment 1 Thiago Macieira 2005-07-02 03:27:06 UTC
I think the reporter wants to right-click the K Menu.
Comment 2 Christian Nolte 2005-07-02 03:32:17 UTC
I would say that both methods would be nice. It would be a good idea if the user could right-click an entry in the kmenu (through kicker, I guess) and if he prefers to work with kmenuedit, then he could right click an entry there to sort it.
Comment 3 Daevid Vincent 2005-08-31 10:17:26 UTC
I was just about to file a wish for this feature.

I'm astonished that this can't be done currently -- I thought I was missing something or being a noob. The menus are filled with all kinds of crap it's nearly impossible to find anything as it is.

I like how WindowsXP has the 'right click' on a start-menu folder and you can sort it. i also like how you can drag items around. no crazy editor needed.

...furthermore, I would kill for the feature in XP whereby you install a new program, an entry is inserted in the menu for you. I don't think Linux is to the collaborative point where this can be achieved, but perhaps you could highlight new menu items until they are clicked on for the first time?
Comment 4 Aaron J. Seigo 2005-11-29 23:08:37 UTC
*** Bug 114651 has been marked as a duplicate of this bug. ***
Comment 5 Aaron J. Seigo 2005-11-29 23:08:54 UTC
*** Bug 117258 has been marked as a duplicate of this bug. ***
Comment 6 Greg Ellis 2006-06-23 03:57:20 UTC
*** This bug has been confirmed by popular vote. ***
Comment 7 Andrew Ash 2006-07-29 07:47:34 UTC
Just to pipe in here, I think this is a great feature that kmenuedit could have.  Usability-wise, I think this is best implemented in kmenuedit itself, not the actual kmenu just yet (drag and drop should come before alphabetize sort).

In kmenuedit, right-clicking on a menu would give this menu:

Cut
Copy
Past
----
Delete
-----
Sort by ->
-----
New Item
New Menu
New Separator

Sort by would pop out a submenu that would include various options:

ABC (Program Name)
ABC (Description)
Date (Newest->Oldest)
Date (Oldest->Newest)
etc...

If this was done, the parent KMenu would have to be added to the top of the menu tree in order to sort the submenus (Games, Graphics, Internet, etc)

I think this is a feature that would really improve in KDE's usability as a whole.  Manually sorting programs is no fun!
Comment 8 Michael Hatzold 2006-11-26 02:30:47 UTC
I second this feature request: It is really a pain to sort the applications one by one. But one has to do this, otherwise you always search for your application because they don't have THEIR place within an (alphbetical) order.
Comment 9 Shriramana Sharma 2007-03-17 04:59:50 UTC
My maximum votes... 

If this sort feature could be enabled in KMenu Editor it would be sufficient for me. But if it were possible to do it directly on the KMenu too it would of course be more convenient. 

I didn't however understand what the other user meant by sorting by date, since there isn't a date property of the menu items. Sorting by name and description would be enough for me.
Comment 10 Shriramana Sharma 2007-03-17 05:01:41 UTC
I forgot some things:

The sort action should function on only the first level items within the current selected item, provided the current item is a directory or the menu root. 

A recursive sort action can be provided which would sort the entire tree within the current item (or the entire menu itself if the current item is the root item).

For non-directories, the actions should be disabled.
Comment 11 Pino Toscano 2007-11-04 14:22:10 UTC
*** Bug 136225 has been marked as a duplicate of this bug. ***
Comment 12 Janet 2007-11-04 19:48:42 UTC
Maybe you want to try tastymenu: http://www.kde-look.org/content/show.php?content=41866
It highlights new application entries and you also can sort the entries alphabetically with one click in the options.

Maybe kmenu could handle it the same way: no "real" sorting of entries (tastymenu leaves the order of the items in kmenuedit untouched) but an additional option in kcontrol (where you can find the other menu options) to show the items in alphabetical order.
Comment 13 Pino Toscano 2008-07-17 09:52:02 UTC
*** Bug 166754 has been marked as a duplicate of this bug. ***
Comment 14 Pino Toscano 2009-04-19 12:13:15 UTC
*** Bug 190038 has been marked as a duplicate of this bug. ***
Comment 15 Unknown 2009-04-19 15:29:27 UTC
The switch to KDE4 still leaves this problem, so I can only second what has been said - having such an option in kmenuedit would be great and improve usability a lot.
(sorry for duplicating, the report dialogue didn't show this one, perhaps because it was too old)
Comment 16 Pino Toscano 2010-08-21 20:27:26 UTC
*** Bug 223600 has been marked as a duplicate of this bug. ***
Comment 17 Pino Toscano 2010-08-21 20:27:35 UTC
*** Bug 229520 has been marked as a duplicate of this bug. ***
Comment 18 Pino Toscano 2010-08-21 20:27:42 UTC
*** Bug 248616 has been marked as a duplicate of this bug. ***
Comment 19 Bzzz 2011-08-09 12:55:03 UTC
Wow, that's sad. This thing is open for 6 years now, and users still have the choice between manually sorting hundreds of their menu items or resetting to system defaults and doing their menu customization all over again.
Comment 20 Shriramana Sharma 2012-07-24 15:41:01 UTC
Hello people -- this bug is over seven years old. Is it that difficult to fix? Please see if you can devote some small amount of time to it! Thanks!
Comment 21 Martín Cigorraga 2012-07-24 18:14:25 UTC
Amen.
Comment 22 The Beerslayer 2012-08-19 01:37:08 UTC
I don't mean to seem impatient, but this sorely-needed enhancement request has now been open for over SEVEN YEARS.

The sheer number of duplicate bugs filed (and so flagged) above should be testament to the number of people who want this capability.  If I had the coding skills, I'd offer to fix it myself, but I don't.

Is it really so difficult to fix?
Comment 23 Julien Borderie 2013-01-08 20:56:18 UTC
I just want to say that I'm working on this feature.
Comment 24 Martín Cigorraga 2013-01-10 06:04:20 UTC
@Julien
Say what!? Are you telling us that Santa will show earlier this year!?
Since you're working on this, how about addint a Search field too? This way searching for a specific entry to edit when you have a lot of software installed isn't so painful :)
Oh, btw, thank you!
Comment 25 Julien Borderie 2013-01-10 19:11:44 UTC
Indeed, it's not a dream :)
For now the sort on program names is almost ready.

Regarding the search field, why not !
Comment 26 Martín Cigorraga 2013-01-11 01:08:41 UTC
COWABUNGA, DUDE!
(Sorry, no more noise :)
Comment 27 Albert Astals Cid 2013-02-18 22:15:40 UTC
Git commit a5c4d49934f53fcf6d39739590094b5c863c79a4 by Albert Astals Cid, on behalf of Julien Borderie.
Committed on 18/02/2013 at 23:13.
Pushed by aacid into branch 'master'.

[KMenuEdit] Ability to sort elements
REVIEW: 107409
FIXED-IN: 4.11.0

M  +21   -0    kmenuedit/kmenuedit.cpp
M  +6    -0    kmenuedit/kmenueditui.rc
M  +1    -1    kmenuedit/main.cpp
M  +175  -0    kmenuedit/treeview.cpp
M  +25   -1    kmenuedit/treeview.h

http://commits.kde.org/kde-workspace/a5c4d49934f53fcf6d39739590094b5c863c79a4