Bug 455540

Summary: Unable to download from Settings with error "invalid number of concurrent streams"
Product: [Applications] Discover Reporter: eskay993 <bzboulos>
Component: discoverAssignee: Dan Leinir Turthra Jensen <leinir>
Status: RESOLVED FIXED    
Severity: normal CC: aleixpol, bugseforuns, christian, D.Boltianski, david.vuckovic7, decedion, denysvit, dromangnoli, dutchgigalo, f.alexander.wilms, fischerfelix06, kde, kickdegans, lcthrock1, locutusofborg64, michal.dybczak, MurzNN, nate, nishantsolanki400, paul, pedro.iago.sabino, piotr.mierzwinski, rikmills, robert.gorajski, simplysynth, sparky123558wify, tomfoley247, williamliu636
Priority: NOR    
Version: 5.24.4   
Target Milestone: ---   
Platform: Kubuntu   
OS: Linux   
URL: https://bugreports.qt.io/browse/QTBUG-94470
See Also: https://bugs.kde.org/show_bug.cgi?id=455884
Latest Commit: Version Fixed In: Whenever your distro backports this commit ^^
Attachments: invalid number of concurrent streams
attachment-16135-0.html

Description eskay993 2022-06-18 10:19:51 UTC
SUMMARY
***
Unable to download anything from the KDE Store from within System Settings. This happens for all types of content (icons, themes, etc) with the same error below. This also happens on Fedora KDE, Manajro and Arco KDE.
***

STEPS TO REPRODUCE
1. Open System Settings > Appearances
2. Click on Icons (or any section with a download option)
3. Click on Get New Icons
4. Select any icon pack and click install

OBSERVED RESULT
The following error message appears and nothing is downloaded:

Download of "PlagueSur icon theme [WhiteSur Expansion]" failed, error: SETTINGS invalid number of concurrent streams

EXPECTED RESULT
Icon pack should successfully download and install

SOFTWARE/OS VERSIONS
Linux/KDE Plasma: Fedora Linux 36
KDE Plasma Version: 5.24.5
KDE Frameworks Version: 5.93.0
Qt Version: 5.15.3

ADDITIONAL INFORMATION
Started happening roughly 18 hours ago (in the afternoon UK time). 

Have tested the following with the same error:
- My main Fedora 36 Install
- Fedora 36 KDE, Arco KDE and Manjaro Live ISOs
- Connecting to my phone hotspot (to eliminate my router as the culprit)

Output from console on Fedora 36. This is everything from running systemsettings till the error, following the above steps:

QSocketNotifier: Can only be used with threads started with QThread
file:///usr/lib64/qt5/qml/org/kde/kirigami.2/ApplicationItem.qml:151:9: QML Shortcut: Shortcut: Only binding to one of multiple key bindings associated with 13. Use 'sequences: [ <key> ]' to bind to all of them.
file:///usr/lib64/qt5/qml/org/kde/kirigami.2/ApplicationItem.qml:147:9: QML Shortcut: Shortcut: Only binding to one of multiple key bindings associated with 14. Use 'sequences: [ <key> ]' to bind to all of them.
QQmlEngine::setContextForObject(): Object already has a QQmlContext
file:///usr/lib64/qt5/qml/org/kde/kirigami.2/ApplicationItem.qml:151:9: QML Shortcut: Shortcut: Only binding to one of multiple key bindings associated with 13. Use 'sequences: [ <key> ]' to bind to all of them.
file:///usr/lib64/qt5/qml/org/kde/kirigami.2/ApplicationItem.qml:147:9: QML Shortcut: Shortcut: Only binding to one of multiple key bindings associated with 14. Use 'sequences: [ <key> ]' to bind to all of them.
qt.qpa.wayland: Wayland does not support QWindow::requestActivate()
QQmlEngine::setContextForObject(): Object already has a QQmlContext
file:///usr/lib64/qt5/qml/org/kde/kirigami.2/ApplicationItem.qml:151:9: QML Shortcut: Shortcut: Only binding to one of multiple key bindings associated with 13. Use 'sequences: [ <key> ]' to bind to all of them.
file:///usr/lib64/qt5/qml/org/kde/kirigami.2/ApplicationItem.qml:147:9: QML Shortcut: Shortcut: Only binding to one of multiple key bindings associated with 14. Use 'sequences: [ <key> ]' to bind to all of them.
QQmlEngine::setContextForObject(): Object already has a QQmlContext
file:///usr/lib64/qt5/qml/org/kde/kirigami.2/ApplicationItem.qml:151:9: QML Shortcut: Shortcut: Only binding to one of multiple key bindings associated with 13. Use 'sequences: [ <key> ]' to bind to all of them.
file:///usr/lib64/qt5/qml/org/kde/kirigami.2/ApplicationItem.qml:147:9: QML Shortcut: Shortcut: Only binding to one of multiple key bindings associated with 14. Use 'sequences: [ <key> ]' to bind to all of them.
file:///usr/share/kpackage/kcms/kcm_colors/contents/ui/main.qml:78:13: QML ColumnLayout: Cannot anchor to an item that isn't a parent or sibling.
QQmlEngine::setContextForObject(): Object already has a QQmlContext
file:///usr/share/kpackage/kcms/kcm_icons/contents/ui/main.qml:207:13: QML Connections: Implicitly defined onFoo properties in Connections are deprecated. Use this syntax instead: function onFoo(<arguments>) { ... }
file:///usr/lib64/qt5/qml/org/kde/kirigami.2/ApplicationItem.qml:151:9: QML Shortcut: Shortcut: Only binding to one of multiple key bindings associated with 13. Use 'sequences: [ <key> ]' to bind to all of them.
file:///usr/lib64/qt5/qml/org/kde/kirigami.2/ApplicationItem.qml:147:9: QML Shortcut: Shortcut: Only binding to one of multiple key bindings associated with 14. Use 'sequences: [ <key> ]' to bind to all of them.
file:///usr/lib64/qt5/qml/org/kde/kirigami.2/templates/OverlaySheet.qml:219:38: QML FocusScope: Binding loop detected for property "contentItemMaximumWidth"
QCoreApplication::postEvent: Unexpected null receiver
file:///usr/lib64/qt5/qml/org/kde/kirigami.2/ApplicationItem.qml:151:9: QML Shortcut: Shortcut: Only binding to one of multiple key bindings associated with 13. Use 'sequences: [ <key> ]' to bind to all of them.
file:///usr/lib64/qt5/qml/org/kde/kirigami.2/ApplicationItem.qml:147:9: QML Shortcut: Shortcut: Only binding to one of multiple key bindings associated with 14. Use 'sequences: [ <key> ]' to bind to all of them.
file:///usr/lib64/qt5/qml/org/kde/newstuff/Action.qml:145:59: QML Connections: Detected function "onInitialized" in Connections element. This is probably intended to be a signal handler but no signal of the target matches the name.
file:///usr/lib64/qt5/qml/org/kde/kirigami.2/AbstractApplicationItem.qml:93: TypeError: Cannot read property 'position' of null
file:///usr/lib64/qt5/qml/org/kde/kirigami.2/AbstractApplicationItem.qml:92: TypeError: Cannot read property 'background' of null
kio_http_cache_cleaner: Already running!
qt.network.http2: connection error: SETTINGS invalid number of concurrent streams
qt.network.http2: stream 1 finished with error: "SETTINGS invalid number of concurrent streams"
kf.newstuff.core: "SETTINGS invalid number of concurrent streams"
kf.newstuff.core: "Download of \"PlagueSur icon theme [WhiteSur Expansion]\" failed, error: SETTINGS invalid number of concurrent streams"
Comment 1 Antonio Rojas 2022-06-18 11:47:53 UTC
Qt bug: https://bugreports.qt.io/browse/QTBUG-94470
Comment 2 Bug Janitor Service 2022-06-18 11:49:05 UTC
A possibly relevant merge request was started @ https://invent.kde.org/qt/qt/qtbase/-/merge_requests/179
Comment 3 Antonio Rojas 2022-06-18 11:51:53 UTC
*** Bug 455544 has been marked as a duplicate of this bug. ***
Comment 4 Antonio Rojas 2022-06-18 12:10:25 UTC
*** Bug 455542 has been marked as a duplicate of this bug. ***
Comment 5 Patrick Silva 2022-06-18 14:24:30 UTC
*** Bug 455514 has been marked as a duplicate of this bug. ***
Comment 6 Antonio Rojas 2022-06-18 15:41:24 UTC
*** Bug 455557 has been marked as a duplicate of this bug. ***
Comment 7 Antonio Rojas 2022-06-18 22:45:50 UTC
*** Bug 455571 has been marked as a duplicate of this bug. ***
Comment 8 locutusofborg 2022-06-19 11:47:55 UTC
This is marked fixed / resolved. Does that mean it'll be fixed in the 5.25.1 point release?
Comment 9 Antonio Rojas 2022-06-19 11:49:31 UTC
(In reply to locutusofborg from comment #8)
> This is marked fixed / resolved. Does that mean it'll be fixed in the 5.25.1
> point release?

No, the fix is in Qt
Comment 10 Felix Fischer 2022-06-19 11:53:37 UTC
Can confirm that just today on arch extra/qt5-base got an update to 5.15.5+kde+r163-1 that fixed it
Comment 11 Robert Gorajski 2022-06-20 07:05:11 UTC
You may have heard it, but Arch is a rolling relase distribution with very fast updates. What about openSUSE LEAP, Debian, etc. ?(In reply to Felix Fischer from comment #10)

> Can confirm that just today on arch extra/qt5-base got an update to
> 5.15.5+kde+r163-1 that fixed it
Comment 12 Antonio Rojas 2022-06-20 07:54:19 UTC
(In reply to Robert Gorajski from comment #11)
> You may have heard it, but Arch is a rolling relase distribution with very
> fast updates. What about openSUSE LEAP, Debian, etc. ?(In reply to Felix
> Fischer from comment #10)

You should ask your distribution to backport the fix
Comment 13 Paul Eveleigh 2022-06-20 15:34:31 UTC
The update came through for Kubuntu on my desktop and fixed the issue

MX Linux which I run on my primary desktop was never affected and is still running free of this bug

KDE Neon, which I run on my laptop, still has the problem reporting "SETTINGS invalid number of concurrent streams"

KDE Neon is currently reporting running Qt version 5.15.4
Comment 14 Antonio Rojas 2022-06-20 15:46:30 UTC
*** Bug 455655 has been marked as a duplicate of this bug. ***
Comment 15 Tom F 2022-06-20 20:19:13 UTC
(In reply to Paul Eveleigh from comment #13)
> The update came through for Kubuntu on my desktop and fixed the issue
> 
> MX Linux which I run on my primary desktop was never affected and is still
> running free of this bug
> 
> KDE Neon, which I run on my laptop, still has the problem reporting
> "SETTINGS invalid number of concurrent streams"
> 
> KDE Neon is currently reporting running Qt version 5.15.4
(In reply to Felix Fischer from comment #10)
> Can confirm that just today on arch extra/qt5-base got an update to
> 5.15.5+kde+r163-1 that fixed it

I'm running KDE Neon testing edition, and QT on that platform is at 5.14.4 as of this moment, with the issue present.  So QT  5.15.5 is awaited with anticipation. Thanks for posting and giving us hope :-)
Comment 16 Antonio Rojas 2022-06-21 06:32:50 UTC
*** Bug 455694 has been marked as a duplicate of this bug. ***
Comment 17 Paul Eveleigh 2022-06-21 07:29:05 UTC
Hi,
Sorry to mislead, I have a minor correction to make.
I have an installation of Kubuntu which works with the following version levels

KDE Plasma Version: 5.24.5
Frameworks Version: 5.95.0
Qt Version: 5.15.3
Kernel Version: 5.15.0.39

My laptop, running Kbuntu which does not work has the following version levels

KDE Plasma Version: 5.24.4
Frameworks Version: 5.92.0
Qt Version: 5.15.3
Kernel Version: 5.15.48

My desktop (the one which works) updated on 19/6/2022 which fixed the issue but the update does not to appear to come through on my laptop ?! I guess the patch is bundled with this update which also pushes KDE Plasma/Framework up a minor version. 

I have also run up a VM and that also has the issue and stuck on the same Plasma version and framework as my laptop. I need to find out how to entice an update to this level.

Regards,

Paul
Comment 18 Paul Eveleigh 2022-06-21 07:55:05 UTC
Hi,

For me, I've fixed it - it now works on both my VM and laptop !

This appears to have been resolved in KDE Plasma 5.24.5, so I added the backports PPA to Kubuntu 22.04 LTS

sudo add-apt-repository ppa:kubuntu-ppa/backports && sudo apt full-upgrade -y

or (what worked for me)

sudo add-apt-repository ppa:kubuntu-ppa/backports
sudo apt update
sudo apt upgrade -y

Full information here : https://community.kde.org/Get_KDE_Software_on_Your_Linux_Distro

Regards,

Paul
Comment 19 Rik Mills 2022-06-21 07:58:53 UTC
> This appears to have been resolved in KDE Plasma 5.24.5, so I added the
> backports PPA to Kubuntu 22.04 LTS

No, there is an updated Qtbase build in the backports PPA with the Qt fix backported from the 22.10 Kinetic package. In the next week or so this will hopefully submitted as a stable release update for the main ubuntu archive.
Comment 20 Paul Eveleigh 2022-06-21 08:12:50 UTC
Thank you Rik,

With Rik's comment I should correct my earlier post in saying that by adding the kubuntu backports repository you are able to pick up the Qtbase build fix which resolves this issue, although you may want to wait until this patch is included in the stable release channel.

Regards,

Paul
Comment 21 Antonio Rojas 2022-06-21 14:40:23 UTC
*** Bug 455722 has been marked as a duplicate of this bug. ***
Comment 22 Antonio Rojas 2022-06-21 16:00:29 UTC
*** Bug 455727 has been marked as a duplicate of this bug. ***
Comment 23 Christian Finnberg 2022-06-22 19:15:15 UTC
Does the error "server stopped accepting new streams before this stream was established" apply to this? I have seen a few users with that error in the last days in a Telegram group about Manjaro
Comment 24 Dimitri Bolt 2022-06-22 22:10:04 UTC
Created attachment 150073 [details]
invalid number of concurrent streams

When I try to install any widgets I can see: "Download of "Google Task - web - obsoleted" failed, error: SETTINGS invalid number of concurrent streams". (I have updated).
Comment 25 Dimitri Bolt 2022-06-22 22:16:18 UTC
When I try to install ant widgets I can see this : "Download of "Google Task - web - obsoleted" failed, error: SETTINGS invalid number of concurrent streams".
Comment 26 Antonio Rojas 2022-06-23 07:09:33 UTC
(In reply to Dimitri Bolt from comment #24)
> Created attachment 150073 [details]
> invalid number of concurrent streams
> 
> When I try to install any widgets I can see: "Download of "Google Task - web
> - obsoleted" failed, error: SETTINGS invalid number of concurrent streams".
> (I have updated).

This is fixed upstream in Qt. Please ask your distro to apply the fix.
Comment 27 Antonio Rojas 2022-06-23 07:12:49 UTC
*** Bug 455821 has been marked as a duplicate of this bug. ***
Comment 28 Rik Mills 2022-06-23 08:27:42 UTC
Until the Qt update can get pushed to the main Ubuntu archive, a fixed Qtbase can be found in Kubuntu's update ppa @ ppa:kubuntu-ppa/ppa
Comment 29 eskay993 2022-06-23 11:55:10 UTC
Thank you for the quick responce to this issue. Fedora 36 just got a Qt update today that includes this fix. All working now!
Comment 30 Michał Dybczak 2022-06-23 19:56:26 UTC
I'm also seeing the exact bug on Manjaro. Since the issue with "get new things" comes like boomerang, old Plasma users are rather sitting quiet, waiting for the fix, especially that we can find and download components manually, so this is not a big deal. So my guess is, more users are affected.

Moreover, in order to detect that bug, you need to look for something to change your system. Most users simply are set and only sporadically use "get new things". That was the case for me. Only when Plasma 5.25 came, I was curious to test new things, and then I found out about the bug. Otherwise, I would be clueless about this regression.

My guess is, the more users update to 5.25, the bigger need to test new things, and we will see more and more reports about this bug.

At the moment, multiple users can confirm it, at least on Manjaro side. It may be a packaging bug thou. Should we reopen it, or get more data? If the latter, what do you propose?
Comment 31 Antonio Rojas 2022-06-23 20:08:22 UTC
(In reply to Michał Dybczak from comment #30)
> At the moment, multiple users can confirm it, at least on Manjaro side. It
> may be a packaging bug thou. Should we reopen it, or get more data? If the
> latter, what do you propose?

This has been answered twice already in this report. Read comments 12 and 26.
Comment 32 Nate Graham 2022-06-24 13:48:18 UTC
*** Bug 455884 has been marked as a duplicate of this bug. ***
Comment 33 Nate Graham 2022-06-24 14:00:48 UTC
*** Bug 455785 has been marked as a duplicate of this bug. ***
Comment 34 Nate Graham 2022-06-24 16:41:15 UTC
*** Bug 455884 has been marked as a duplicate of this bug. ***
Comment 35 Kick de Gans 2022-06-25 07:08:01 UTC
Created attachment 150135 [details]
attachment-16135-0.html

Thanks, the bug is now resolved. I can install themes again 👍

Op vr 24 jun. 2022 om 18:45 schreef Nate Graham <bugzilla_noreply@kde.org>:

> https://bugs.kde.org/show_bug.cgi?id=455540
>
> Nate Graham <nate@kde.org> changed:
>
>            What    |Removed                     |Added
>
> ----------------------------------------------------------------------------
>            See Also|                            |
> https://bugs.kde.org/show_b
>                    |                            |ug.cgi?id=455884
>
> --
> You are receiving this mail because:
> You are on the CC list for the bug.
Comment 36 willi 2022-06-25 08:27:20 UTC
(In reply to Antonio Rojas from comment #26)
> (In reply to Dimitri Bolt from comment #24)
> > Created attachment 150073 [details]
> > invalid number of concurrent streams
> > 
> > When I try to install any widgets I can see: "Download of "Google Task - web
> > - obsoleted" failed, error: SETTINGS invalid number of concurrent streams".
> > (I have updated).
> 
> This is fixed upstream in Qt. Please ask your distro to apply the fix.

how to ask my Distro to appy it ?
Comment 37 willi 2022-06-25 08:28:48 UTC
(In reply to Antonio Rojas from comment #26)
> (In reply to Dimitri Bolt from comment #24)
> > Created attachment 150073 [details]
> > invalid number of concurrent streams
> > 
> > When I try to install any widgets I can see: "Download of "Google Task - web
> > - obsoleted" failed, error: SETTINGS invalid number of concurrent streams".
> > (I have updated).
> 
> This is fixed upstream in Qt. Please ask your distro to apply the fix.

how to ask my Distro to apply it ?
Comment 38 Michał Dybczak 2022-06-25 08:32:38 UTC
I just updated my system (Manjaro testing), with an update that showed up a few days ago, and I can confirm that the bug is gone. I was able to download global themes from "get new thing" now.
Comment 39 Antonio Rojas 2022-07-03 08:29:01 UTC
*** Bug 456267 has been marked as a duplicate of this bug. ***