Bug 455514 - Installing cursor through the store fails
Summary: Installing cursor through the store fails
Status: RESOLVED DUPLICATE of bug 455540
Alias: None
Product: systemsettings
Classification: Applications
Component: kcm_cursortheme (show other bugs)
Version: 5.25.0
Platform: OpenSUSE Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-06-17 22:28 UTC by zerocostabstraction
Modified: 2022-06-18 14:24 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description zerocostabstraction 2022-06-17 22:28:16 UTC
SUMMARY

Trying to download and install ANY cursor theme from the store fails with this:

Download of "Oxygen Neon Large" failed, error: SETTINGS invalid number of concurrent streams


STEPS TO REPRODUCE
1. Open system settings
2. Appearance -> Cursors -> Get New Cursors...
3. Pick one

OBSERVED RESULT

Fails to install it 

EXPECTED RESULT

Installs the cursors

System info

Operating System: openSUSE Tumbleweed 20220613
KDE Plasma Version: 5.25.0
KDE Frameworks Version: 5.94.0
Qt Version: 5.15.2
Kernel Version: 5.18.2-1-default (64-bit)
Graphics Platform: Wayland
Comment 1 computerworm 2022-06-18 02:51:56 UTC
The same thing happens to me when I try to install any type of add-on from the Plasma Store - cursors, application styles, color schemes, splash screens, icons, window decorations, and panel widgets. Please fix this soon. :(

System Info:
Operating System: Artix Linux
KDE Plasma Version: 5.25.0
KDE Frameworks Version: 5.95.0
Qt Version: 5.15.4
Kernel Version: 5.18.5-artix1-1 (64-bit)
Graphics Platform: Wayland
Comment 2 computerworm 2022-06-18 03:53:36 UTC
I tried again, this time with Discover, and got something slightly more helpful. The error message is mostly the same as before, but it's prefaced with "plasma-themes.knsrc". I found a bunch of knsrc files in /usr/share/knsrcfiles. So the error is associated with that somehow
Comment 3 Patrick Silva 2022-06-18 14:24:30 UTC

*** This bug has been marked as a duplicate of bug 455540 ***