Bug 255935

Summary: KPackageKit crashed when downloading some packages (libdebconfkde) [QWidget::releaseShortcut, QLabelPrivate::clearContents, ~QLabel, ..., ~DebconfElement]
Product: kpackagekit Reporter: Ac17 <fd.svensson>
Component: generalAssignee: Steven M. Parrish <smparrish>
Status: RESOLVED FIXED    
Severity: crash CC: andresbajotierra, bosyber, cpark, dantti12, dave, durham_harry, grahamtooley, herman.klushin, johnqed, mer2329, quamis+kde, Ronny.Standtke, samirhin72, timothy997, vcpmarcos-spamcan, wheelband
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Ubuntu Packages   
OS: Linux   
Latest Commit: Version Fixed In: 0.7.2
Attachments: New crash information added by DrKonqi
New crash information added by DrKonqi
New crash information added by DrKonqi
New crash information added by DrKonqi
New crash information added by DrKonqi

Description Ac17 2010-11-03 04:47:24 UTC
Application: kpackagekitsmarticon (0.6.2)
KDE Platform Version: 4.5.1 (KDE 4.5.1)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-23-generic x86_64
Distribution: Ubuntu 10.10

-- Information about the crash:
- What I was doing when the application crashed:
I've just  downloading some mozilla integretion in the programs and just before I'd downloaded Sun's Java.

-- Backtrace:
Application: Kpackagekit (kpackagekitsmarticon), signal: Segmentation fault
[KCrash Handler]
#6  0x00007f79bd5c5963 in QWidget::releaseShortcut (this=0x178d3e0, id=-20) at kernel/qwidget.cpp:11043
#7  0x00007f79bd9a37f8 in QLabelPrivate::clearContents (this=0x179ebb0) at widgets/qlabel.cpp:1363
#8  0x00007f79bd9a4409 in QLabel::~QLabel (this=0x178d3e0, __in_chrg=<value optimized out>) at widgets/qlabel.cpp:262
#9  0x00007f79be8f4d5f in QObjectPrivate::deleteChildren (this=0x1721230) at kernel/qobject.cpp:1957
#10 0x00007f79bd5d7168 in QWidget::~QWidget (this=0x1788730, __in_chrg=<value optimized out>) at kernel/qwidget.cpp:1589
#11 0x00007f79be56c7ab in ~DebconfElement (this=0x1788730, __in_chrg=<value optimized out>) at /build/buildd/libdebconf-kde-0.1~svn1167939/src/DebconfElement.h:26
#12 DebconfKde::DebconfNote::~DebconfNote (this=0x1788730, __in_chrg=<value optimized out>) at /build/buildd/libdebconf-kde-0.1~svn1167939/src/DebconfNote.cpp:32
#13 0x00007f79be8f4d5f in QObjectPrivate::deleteChildren (this=0x179e5a0) at kernel/qobject.cpp:1957
#14 0x00007f79bd5d657c in QWidget::~QWidget (this=0x17a3c50, __in_chrg=<value optimized out>) at kernel/qwidget.cpp:1589
#15 0x00007f79be8f4d5f in QObjectPrivate::deleteChildren (this=0x17288d0) at kernel/qobject.cpp:1957
#16 0x00007f79bd5d657c in QWidget::~QWidget (this=0x1720c40, __in_chrg=<value optimized out>) at kernel/qwidget.cpp:1589
#17 0x00007f79be8f4d5f in QObjectPrivate::deleteChildren (this=0x1728620) at kernel/qobject.cpp:1957
#18 0x00007f79bd5d7168 in QWidget::~QWidget (this=0x1715c20, __in_chrg=<value optimized out>) at kernel/qwidget.cpp:1589
#19 0x00007f79bda30c01 in QScrollArea::~QScrollArea (this=0x7f79bc209e40, __in_chrg=<value optimized out>) at widgets/qscrollarea.cpp:176
#20 0x00007f79be8f4d5f in QObjectPrivate::deleteChildren (this=0x16d7b20) at kernel/qobject.cpp:1957
#21 0x00007f79bd5d7168 in QWidget::~QWidget (this=0x172e1e0, __in_chrg=<value optimized out>) at kernel/qwidget.cpp:1589
#22 0x00007f79be571c71 in DebconfKde::DebconfGui::~DebconfGui (this=0x7f79bc209e40, __in_chrg=<value optimized out>) at /build/buildd/libdebconf-kde-0.1~svn1167939/src/DebconfGui.h:62
#23 0x0000000000413576 in _start ()

Reported using DrKonqi
Comment 1 Daniel Nicoletti 2010-11-03 11:19:24 UTC
Can you please say which exactly packages where you downloading?
They might help reproduce the crash
Comment 2 Ac17 2010-11-04 21:51:43 UTC
(In reply to comment #1)
> Can you please say which exactly packages where you downloading?
> They might help reproduce the crash

I'm just downloaded java6 Sun but after I had the crash I autodelete and I've a lot of bad things in my computer 228 Meg. After that it's work very fine, so i think we should blame me ;-)
Comment 3 Dario Andres 2010-12-12 19:22:57 UTC
[Comment from a bug triager]
Bug 259460 and bug 256821 also have a similar backtrace (which contains "~DebconfElement"...)
Thanks
Comment 4 Dario Andres 2011-01-31 01:06:17 UTC
[Comment from a bug triager]
From bug 259460:
Ran wireshark packet capture previous to downloading and also changed ethernet
port from monitor destination to normal port (on cisco switch) in order to
download more tools.
Just completed downloading rrdtool and started on MySQL Server download,
returned to see crash report.
Comment 5 Dario Andres 2011-01-31 01:06:21 UTC
*** Bug 259460 has been marked as a duplicate of this bug. ***
Comment 6 Dario Andres 2011-01-31 01:06:26 UTC
*** Bug 262832 has been marked as a duplicate of this bug. ***
Comment 7 Ac17 2011-01-31 17:33:07 UTC
My KPackagekit is working just fine now, and I' ve move'd on to Nathy.

--- Den mån 2011-01-31 skrev Dario Andres <andresbajotierra@gmail.com>:

Från: Dario Andres <andresbajotierra@gmail.com>
Ämne: [Bug 255935] KPackageKit crashed when downloading some packages (libdebconfkde) [QWidget::releaseShortcut, QLabelPrivate::clearContents, ~QLabel, ..., ~DebconfElement]
Till: fd.svensson@yahoo.se
Datum: måndag 31 januari 2011 00:06

https://bugs.kde.org/show_bug.cgi?id=255935


Dario Andres <andresbajotierra@gmail.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |cpark@farmersnational.com




--- Comment #5 from Dario Andres <andresbajotierra gmail com>  2011-01-31 01:06:21 ---
*** Bug 259460 has been marked as a duplicate of this bug. ***
Comment 8 Dario Andres 2011-03-08 21:12:41 UTC
[Comment from a bug triager]
From bug 266744:
- What I was doing when the application crashed:
I was installing ebox-samba and when it was almost done it crashed.

[KCrash Handler]
#6  0x00007f5f47031963 in QWidget::releaseShortcut (this=0x277f530, id=-57) at
kernel/qwidget.cpp:11043
#7  0x00007f5f4740f7f8 in QLabelPrivate::clearContents (this=0x2733d50) at
widgets/qlabel.cpp:1363
#8  0x00007f5f47410409 in QLabel::~QLabel (this=0x277f530, __in_chrg=<value
optimized out>) at widgets/qlabel.cpp:262
#9  0x00007f5f48360d5f in QObjectPrivate::deleteChildren (this=0x2688d20) at
kernel/qobject.cpp:1957
#10 0x00007f5f47043168 in QWidget::~QWidget (this=0x24fb1d0, __in_chrg=<value
optimized out>) at kernel/qwidget.cpp:1589
#11 0x00007f5f47fd7bfb in ~DebconfElement (this=0x24fb1d0, __in_chrg=<value
optimized out>) at
/build/buildd/libdebconf-kde-0.1~svn1167939/src/DebconfElement.h:26
#12 DebconfKde::DebconfMultiselect::~DebconfMultiselect (this=0x24fb1d0,
__in_chrg=<value optimized out>) at
/build/buildd/libdebconf-kde-0.1~svn1167939/src/DebconfMultiselect.cpp:38
#13 0x00007f5f48360d5f in QObjectPrivate::deleteChildren (this=0x26d1ab0) at
kernel/qobject.cpp:1957

From bug 267264:
- What I was doing when the application crashed: I had just install DVD Styler
and closed Kpackage and afterwards the crash happened

[KCrash Handler]
#6  0x00007fb7b585a963 in QWidget::releaseShortcut (this=0x130d2c0, id=-32) at
kernel/qwidget.cpp:11043
#7  0x00007fb7b5c387f8 in QLabelPrivate::clearContents (this=0x130fab0) at
widgets/qlabel.cpp:1363
#8  0x00007fb7b5c39409 in QLabel::~QLabel (this=0x130d2c0, __in_chrg=<value
optimized out>) at widgets/qlabel.cpp:262
#9  0x00007fb7b6b89d5f in QObjectPrivate::deleteChildren (this=0xfb2470) at
kernel/qobject.cpp:1957
#10 0x00007fb7b586c168 in QWidget::~QWidget (this=0xf41470, __in_chrg=<value
optimized out>) at kernel/qwidget.cpp:1589
#11 0x00007fb7b680324b in ~DebconfElement (this=0xf41470, __in_chrg=<value
optimized out>) at
/build/buildd/libdebconf-kde-0.1~svn1167939/src/DebconfElement.h:26
#12 DebconfKde::DebconfString::~DebconfString (this=0xf41470, __in_chrg=<value
optimized out>) at
/build/buildd/libdebconf-kde-0.1~svn1167939/src/DebconfString.cpp:32


From bug 267867:
- What I was doing when the application crashed:
I removed the source code lines from the software sources & cliked OK. Then it
crashed.
Comment 9 Dario Andres 2011-03-08 21:12:47 UTC
*** Bug 266744 has been marked as a duplicate of this bug. ***
Comment 10 Dario Andres 2011-03-08 21:12:50 UTC
*** Bug 267264 has been marked as a duplicate of this bug. ***
Comment 11 Dario Andres 2011-03-08 21:12:54 UTC
*** Bug 267867 has been marked as a duplicate of this bug. ***
Comment 12 Ronny Standtke 2011-05-07 15:21:57 UTC
Created attachment 59727 [details]
New crash information added by DrKonqi

kpackagekitsmarticon (0.6.3.3) on KDE Platform 4.6.2 (4.6.2) using Qt 4.7.2

- What I was doing when the application crashed:

Installed some applications and closed kpackagekit

-- Backtrace (Reduced):
#6  QWidget::releaseShortcut (this=0x854a20, id=-14) at kernel/qwidget.cpp:11164
#7  0x00007fd905f54b23 in QLabelPrivate::clearContents (this=0x8259b0) at widgets/qlabel.cpp:1365
#8  0x00007fd905f54e19 in QLabel::~QLabel (this=0x854a20, __in_chrg=<value optimized out>) at widgets/qlabel.cpp:262
#9  0x00007fd905f54e59 in QLabel::~QLabel (this=0x854a20, __in_chrg=<value optimized out>) at widgets/qlabel.cpp:263
#10 0x00007fd906e66c14 in QObjectPrivate::deleteChildren (this=0x84f970) at kernel/qobject.cpp:1964
Comment 13 Samir 2011-05-14 20:37:29 UTC
Created attachment 59997 [details]
New crash information added by DrKonqi

kpackagekitsmarticon (0.6.3.3) on KDE Platform 4.6.3 (4.6.3) using Qt 4.7.2

- What I was doing when the application crashed:
I opened the KPackageKit and I started to install sun-java-jre and sun-java-jdk, when finished downloading it showed me an error saying could not install. without closing the KPackageKit I started to install the synaptic, when finished downloading, KPackageKit installed sun-java-jre , sun-java-jdk and synaptic. then i closed the KPackageKit and it crash.
I had already passed this on a previous installation of kubuntu 11.04, the last time i installed kubuntu 11.04 x86, in this time i have kubuntu 11.04 x64
I think there is a problem in the installation process of sun-java-jre and sun-java-jdk
I installed sun-java-jre and sun-java-jdk, 
- Unusual behavior I noticed:
I had already passed this on a previous installation of kubuntu 11.04, the last time i installed kubuntu 11.04 x86, in this time i have kubuntu 11.04 x64
I think there is a problem in the installation process of sun-java-jre and sun-java-jdk
I installed sun-java-jre and sun-java-jdk,

-- Backtrace (Reduced):
#6  QWidget::releaseShortcut (this=0xb8f000, id=-12) at kernel/qwidget.cpp:11164
#7  0x00007f52ae846b23 in QLabelPrivate::clearContents (this=0xba7f50) at widgets/qlabel.cpp:1365
#8  0x00007f52ae846e19 in QLabel::~QLabel (this=0xb8f000, __in_chrg=<value optimized out>) at widgets/qlabel.cpp:262
#9  0x00007f52ae846e59 in QLabel::~QLabel (this=0xb8f000, __in_chrg=<value optimized out>) at widgets/qlabel.cpp:263
#10 0x00007f52af758c14 in QObjectPrivate::deleteChildren (this=0xb61360) at kernel/qobject.cpp:1964
Comment 14 Jekyll Wu 2011-12-01 04:26:30 UTC
*** Bug 271505 has been marked as a duplicate of this bug. ***
Comment 15 Daniel Nicoletti 2012-04-03 02:56:22 UTC
*** Bug 287188 has been marked as a duplicate of this bug. ***
Comment 16 Daniel Nicoletti 2012-04-03 02:56:39 UTC
*** Bug 285324 has been marked as a duplicate of this bug. ***
Comment 17 Daniel Nicoletti 2012-04-03 02:58:32 UTC
Git commit dbfb2d039702b046fd20f544dd4ed657c1fc24c5 by Daniel Nicoletti.
Committed on 03/04/2012 at 04:57.
Pushed by dantti into branch 'master'.

Fix crash when quiting apper-sentinel due to late deleting

M  +27   -8    Sentinel/DBusInterface.cpp
M  +2    -1    Sentinel/DBusInterface.h
M  +1    -0    Sentinel/org.kde.ApperSentinel.xml
M  +10   -5    libapper/PkTransaction.cpp

http://commits.kde.org/apper/dbfb2d039702b046fd20f544dd4ed657c1fc24c5
Comment 18 mer2329 2012-06-19 19:30:58 UTC
Created attachment 71960 [details]
New crash information added by DrKonqi

apper-sentinel (0.7.1) on KDE Platform 4.8.3 (4.8.3) using Qt 4.8.1

i was installing "mdadm" through software management in the system settings because "muon" always asks for my password and when complete resets the view back to the index, making me lose my place. this has happened many times but i finallt realize what is doing it

-- Backtrace (Reduced):
#7  QWidget::releaseShortcut (this=0x8d92a10, id=-3) at kernel/qwidget.cpp:11330
#8  0xb61dd5b1 in QLabelPrivate::clearContents (this=0x8d8a568) at widgets/qlabel.cpp:1389
#9  0xb61dd908 in QLabel::~QLabel (this=0x8d92a10, __in_chrg=<optimized out>) at widgets/qlabel.cpp:277
#10 0xb61dd972 in QLabel::~QLabel (this=0x8d92a10, __in_chrg=<optimized out>) at widgets/qlabel.cpp:278
#11 0xb6cf2d11 in QObjectPrivate::deleteChildren (this=0x8d7ee48) at kernel/qobject.cpp:1908
Comment 19 Daniel Nicoletti 2012-06-19 20:23:12 UTC
Please note the bug is fixed on Apper 0.7.2
Comment 20 wheelband 2012-11-01 23:46:40 UTC
Created attachment 74926 [details]
New crash information added by DrKonqi

apper-sentinel (0.7.1) on KDE Platform 4.8.5 (4.8.5) using Qt 4.8.1

- What I was doing when the application crashed:
when ever i install new packeges my system crashes several times same as when i boot

-- Backtrace (Reduced):
#7  QWidget::releaseShortcut (this=0x90f7ee8, id=-3) at kernel/qwidget.cpp:11330
#8  0xb619c5c1 in QLabelPrivate::clearContents (this=0x90f70e8) at widgets/qlabel.cpp:1389
#9  0xb619c918 in QLabel::~QLabel (this=0x90f7ee8, __in_chrg=<optimized out>) at widgets/qlabel.cpp:277
#10 0xb619c982 in QLabel::~QLabel (this=0x90f7ee8, __in_chrg=<optimized out>) at widgets/qlabel.cpp:278
#11 0xb6cb1d11 in QObjectPrivate::deleteChildren (this=0x8efb818) at kernel/qobject.cpp:1908
Comment 21 Daniel Nicoletti 2012-11-01 23:48:17 UTC
Please note the bug is fixed on Apper 0.7.2
Comment 22 bosyber 2012-12-14 12:10:37 UTC
*** Bug 311683 has been marked as a duplicate of this bug. ***
Comment 23 Herman 2013-08-14 10:17:19 UTC
Created attachment 81701 [details]
New crash information added by DrKonqi

apper-sentinel (0.7.1) on KDE Platform 4.8.5 (4.8.5) using Qt 4.8.1

- What I was doing when the application crashed:

Installed Firefox on clean system with autoupgrade finished BUT not reboot

-- Backtrace (Reduced):
#7  QWidget::releaseShortcut (this=0x84e2600, id=-5) at kernel/qwidget.cpp:11330
#8  0xb62665c1 in QLabelPrivate::clearContents (this=0x83ddcb0) at widgets/qlabel.cpp:1389
#9  0xb6266918 in QLabel::~QLabel (this=0x84e2600, __in_chrg=<optimized out>) at widgets/qlabel.cpp:277
#10 0xb6266982 in QLabel::~QLabel (this=0x84e2600, __in_chrg=<optimized out>) at widgets/qlabel.cpp:278
#11 0xb6d7bd11 in QObjectPrivate::deleteChildren (this=0x83f67d0) at kernel/qobject.cpp:1908