Bug 285324 - Apper crash after installed java+java fonts
Summary: Apper crash after installed java+java fonts
Status: RESOLVED DUPLICATE of bug 255935
Alias: None
Product: apper
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Daniel Nicoletti
URL:
Keywords:
: 287925 289226 289612 292201 294725 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-10-30 15:44 UTC by quamis
Modified: 2012-04-03 02:56 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description quamis 2011-10-30 15:44:48 UTC
Application: apper-sentinel (0.7.0)
KDE Platform Version: 4.7.1 (4.7.1)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-12-generic-pae i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:

I already had openjdk. but i installed the java package from sun. All packages got installed, and the app crashed while refreshing the software list.

-- Backtrace:
Application: Apper (apper-sentinel), signal: Segmentation fault
[KCrash Handler]
#7  QWidget::releaseShortcut (this=0x96642d0, id=-3) at kernel/qwidget.cpp:11208
#8  0xb63f49e1 in QLabelPrivate::clearContents (this=0x9662848) at widgets/qlabel.cpp:1365
#9  0xb63f4d38 in QLabel::~QLabel (this=0x96642d0, __in_chrg=<optimized out>) at widgets/qlabel.cpp:262
#10 0xb63f4da2 in QLabel::~QLabel (this=0x96642d0, __in_chrg=<optimized out>) at widgets/qlabel.cpp:263
#11 0xb6edc841 in QObjectPrivate::deleteChildren (this=0x9659808) at kernel/qobject.cpp:1955
#12 0xb5fe6f8e in QWidget::~QWidget (this=0x9616148, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1651
#13 0xb6d54abd in ~DebconfElement (this=0x9616148, __in_chrg=<optimized out>) at /build/buildd/debconf-kde-0.1+git20110702/src/DebconfElement.h:25
#14 DebconfKde::DebconfNote::~DebconfNote (this=0x9616148, __in_chrg=<optimized out>) at /build/buildd/debconf-kde-0.1+git20110702/src/DebconfNote.cpp:30
#15 0xb6d54b02 in DebconfKde::DebconfNote::~DebconfNote (this=0x9616148, __in_chrg=<optimized out>) at /build/buildd/debconf-kde-0.1+git20110702/src/DebconfNote.cpp:32
#16 0xb6edc841 in QObjectPrivate::deleteChildren (this=0x9643468) at kernel/qobject.cpp:1955
#17 0xb5fe6f8e in QWidget::~QWidget (this=0x96622d0, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1651
#18 0xb5fe7262 in QWidget::~QWidget (this=0x96622d0, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1671
#19 0xb6edc841 in QObjectPrivate::deleteChildren (this=0x96461f0) at kernel/qobject.cpp:1955
#20 0xb5fe6f8e in QWidget::~QWidget (this=0x96461d8, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1651
#21 0xb5fe7262 in QWidget::~QWidget (this=0x96461d8, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1671
#22 0xb6edc841 in QObjectPrivate::deleteChildren (this=0x9645fd8) at kernel/qobject.cpp:1955
#23 0xb5fe6f8e in QWidget::~QWidget (this=0x96446c0, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1651
#24 0xb63f090f in QFrame::~QFrame (this=0x96446c0, __in_chrg=<optimized out>) at widgets/qframe.cpp:240
#25 0xb6483644 in QAbstractScrollArea::~QAbstractScrollArea (this=0x96446c0, __in_chrg=<optimized out>) at widgets/qabstractscrollarea.cpp:521
#26 0xb648855f in QScrollArea::~QScrollArea (this=0x96446c0, __in_chrg=<optimized out>) at widgets/qscrollarea.cpp:174
#27 0xb64885a2 in QScrollArea::~QScrollArea (this=0x96446c0, __in_chrg=<optimized out>) at widgets/qscrollarea.cpp:176
#28 0xb6edc841 in QObjectPrivate::deleteChildren (this=0x9644920) at kernel/qobject.cpp:1955
#29 0xb5fe6f8e in QWidget::~QWidget (this=0x96609a0, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1651
#30 0xb6d59b15 in ~DebconfGui (this=0x96609a0, __in_chrg=<optimized out>) at /build/buildd/debconf-kde-0.1+git20110702/src/DebconfGui.h:88
#31 DebconfKde::DebconfGui::~DebconfGui (this=0x96609a0, __in_chrg=<optimized out>) at /build/buildd/debconf-kde-0.1+git20110702/src/DebconfGui.h:88
#32 0x0805f5d4 in DBusInterface::~DBusInterface (this=0x9666330, __in_chrg=<optimized out>) at /build/buildd/apper-0.7.0~20111008/Sentinel/DBusInterface.cpp:56
#33 0x0805f680 in DBusInterface::~DBusInterface (this=0x9666330, __in_chrg=<optimized out>) at /build/buildd/apper-0.7.0~20111008/Sentinel/DBusInterface.cpp:59
#34 0xb6edc841 in QObjectPrivate::deleteChildren (this=0x9533800) at kernel/qobject.cpp:1955
#35 0xb6ee1439 in QObject::~QObject (this=0xbff8df68, __in_chrg=<optimized out>) at kernel/qobject.cpp:946
#36 0xb6ecb648 in QCoreApplication::~QCoreApplication (this=0xbff8df68, __in_chrg=<optimized out>) at kernel/qcoreapplication.cpp:671
#37 0xb5f9c943 in QApplication::~QApplication (this=0xbff8df68, __in_chrg=<optimized out>) at kernel/qapplication.cpp:1093
#38 0xb761e418 in KApplication::~KApplication (this=0xbff8df68, __in_chrg=<optimized out>) at ../../kdeui/kernel/kapplication.cpp:894
#39 0xb7626248 in KUniqueApplication::~KUniqueApplication (this=0xbff8df68, __in_chrg=<optimized out>) at ../../kdeui/kernel/kuniqueapplication.cpp:347
#40 0x0805400c in main (argc=7602293, argv=0x19) at /build/buildd/apper-0.7.0~20111008/Sentinel/main.cpp:53

Reported using DrKonqi
Comment 1 Jekyll Wu 2011-12-01 04:24:08 UTC
maybe related with bug 287188 and bug 287925
Comment 2 Myriam Schweingruber 2011-12-07 14:57:16 UTC
*** Bug 287925 has been marked as a duplicate of this bug. ***
Comment 3 Myriam Schweingruber 2011-12-07 14:58:13 UTC
Confirmed by duplicate.
Comment 4 Christoph Feck 2011-12-17 19:10:25 UTC
*** Bug 289226 has been marked as a duplicate of this bug. ***
Comment 5 Jekyll Wu 2011-12-22 20:45:11 UTC
*** Bug 289612 has been marked as a duplicate of this bug. ***
Comment 6 Jekyll Wu 2012-01-22 15:42:12 UTC
*** Bug 292201 has been marked as a duplicate of this bug. ***
Comment 7 Jekyll Wu 2012-02-24 05:41:30 UTC
*** Bug 294725 has been marked as a duplicate of this bug. ***
Comment 8 Daniel Nicoletti 2012-04-03 02:56:39 UTC

*** This bug has been marked as a duplicate of bug 255935 ***