Bug 266744 - KPackageKit Crash
Summary: KPackageKit Crash
Status: RESOLVED DUPLICATE of bug 255935
Alias: None
Product: kpackagekit
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash
Target Milestone: ---
Assignee: Steven M. Parrish
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-02-20 19:33 UTC by timothy997
Modified: 2011-03-08 21:12 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description timothy997 2011-02-20 19:33:41 UTC
Application: kpackagekitsmarticon (0.6.2)
KDE Platform Version: 4.5.1 (KDE 4.5.1)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-25-generic x86_64
Distribution: Ubuntu 10.10

-- Information about the crash:
- What I was doing when the application crashed:

I was installing ebox-samba and when it was almost done it crashed.

-- Backtrace:
Application: KPackageKit (kpackagekitsmarticon), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f5f49f49760 (LWP 2866))]

Thread 2 (Thread 0x7f5f3290a700 (LWP 3193)):
#0  0xffffffffff60017b in ?? ()
#1  0x00007f5f32909a90 in ?? ()
#2  0x00007fff8a1ff852 in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 1 (Thread 0x7f5f49f49760 (LWP 2866)):
[KCrash Handler]
#6  0x00007f5f47031963 in QWidget::releaseShortcut (this=0x277f530, id=-57) at kernel/qwidget.cpp:11043
#7  0x00007f5f4740f7f8 in QLabelPrivate::clearContents (this=0x2733d50) at widgets/qlabel.cpp:1363
#8  0x00007f5f47410409 in QLabel::~QLabel (this=0x277f530, __in_chrg=<value optimized out>) at widgets/qlabel.cpp:262
#9  0x00007f5f48360d5f in QObjectPrivate::deleteChildren (this=0x2688d20) at kernel/qobject.cpp:1957
#10 0x00007f5f47043168 in QWidget::~QWidget (this=0x24fb1d0, __in_chrg=<value optimized out>) at kernel/qwidget.cpp:1589
#11 0x00007f5f47fd7bfb in ~DebconfElement (this=0x24fb1d0, __in_chrg=<value optimized out>) at /build/buildd/libdebconf-kde-0.1~svn1167939/src/DebconfElement.h:26
#12 DebconfKde::DebconfMultiselect::~DebconfMultiselect (this=0x24fb1d0, __in_chrg=<value optimized out>) at /build/buildd/libdebconf-kde-0.1~svn1167939/src/DebconfMultiselect.cpp:38
#13 0x00007f5f48360d5f in QObjectPrivate::deleteChildren (this=0x26d1ab0) at kernel/qobject.cpp:1957
#14 0x00007f5f4704257c in QWidget::~QWidget (this=0x26383d0, __in_chrg=<value optimized out>) at kernel/qwidget.cpp:1589
#15 0x00007f5f48360d5f in QObjectPrivate::deleteChildren (this=0x22e7860) at kernel/qobject.cpp:1957
#16 0x00007f5f4704257c in QWidget::~QWidget (this=0x227f490, __in_chrg=<value optimized out>) at kernel/qwidget.cpp:1589
#17 0x00007f5f48360d5f in QObjectPrivate::deleteChildren (this=0x22e8aa0) at kernel/qobject.cpp:1957
#18 0x00007f5f47043168 in QWidget::~QWidget (this=0x22882c0, __in_chrg=<value optimized out>) at kernel/qwidget.cpp:1589
#19 0x00007f5f4749cc01 in QScrollArea::~QScrollArea (this=0x7f5f45c75e40, __in_chrg=<value optimized out>) at widgets/qscrollarea.cpp:176
#20 0x00007f5f48360d5f in QObjectPrivate::deleteChildren (this=0x22f02a0) at kernel/qobject.cpp:1957
#21 0x00007f5f47043168 in QWidget::~QWidget (this=0x22e6810, __in_chrg=<value optimized out>) at kernel/qwidget.cpp:1589
#22 0x00007f5f47fddc71 in DebconfKde::DebconfGui::~DebconfGui (this=0x7f5f45c75e40, __in_chrg=<value optimized out>) at /build/buildd/libdebconf-kde-0.1~svn1167939/src/DebconfGui.h:62
#23 0x0000000000413576 in _start ()

Possible duplicates by query: bug 262832, bug 259460, bug 256821, bug 255935, bug 253930.

Reported using DrKonqi
Comment 1 Dario Andres 2011-03-08 21:12:47 UTC
[Comment from a bug triager]
This issue is being tracked at bug 255935.
Merging. Thanks

*** This bug has been marked as a duplicate of bug 255935 ***