Bug 267264 - K Package crash
Summary: K Package crash
Status: RESOLVED DUPLICATE of bug 255935
Alias: None
Product: kpackagekit
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash
Target Milestone: ---
Assignee: Steven M. Parrish
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-02-27 17:47 UTC by durham_harry
Modified: 2011-03-08 21:12 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description durham_harry 2011-02-27 17:47:38 UTC
Application: kpackagekitsmarticon (0.6.2)
KDE Platform Version: 4.5.1 (KDE 4.5.1) (Compiled from sources)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-25-generic x86_64
Distribution: Ubuntu 10.10

-- Information about the crash:
- What I was doing when the application crashed: I had just install DVD Styler and closed Kpackage and afterwards the crash happened.

-- Backtrace:
Application: KPackageKit (kpackagekitsmarticon), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fb7b8770760 (LWP 12548))]

Thread 2 (Thread 0x7fb7a52ae700 (LWP 13605)):
#0  0x00007fb7b41fa203 in __poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fb7b0d49009 in ?? () from /lib/libglib-2.0.so.0
#2  0x00007fb7b0d4945c in g_main_context_iteration () from /lib/libglib-2.0.so.0
#3  0x00007fb7b6ba41e6 in QEventDispatcherGlib::processEvents (this=0x12b2010, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:417
#4  0x00007fb7b6b76a02 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#5  0x00007fb7b6b76dec in QEventLoop::exec (this=0x7fb7a52addb0, flags=) at kernel/qeventloop.cpp:201
#6  0x00007fb7b6a812fd in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#7  0x00007fb7b6b565f8 in QInotifyFileSystemWatcherEngine::run (this=0x12b10d0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007fb7b6a8427e in QThreadPrivate::start (arg=0x12b10d0) at thread/qthread_unix.cpp:266
#9  0x00007fb7b4c49971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#10 0x00007fb7b420692d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fb7b8770760 (LWP 12548)):
[KCrash Handler]
#6  0x00007fb7b585a963 in QWidget::releaseShortcut (this=0x130d2c0, id=-32) at kernel/qwidget.cpp:11043
#7  0x00007fb7b5c387f8 in QLabelPrivate::clearContents (this=0x130fab0) at widgets/qlabel.cpp:1363
#8  0x00007fb7b5c39409 in QLabel::~QLabel (this=0x130d2c0, __in_chrg=<value optimized out>) at widgets/qlabel.cpp:262
#9  0x00007fb7b6b89d5f in QObjectPrivate::deleteChildren (this=0xfb2470) at kernel/qobject.cpp:1957
#10 0x00007fb7b586c168 in QWidget::~QWidget (this=0xf41470, __in_chrg=<value optimized out>) at kernel/qwidget.cpp:1589
#11 0x00007fb7b680324b in ~DebconfElement (this=0xf41470, __in_chrg=<value optimized out>) at /build/buildd/libdebconf-kde-0.1~svn1167939/src/DebconfElement.h:26
#12 DebconfKde::DebconfString::~DebconfString (this=0xf41470, __in_chrg=<value optimized out>) at /build/buildd/libdebconf-kde-0.1~svn1167939/src/DebconfString.cpp:32
#13 0x00007fb7b6b89d5f in QObjectPrivate::deleteChildren (this=0x10064d0) at kernel/qobject.cpp:1957
#14 0x00007fb7b586b57c in QWidget::~QWidget (this=0x12f1ef0, __in_chrg=<value optimized out>) at kernel/qwidget.cpp:1589
#15 0x00007fb7b6b89d5f in QObjectPrivate::deleteChildren (this=0xf286b0) at kernel/qobject.cpp:1957
#16 0x00007fb7b586b57c in QWidget::~QWidget (this=0xf1ef60, __in_chrg=<value optimized out>) at kernel/qwidget.cpp:1589
#17 0x00007fb7b6b89d5f in QObjectPrivate::deleteChildren (this=0xf281a0) at kernel/qobject.cpp:1957
#18 0x00007fb7b586c168 in QWidget::~QWidget (this=0xee9b10, __in_chrg=<value optimized out>) at kernel/qwidget.cpp:1589
#19 0x00007fb7b5cc5c01 in QScrollArea::~QScrollArea (this=0x7fb7b449ee40, __in_chrg=<value optimized out>) at widgets/qscrollarea.cpp:176
#20 0x00007fb7b6b89d5f in QObjectPrivate::deleteChildren (this=0xf2d710) at kernel/qobject.cpp:1957
#21 0x00007fb7b586c168 in QWidget::~QWidget (this=0xf29e50, __in_chrg=<value optimized out>) at kernel/qwidget.cpp:1589
#22 0x00007fb7b6806c71 in DebconfKde::DebconfGui::~DebconfGui (this=0x7fb7b449ee40, __in_chrg=<value optimized out>) at /build/buildd/libdebconf-kde-0.1~svn1167939/src/DebconfGui.h:62
#23 0x0000000000413576 in _start ()

Possible duplicates by query: bug 266744, bug 262832, bug 259460, bug 256821, bug 255935.

Reported using DrKonqi
Comment 1 Dario Andres 2011-03-08 21:12:50 UTC
[Comment from a bug triager]
This issue is being tracked at bug 255935.
Merging. Thanks

*** This bug has been marked as a duplicate of bug 255935 ***