Bug 262832 - Q4Wine crashed on First Initialization with Amarok running
Summary: Q4Wine crashed on First Initialization with Amarok running
Status: RESOLVED DUPLICATE of bug 255935
Alias: None
Product: kpackagekit
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash
Target Milestone: ---
Assignee: Steven M. Parrish
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-01-11 09:01 UTC by Keijo D. Putt
Modified: 2011-01-31 01:06 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Keijo D. Putt 2011-01-11 09:01:30 UTC
Application: kpackagekitsmarticon (0.6.2)
KDE Platform Version: 4.5.1 (KDE 4.5.1)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-24-generic i686
Distribution: Ubuntu 10.10

-- Information about the crash:
- What I was doing when the application crashed:

I left the laptop unattended for a few minutes, while Amarok was playing. Q4wine was expecting some input (Step 7 of 8), and it coincidentally crashed, on idle time, just when Amarok changed the track it was playing. Music still sounds, though...

-- Backtrace:
Application: KPackageKit (kpackagekitsmarticon), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7869710 (LWP 2428))]

Thread 2 (Thread 0xb409bb70 (LWP 2829)):
#0  0x00833416 in __kernel_vsyscall ()
#1  0x00a1ddf6 in poll () from /lib/libc.so.6
#2  0x04abfa1b in g_poll () from /lib/libglib-2.0.so.0
#3  0x04ab243c in ?? () from /lib/libglib-2.0.so.0
#4  0x04ab2848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#5  0x0118559f in QEventDispatcherGlib::processEvents (this=0x8bb1228, flags=...) at kernel/qeventdispatcher_glib.cpp:417
#6  0x01155609 in QEventLoop::processEvents (this=0xb409b290, flags=) at kernel/qeventloop.cpp:149
#7  0x01155a8a in QEventLoop::exec (this=0xb409b290, flags=...) at kernel/qeventloop.cpp:201
#8  0x01051b7e in QThread::exec (this=0x8da2468) at thread/qthread.cpp:490
#9  0x0113435b in QInotifyFileSystemWatcherEngine::run (this=0x8da2468) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x01054df9 in QThreadPrivate::start (arg=0x8da2468) at thread/qthread_unix.cpp:266
#11 0x00790cc9 in start_thread () from /lib/libpthread.so.0
#12 0x00a2c69e in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb7869710 (LWP 2428)):
[KCrash Handler]
#7  0x05aea232 in QWidget::releaseShortcut (this=0x8ace278, id=-5) at kernel/qwidget.cpp:11043
#8  0x05f1f910 in QLabelPrivate::clearContents (this=0x8b9beb0) at widgets/qlabel.cpp:1363
#9  0x05f204a8 in QLabel::~QLabel (this=0x8ace278, __in_chrg=<value optimized out>) at widgets/qlabel.cpp:262
#10 0x01169816 in QObjectPrivate::deleteChildren (this=0x8b9ca38) at kernel/qobject.cpp:1957
#11 0x05afc8fc in QWidget::~QWidget (this=0x8b904e0, __in_chrg=<value optimized out>) at kernel/qwidget.cpp:1589
#12 0x00b870ad in ~DebconfElement (this=0x8b904e0, __in_chrg=<value optimized out>) at /build/buildd/libdebconf-kde-0.1~svn1167939/src/DebconfElement.h:26
#13 DebconfKde::DebconfBoolean::~DebconfBoolean (this=0x8b904e0, __in_chrg=<value optimized out>) at /build/buildd/libdebconf-kde-0.1~svn1167939/src/DebconfBoolean.cpp:32
#14 0x01169816 in QObjectPrivate::deleteChildren (this=0x8b87860) at kernel/qobject.cpp:1957
#15 0x05afbcbc in QWidget::~QWidget (this=0x8b89a40, __in_chrg=<value optimized out>) at kernel/qwidget.cpp:1589
#16 0x01169816 in QObjectPrivate::deleteChildren (this=0x8b6a910) at kernel/qobject.cpp:1957
#17 0x05afbcbc in QWidget::~QWidget (this=0x8b699b0, __in_chrg=<value optimized out>) at kernel/qwidget.cpp:1589
#18 0x01169816 in QObjectPrivate::deleteChildren (this=0x8b6a758) at kernel/qobject.cpp:1957
#19 0x05afc8fc in QWidget::~QWidget (this=0x8b698d8, __in_chrg=<value optimized out>) at kernel/qwidget.cpp:1589
#20 0x05f18a61 in QFrame::~QFrame (this=0x8b698d8, __in_chrg=<value optimized out>) at widgets/qframe.cpp:242
#21 0x05fb7854 in QAbstractScrollArea::~QAbstractScrollArea (this=0x8b698d8, __in_chrg=<value optimized out>) at widgets/qabstractscrollarea.cpp:526
#22 0x05fbc095 in QScrollArea::~QScrollArea (this=0x8b698d8, __in_chrg=<value optimized out>) at widgets/qscrollarea.cpp:176
#23 0x01169816 in QObjectPrivate::deleteChildren (this=0x8b54218) at kernel/qobject.cpp:1957
#24 0x05afc8fc in QWidget::~QWidget (this=0x8ab0f20, __in_chrg=<value optimized out>) at kernel/qwidget.cpp:1589
#25 0x00b903b5 in DebconfKde::DebconfGui::~DebconfGui (this=0x8ab0f20, __in_chrg=<value optimized out>) at /build/buildd/libdebconf-kde-0.1~svn1167939/src/DebconfGui.h:62
#26 0x0805938c in _start ()

Possible duplicates by query: bug 259460, bug 256821, bug 255935, bug 253930.

Reported using DrKonqi
Comment 1 Dario Andres 2011-01-31 01:06:26 UTC
[Comment from a bug triager]
This issue is now being tracked at bug 255935. Merging. Thanks

*** This bug has been marked as a duplicate of bug 255935 ***