Bug 287188 - Random Crash
Summary: Random Crash
Status: RESOLVED DUPLICATE of bug 255935
Alias: None
Product: apper
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Daniel Nicoletti
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-11-21 20:20 UTC by Dave Gordon
Modified: 2012-04-03 02:56 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dave Gordon 2011-11-21 20:20:51 UTC
Application: apper-sentinel (0.7.0)
KDE Platform Version: 4.7.2 (4.7.2)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-12-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:

Just using the KDE menu (Classic style) - did not select the application  - In fact I think I was on the multimedia submenu

-- Backtrace:
Application: Apper (apper-sentinel), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f6ef25a3780 (LWP 4152))]

Thread 2 (Thread 0x7f6ee0ed8700 (LWP 10536)):
#0  0x00007f6eeea37773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f6eeb1cdf68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f6eeb1ce429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f6ef0e04f3e in QEventDispatcherGlib::processEvents (this=0x87d250, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f6ef0dd8cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f6ef0dd8ef7 in QEventLoop::exec (this=0x7f6ee0ed7dd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f6ef0cf027f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007f6ef0dbbcbf in QInotifyFileSystemWatcherEngine::run (this=0xd503f0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f6ef0cf2d05 in QThreadPrivate::start (arg=0xd503f0) at thread/qthread_unix.cpp:331
#9  0x00007f6eebcafefc in start_thread (arg=0x7f6ee0ed8700) at pthread_create.c:304
#10 0x00007f6eeea4389d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f6ef25a3780 (LWP 4152)):
[KCrash Handler]
#6  QWidget::releaseShortcut (this=0xa4e380, id=-3) at kernel/qwidget.cpp:11208
#7  0x00007f6eefad05a3 in QLabelPrivate::clearContents (this=0xa25eb0) at widgets/qlabel.cpp:1365
#8  0x00007f6eefad0899 in QLabel::~QLabel (this=<optimized out>, __in_chrg=<optimized out>) at widgets/qlabel.cpp:262
#9  0x00007f6eefad08d9 in QLabel::~QLabel (this=0xa4e380, __in_chrg=<optimized out>) at widgets/qlabel.cpp:263
#10 0x00007f6ef0debd75 in QObjectPrivate::deleteChildren (this=0xa1c020) at kernel/qobject.cpp:1955
#11 0x00007f6eef7200da in QWidget::~QWidget (this=0xa43280, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1651
#12 0x00007f6ef0a617b9 in DebconfKde::DebconfSelect::~DebconfSelect (this=0xa43280, __in_chrg=<optimized out>) at /build/buildd/debconf-kde-0.1+git20110702/src/DebconfSelect.cpp:32
#13 0x00007f6ef0debd75 in QObjectPrivate::deleteChildren (this=0xa10000) at kernel/qobject.cpp:1955
#14 0x00007f6eef7200da in QWidget::~QWidget (this=0xa45c80, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1651
#15 0x00007f6eef720379 in QWidget::~QWidget (this=0xa45c80, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1671
#16 0x00007f6ef0debd75 in QObjectPrivate::deleteChildren (this=0xa0e690) at kernel/qobject.cpp:1955
#17 0x00007f6eef7200da in QWidget::~QWidget (this=0xa56ae0, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1651
#18 0x00007f6eef720379 in QWidget::~QWidget (this=0xa56ae0, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1671
#19 0x00007f6ef0debd75 in QObjectPrivate::deleteChildren (this=0xa0e3e0) at kernel/qobject.cpp:1955
#20 0x00007f6eef7200da in QWidget::~QWidget (this=0xa00a50, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1651
#21 0x00007f6eefb51dd9 in QScrollArea::~QScrollArea (this=0xa00a50, __in_chrg=<optimized out>) at widgets/qscrollarea.cpp:176
#22 0x00007f6ef0debd75 in QObjectPrivate::deleteChildren (this=0x7df300) at kernel/qobject.cpp:1955
#23 0x00007f6eef7200da in QWidget::~QWidget (this=0xa010d0, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1651
#24 0x00007f6ef0a649b1 in ~DebconfGui (this=0xa010d0, __in_chrg=<optimized out>) at /build/buildd/debconf-kde-0.1+git20110702/src/DebconfGui.h:88
#25 DebconfKde::DebconfGui::~DebconfGui (this=<optimized out>, __in_chrg=<optimized out>) at /build/buildd/debconf-kde-0.1+git20110702/src/DebconfGui.h:88
#26 0x0000000000419ac4 in DBusInterface::~DBusInterface (this=0xa02d60, __in_chrg=<optimized out>) at /build/buildd/apper-0.7.0~20111008/Sentinel/DBusInterface.cpp:56
#27 0x0000000000419b59 in DBusInterface::~DBusInterface (this=0xa02d60, __in_chrg=<optimized out>) at /build/buildd/apper-0.7.0~20111008/Sentinel/DBusInterface.cpp:59
#28 0x00007f6ef0debd75 in QObjectPrivate::deleteChildren (this=0x7eef80) at kernel/qobject.cpp:1955
#29 0x00007f6ef0df1349 in QObject::~QObject (this=0x7fff5a733af0, __in_chrg=<optimized out>) at kernel/qobject.cpp:946
#30 0x00007f6eef6ddf87 in QApplication::~QApplication (this=0x7fff5a733af0, __in_chrg=<optimized out>) at kernel/qapplication.cpp:1093
#31 0x000000000040f719 in main (argc=1, argv=0x7fff5a733dd8) at /build/buildd/apper-0.7.0~20111008/Sentinel/main.cpp:53

Reported using DrKonqi
Comment 1 Daniel Nicoletti 2012-04-03 02:56:22 UTC

*** This bug has been marked as a duplicate of bug 255935 ***