Bug 267867 - Kpackagekit crashes when removing sources.
Summary: Kpackagekit crashes when removing sources.
Status: RESOLVED DUPLICATE of bug 255935
Alias: None
Product: kpackagekit
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash
Target Milestone: ---
Assignee: Steven M. Parrish
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-07 11:30 UTC by grahamt
Modified: 2011-03-08 21:12 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description grahamt 2011-03-07 11:30:26 UTC
Application: kpackagekitsmarticon (0.6.3.3)
KDE Platform Version: 4.6.1 (4.6.1)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-27-generic i686
Distribution: Ubuntu 10.10

-- Information about the crash:
- What I was doing when the application crashed:

I removed the source code lines from the software sources & cliked OK. Then it crashed.

The crash can be reproduced every time.

-- Backtrace:
Application: KPackageKit (kpackagekitsmarticon), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7791710 (LWP 10589))]

Thread 2 (Thread 0xb3f7bb70 (LWP 11211)):
#0  0x00da3e36 in clock_gettime (clock_id=14319604, tp=0xb3f7af90) at ../sysdeps/unix/clock_gettime.c:100
#1  0x00eab50b in do_gettime () at tools/qelapsedtimer_unix.cpp:105
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:119
#3  0x00f826e5 in QTimerInfoList::updateCurrentTime (this=0x9006684) at kernel/qeventdispatcher_unix.cpp:339
#4  0x00f8272a in QTimerInfoList::timerWait (this=0x9006684, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x00f807a8 in timerSourcePrepareHelper (src=<value optimized out>, timeout=0xb3f7b0bc) at kernel/qeventdispatcher_glib.cpp:136
#6  0x00f8083d in timerSourcePrepare (source=0x0, timeout=0xda7ff4) at kernel/qeventdispatcher_glib.cpp:169
#7  0x02d6fe6a in g_main_context_prepare () from /lib/libglib-2.0.so.0
#8  0x02d70279 in ?? () from /lib/libglib-2.0.so.0
#9  0x02d70848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#10 0x00f8059f in QEventDispatcherGlib::processEvents (this=0x8ec6378, flags=...) at kernel/qeventdispatcher_glib.cpp:417
#11 0x00f50609 in QEventLoop::processEvents (this=0xb3f7b290, flags=) at kernel/qeventloop.cpp:149
#12 0x00f50a8a in QEventLoop::exec (this=0xb3f7b290, flags=...) at kernel/qeventloop.cpp:201
#13 0x00e4cb7e in QThread::exec (this=0x9005c48) at thread/qthread.cpp:490
#14 0x00f2f35b in QInotifyFileSystemWatcherEngine::run (this=0x9005c48) at io/qfilesystemwatcher_inotify.cpp:248
#15 0x00e4fdf9 in QThreadPrivate::start (arg=0x9005c48) at thread/qthread_unix.cpp:266
#16 0x00d8bcc9 in start_thread (arg=0xb3f7bb70) at pthread_create.c:304
#17 0x0753f69e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 1 (Thread 0xb7791710 (LWP 10589)):
[KCrash Handler]
#7  0x02164232 in QWidget::releaseShortcut (this=0x8edd0b0, id=-17) at kernel/qwidget.cpp:11043
#8  0x02599910 in QLabelPrivate::clearContents (this=0x8eddb40) at widgets/qlabel.cpp:1363
#9  0x0259a4a8 in QLabel::~QLabel (this=0x8edd0b0, __in_chrg=<value optimized out>) at widgets/qlabel.cpp:262
#10 0x00f64816 in QObjectPrivate::deleteChildren (this=0x8e1ccc8) at kernel/qobject.cpp:1957
#11 0x021768fc in QWidget::~QWidget (this=0x8edd088, __in_chrg=<value optimized out>) at kernel/qwidget.cpp:1589
#12 0x002e7a3d in ~DebconfElement (this=0x8edd088, __in_chrg=<value optimized out>) at /build/buildd/libdebconf-kde-0.1~svn1167939/src/DebconfElement.h:26
#13 DebconfKde::DebconfNote::~DebconfNote (this=0x8edd088, __in_chrg=<value optimized out>) at /build/buildd/libdebconf-kde-0.1~svn1167939/src/DebconfNote.cpp:32
#14 0x00f64816 in QObjectPrivate::deleteChildren (this=0x8ed5268) at kernel/qobject.cpp:1957
#15 0x02175cbc in QWidget::~QWidget (this=0x8ee87f0, __in_chrg=<value optimized out>) at kernel/qwidget.cpp:1589
#16 0x00f64816 in QObjectPrivate::deleteChildren (this=0x8e1dc30) at kernel/qobject.cpp:1957
#17 0x02175cbc in QWidget::~QWidget (this=0x8e1ae68, __in_chrg=<value optimized out>) at kernel/qwidget.cpp:1589
#18 0x00f64816 in QObjectPrivate::deleteChildren (this=0x8e1ac20) at kernel/qobject.cpp:1957
#19 0x021768fc in QWidget::~QWidget (this=0x8e40c10, __in_chrg=<value optimized out>) at kernel/qwidget.cpp:1589
#20 0x02592a61 in QFrame::~QFrame (this=0x8e40c10, __in_chrg=<value optimized out>) at widgets/qframe.cpp:242
#21 0x02631854 in QAbstractScrollArea::~QAbstractScrollArea (this=0x8e40c10, __in_chrg=<value optimized out>) at widgets/qabstractscrollarea.cpp:526
#22 0x02636095 in QScrollArea::~QScrollArea (this=0x8e40c10, __in_chrg=<value optimized out>) at widgets/qscrollarea.cpp:176
#23 0x00f64816 in QObjectPrivate::deleteChildren (this=0x8e0a0e0) at kernel/qobject.cpp:1957
#24 0x021768fc in QWidget::~QWidget (this=0x8e68ff0, __in_chrg=<value optimized out>) at kernel/qwidget.cpp:1589
#25 0x002ee3b5 in DebconfKde::DebconfGui::~DebconfGui (this=0x8e68ff0, __in_chrg=<value optimized out>) at /build/buildd/libdebconf-kde-0.1~svn1167939/src/DebconfGui.h:62
#26 0x0805983c in _start ()

Possible duplicates by query: bug 267264, bug 266744, bug 262832, bug 259460, bug 256821.

Reported using DrKonqi
Comment 1 Dario Andres 2011-03-08 21:12:54 UTC
[Comment from a bug triager]
This issue is being tracked at bug 255935.
Merging. Thanks

*** This bug has been marked as a duplicate of bug 255935 ***