Bug 259460 - KpackageKit crash while downloading applications
Summary: KpackageKit crash while downloading applications
Status: RESOLVED DUPLICATE of bug 255935
Alias: None
Product: kpackagekit
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash
Target Milestone: ---
Assignee: Steven M. Parrish
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-10 18:49 UTC by cpark
Modified: 2011-01-31 01:06 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description cpark 2010-12-10 18:49:23 UTC
Application: kpackagekitsmarticon (0.6.2)
KDE Platform Version: 4.5.1 (KDE 4.5.1)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-23-generic-pae i686
Distribution: Ubuntu 10.10

-- Information about the crash:
- What I was doing when the application crashed:

Ran wireshark packet capture previous to downloading and also changed ethernet port from monitor destination to normal port (on cisco switch) in order to download more tools.

Just completed downloading rrdtool and started on MySQL Server download, returned to see crash report.

-- Backtrace:
Application: KPackageKit (kpackagekitsmarticon), signal: Segmentation fault
[Current thread is 1 (Thread 0xb518a710 (LWP 2276))]

Thread 2 (Thread 0xb0fceb70 (LWP 2482)):
#0  0xb5626e36 in clock_gettime () from /lib/librt.so.1
#1  0xb6dc550b in do_gettime () at tools/qelapsedtimer_unix.cpp:105
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:119
#3  0xb6e9c6e5 in QTimerInfoList::updateCurrentTime (this=0xb2300eb4) at kernel/qeventdispatcher_unix.cpp:339
#4  0xb6e9c72a in QTimerInfoList::timerWait (this=0xb2300eb4, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0xb6e9a7a8 in timerSourcePrepareHelper (src=<value optimized out>, timeout=0xb0fce0bc) at kernel/qeventdispatcher_glib.cpp:136
#6  0xb6e9a83d in timerSourcePrepare (source=0x0, timeout=0xb562aff4) at kernel/qeventdispatcher_glib.cpp:169
#7  0xb5593e6a in g_main_context_prepare () from /lib/libglib-2.0.so.0
#8  0xb5594279 in ?? () from /lib/libglib-2.0.so.0
#9  0xb5594848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#10 0xb6e9a59f in QEventDispatcherGlib::processEvents (this=0x9b7feb8, flags=...) at kernel/qeventdispatcher_glib.cpp:417
#11 0xb6e6a609 in QEventLoop::processEvents (this=0xb0fce290, flags=) at kernel/qeventloop.cpp:149
#12 0xb6e6aa8a in QEventLoop::exec (this=0xb0fce290, flags=...) at kernel/qeventloop.cpp:201
#13 0xb6d66b7e in QThread::exec (this=0x9bb2930) at thread/qthread.cpp:490
#14 0xb6e4935b in QInotifyFileSystemWatcherEngine::run (this=0x9bb2930) at io/qfilesystemwatcher_inotify.cpp:248
#15 0xb6d69df9 in QThreadPrivate::start (arg=0x9bb2930) at thread/qthread_unix.cpp:266
#16 0xb5dbdcc9 in start_thread () from /lib/libpthread.so.0
#17 0xb5bfd6be in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb518a710 (LWP 2276)):
[KCrash Handler]
#7  0xb62fe232 in QWidget::releaseShortcut (this=0x9a74498, id=-17) at kernel/qwidget.cpp:11043
#8  0xb6733910 in QLabelPrivate::clearContents (this=0x99a5770) at widgets/qlabel.cpp:1363
#9  0xb67344a8 in QLabel::~QLabel (this=0x9a74498, __in_chrg=<value optimized out>) at widgets/qlabel.cpp:262
#10 0xb6e7e816 in QObjectPrivate::deleteChildren (this=0x99b0258) at kernel/qobject.cpp:1957
#11 0xb63108fc in QWidget::~QWidget (this=0x9a70a90, __in_chrg=<value optimized out>) at kernel/qwidget.cpp:1589
#12 0xb6cfb1cd in ~DebconfElement (this=0x9a70a90, __in_chrg=<value optimized out>) at /build/buildd/libdebconf-kde-0.1~svn1167939/src/DebconfElement.h:26
#13 DebconfKde::DebconfPassword::~DebconfPassword (this=0x9a70a90, __in_chrg=<value optimized out>) at /build/buildd/libdebconf-kde-0.1~svn1167939/src/DebconfPassword.cpp:32
#14 0xb6e7e816 in QObjectPrivate::deleteChildren (this=0x9a71b90) at kernel/qobject.cpp:1957
#15 0xb630fcbc in QWidget::~QWidget (this=0x9997550, __in_chrg=<value optimized out>) at kernel/qwidget.cpp:1589
#16 0xb6e7e816 in QObjectPrivate::deleteChildren (this=0x99414a0) at kernel/qobject.cpp:1957
#17 0xb630fcbc in QWidget::~QWidget (this=0x9943160, __in_chrg=<value optimized out>) at kernel/qwidget.cpp:1589
#18 0xb6e7e816 in QObjectPrivate::deleteChildren (this=0x9942f18) at kernel/qobject.cpp:1957
#19 0xb63108fc in QWidget::~QWidget (this=0x9942d58, __in_chrg=<value optimized out>) at kernel/qwidget.cpp:1589
#20 0xb672ca61 in QFrame::~QFrame (this=0x9942d58, __in_chrg=<value optimized out>) at widgets/qframe.cpp:242
#21 0xb67cb854 in QAbstractScrollArea::~QAbstractScrollArea (this=0x9942d58, __in_chrg=<value optimized out>) at widgets/qabstractscrollarea.cpp:526
#22 0xb67d0095 in QScrollArea::~QScrollArea (this=0x9942d58, __in_chrg=<value optimized out>) at widgets/qscrollarea.cpp:176
#23 0xb6e7e816 in QObjectPrivate::deleteChildren (this=0x99382c0) at kernel/qobject.cpp:1957
#24 0xb63108fc in QWidget::~QWidget (this=0x993f398, __in_chrg=<value optimized out>) at kernel/qwidget.cpp:1589
#25 0xb6d013b5 in DebconfKde::DebconfGui::~DebconfGui (this=0x993f398, __in_chrg=<value optimized out>) at /build/buildd/libdebconf-kde-0.1~svn1167939/src/DebconfGui.h:62
#26 0x0805938c in _start ()

This bug may be a duplicate of or related to bug 255935.

Possible duplicates by query: bug 256821, bug 255935.

Reported using DrKonqi
Comment 1 Dario Andres 2010-12-12 19:22:58 UTC
[Comment from a bug triager]
This may be relate to the issue in bug 255935. Regards
Comment 2 Dario Andres 2011-01-31 01:06:21 UTC
[Comment from a bug triager]
This issue is now being tracked at bug 255935. Merging. Thanks

*** This bug has been marked as a duplicate of bug 255935 ***