Bug 311683 - apper crash after succesful install of new package
Summary: apper crash after succesful install of new package
Status: RESOLVED DUPLICATE of bug 255935
Alias: None
Product: apper
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Daniel Nicoletti
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-14 12:05 UTC by bosyber
Modified: 2012-12-14 12:10 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bosyber 2012-12-14 12:05:24 UTC
Application: apper-sentinel (0.7.1)
KDE Platform Version: 4.9.4
Qt Version: 4.8.2
Operating System: Linux 3.5.0-21-generic x86_64
Distribution: Ubuntu 12.04.1 LTS

-- Information about the crash:
- What I was doing when the application crashed:
Installing a new package, then pressing close, the crash happened after that.

Note that the report that this is possibly related to is marked closed with a much older version of KDE- since this is a much later version, either the bug wasn't fully solved, or it is another problem. Several of the duplicates do look very similar to this one.

-- Backtrace:
Application: Apper (apper-sentinel), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[KCrash Handler]
#6  QWidget::releaseShortcut (this=0x2504ef0, id=-10) at kernel/qwidget.cpp:11339
#7  0x00007f6c3a3c2883 in QLabelPrivate::clearContents (this=0x2504f20) at widgets/qlabel.cpp:1389
#8  0x00007f6c3a3c2b79 in QLabel::~QLabel (this=<optimized out>, __in_chrg=<optimized out>) at widgets/qlabel.cpp:277
#9  0x00007f6c3a3c2bb9 in QLabel::~QLabel (this=0x2504ef0, __in_chrg=<optimized out>) at widgets/qlabel.cpp:278
#10 0x00007f6c3b6f7e15 in QObjectPrivate::deleteChildren (this=0x2214100) at kernel/qobject.cpp:1908
#11 0x00007f6c39ff95b0 in QWidget::~QWidget (this=0x2201500, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1677
#12 0x00007f6c3b35c799 in DebconfKde::DebconfError::~DebconfError (this=0x2201500, __in_chrg=<optimized out>) at /build/buildd/debconf-kde-0.2/src/DebconfError.cpp:35
#13 0x00007f6c3b6f7e15 in QObjectPrivate::deleteChildren (this=0x25e9000) at kernel/qobject.cpp:1908
#14 0x00007f6c39ff95b0 in QWidget::~QWidget (this=0x22120e0, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1677
#15 0x00007f6c39ff9889 in QWidget::~QWidget (this=0x22120e0, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1701
#16 0x00007f6c3b6f7e15 in QObjectPrivate::deleteChildren (this=0x212dab0) at kernel/qobject.cpp:1908
#17 0x00007f6c39ff95b0 in QWidget::~QWidget (this=0x20e9dc0, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1677
#18 0x00007f6c39ff9889 in QWidget::~QWidget (this=0x20e9dc0, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1701
#19 0x00007f6c3b6f7e15 in QObjectPrivate::deleteChildren (this=0x212d800) at kernel/qobject.cpp:1908
#20 0x00007f6c39ff95b0 in QWidget::~QWidget (this=0x21d83b0, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1677
#21 0x00007f6c3a444569 in QScrollArea::~QScrollArea (this=0x21d83b0, __in_chrg=<optimized out>) at widgets/qscrollarea.cpp:176
#22 0x00007f6c3b6f7e15 in QObjectPrivate::deleteChildren (this=0x1f73bf0) at kernel/qobject.cpp:1908
#23 0x00007f6c39ff95b0 in QWidget::~QWidget (this=0x20f4620, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1677
#24 0x00007f6c3b361cb1 in ~DebconfGui (this=0x20f4620, __in_chrg=<optimized out>) at /build/buildd/debconf-kde-0.2/src/DebconfGui.h:88
#25 DebconfKde::DebconfGui::~DebconfGui (this=0x20f4620, __in_chrg=<optimized out>) at /build/buildd/debconf-kde-0.2/src/DebconfGui.h:88
#26 0x00000000004191e4 in DBusInterface::~DBusInterface (this=0x21c0df0, __in_chrg=<optimized out>) at /build/buildd/apper-0.7.1/Sentinel/DBusInterface.cpp:56
#27 0x0000000000419279 in DBusInterface::~DBusInterface (this=0x21c0df0, __in_chrg=<optimized out>) at /build/buildd/apper-0.7.1/Sentinel/DBusInterface.cpp:59
#28 0x00007f6c3b6f7e15 in QObjectPrivate::deleteChildren (this=0x1f5ff20) at kernel/qobject.cpp:1908
#29 0x00007f6c3b6fe07c in QObject::~QObject (this=0x7fff6bebb430, __in_chrg=<optimized out>) at kernel/qobject.cpp:927
#30 0x00007f6c39fb82be in QApplication::~QApplication (this=0x7fff6bebb430, __in_chrg=<optimized out>) at kernel/qapplication.cpp:1100
#31 0x000000000040f729 in main (argc=1, argv=0x7fff6bebb718) at /build/buildd/apper-0.7.1/Sentinel/main.cpp:54

This bug may be a duplicate of or related to bug 255935.

Possible duplicates by query: bug 294725, bug 292201, bug 289612, bug 289226.

Reported using DrKonqi
Comment 1 bosyber 2012-12-14 12:10:37 UTC
never mind, that's not true - I misread where the version of apper is given, the installed version is indeed newer than the version that has the fix for  those other bugs, so this is likely a duplicate.

*** This bug has been marked as a duplicate of bug 255935 ***