Bug 75254 - screensaver doesn't turn on
Summary: screensaver doesn't turn on
Status: RESOLVED FIXED
Alias: None
Product: kscreensaver
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: Slackware Linux
: NOR normal with 61 votes (vote)
Target Milestone: ---
Assignee: kscreensaver bugs tracking
URL:
Keywords:
: 76746 93045 102341 118873 122680 128610 129062 131967 136161 136891 137070 137591 140687 148758 152377 176824 (view as bug list)
Depends on:
Blocks:
 
Reported: 2004-02-15 00:53 UTC by Victor
Modified: 2009-01-04 17:13 UTC (History)
17 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Victor 2004-02-15 00:53:57 UTC
Version:            (using KDE KDE 3.2.0)
Installed from:    Slackware Packages

I was using Slack 9.1 with kde 3.2 I had trouble turning my screensaver on--I'd set it by right-clicking the desktop, then configure desktop, then screensaver, etc. When I hit "test," it worked, but in reality it wouldn't work no matter how I set it's priority setting. I switched to kde 3.1.4, and now it works perfectly even though I have not changed any (I underscore--any) of the settings.
Comment 1 Victor 2004-02-17 15:25:02 UTC
I actually got it to work eventually with kde 3.2.0 by setting it up from Ctl Ctr. I am wondering, is it there a bug such that right-clicking on the desktop and setting up the screen saver doesn't work, or in 3.2.0 it is not supposed to work at all unless it is set up from the control center?
Comment 2 Stephen Leaf 2005-03-15 19:56:25 UTC
I'm having problems with this as well. Test works great. but when I go idle for x many mins and the screen saver *should* turn on.. it doesn't. instead it just freezes the image. So if I'm just sitting here and it "turns on" I don't know this until I move the mouse or hit a key and the screen will update.
Comment 3 Stephen Leaf 2005-08-21 04:27:14 UTC
As an update to this I was able to get a few screen savers to actually work.
Blank Screen, Clock and Polygons.
Only way tho was I checked the "Make aware of power management"

The rest however just freeze the screen. (I want my swarms :'( RUN FOR IT LITTLE WHITE LINE!)
Comment 4 Chris Howells 2006-05-29 00:51:47 UTC
The Swarm screensaver is broken and indeed just appears to freeze the screen. Was the Swarm screensaver involved? If you chose another one does it work?

Thanks.
Comment 5 Oswald Buddenhagen 2007-04-12 14:41:58 UTC
irreproducible, other than bug 74663 (the one stephen observed).
Comment 6 Oswald Buddenhagen 2007-04-13 10:34:25 UTC
ok, there are quite some very similar reports. lats make this one the "master".

from where it is set is most certainly irrelevant. the other bugs indicate that it is sort of random.
Comment 7 Oswald Buddenhagen 2007-04-13 10:36:37 UTC
*** Bug 76746 has been marked as a duplicate of this bug. ***
Comment 8 Oswald Buddenhagen 2007-04-13 10:37:45 UTC
*** Bug 93045 has been marked as a duplicate of this bug. ***
Comment 9 Oswald Buddenhagen 2007-04-13 10:38:56 UTC
*** Bug 102341 has been marked as a duplicate of this bug. ***
Comment 10 Oswald Buddenhagen 2007-05-17 14:47:59 UTC
*** Bug 118873 has been marked as a duplicate of this bug. ***
Comment 11 Oswald Buddenhagen 2007-05-18 21:34:40 UTC
*** Bug 122680 has been marked as a duplicate of this bug. ***
Comment 12 Oswald Buddenhagen 2007-05-18 21:35:50 UTC
*** Bug 128610 has been marked as a duplicate of this bug. ***
Comment 13 Oswald Buddenhagen 2007-05-18 21:37:41 UTC
*** Bug 129062 has been marked as a duplicate of this bug. ***
Comment 14 Oswald Buddenhagen 2007-05-18 21:39:12 UTC
*** Bug 131967 has been marked as a duplicate of this bug. ***
Comment 15 Oswald Buddenhagen 2007-05-18 21:48:57 UTC
*** Bug 136161 has been marked as a duplicate of this bug. ***
Comment 16 Oswald Buddenhagen 2007-05-18 21:54:05 UTC
*** Bug 136891 has been marked as a duplicate of this bug. ***
Comment 17 Oswald Buddenhagen 2007-05-18 21:55:22 UTC
*** Bug 137070 has been marked as a duplicate of this bug. ***
Comment 18 Oswald Buddenhagen 2007-05-18 21:58:00 UTC
*** Bug 140687 has been marked as a duplicate of this bug. ***
Comment 19 Oswald Buddenhagen 2007-05-18 22:00:02 UTC
*** Bug 76008 has been marked as a duplicate of this bug. ***
Comment 20 Oswald Buddenhagen 2007-05-18 22:03:41 UTC
*** Bug 137591 has been marked as a duplicate of this bug. ***
Comment 21 Oswald Buddenhagen 2007-05-18 22:13:41 UTC
this is by far the most reported kscreensaver issue - some of the duplicates have in turn duplicates ...

bug #128610 documents a failed attempt to fix it.
bug #136315 has some good analysis and a patch.
Comment 22 Daniel Hahler 2007-05-19 22:10:14 UTC
I've reported bug #136315: it has a patch and should at least fix some of the dupes. But probably not all or even most of them:
There does not seem to be a single bug only here.
Comment 23 Lubos Lunak 2007-09-26 15:51:43 UTC
I don't think it was a good idea to merge all "very similar" reports to this one. I'm pretty sure at least some of those have been fixed meanwhile, but with the mess this bugreport is right now it's hard to tell what still needs fixing. I'd suggest to close this one (no response from reporter anyway) and whoever still has some problem with 3.5.7 should file reopen their duplicate or file a new one.

Comment 24 Oswald Buddenhagen 2007-10-31 16:20:20 UTC
i *think* i fixed this now ...
Comment 25 Martin Tsachev 2007-10-31 16:25:13 UTC
What does now refer to? I want to upgrade to a version which includes the fix. I'm using kde-base/kscreensaver-3.5.7 on gentoo atm.
Comment 26 Oswald Buddenhagen 2007-11-01 21:27:34 UTC
*** Bug 148758 has been marked as a duplicate of this bug. ***
Comment 27 Oswald Buddenhagen 2007-11-15 20:04:22 UTC
*** Bug 152377 has been marked as a duplicate of this bug. ***
Comment 28 Oswald Buddenhagen 2009-01-04 17:13:22 UTC
*** Bug 176824 has been marked as a duplicate of this bug. ***