Bug 39097 - Better handling for error messages and dialogs
Summary: Better handling for error messages and dialogs
Status: RESOLVED FIXED
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: 1.3.99
Platform: Compiled Sources Linux
: NOR wishlist with 215 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 26281 40210 43145 51439 59748 82829 89555 100151 103927 104634 115559 123809 123899 138197 142718 144731 149696 149819 149923 151689 161882 186223 187585 (view as bug list)
Depends on:
Blocks:
 
Reported: 2002-03-08 08:48 UTC by Unknown
Modified: 2009-12-18 01:17 UTC (History)
28 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description dexxter 2002-03-08 08:34:37 UTC
(*** This bug was imported into bugs.kde.org ***)

Package:           kmail
Version:           1.3.99 (using KDE 2.9.0 7 (3.0 rc1))
Severity:          wishlist
Installed from:    compiled sources
Compiler:          gcc version 2.95.4 (Debian prerelease)
OS:                Linux (i686) release 2.4.17
OS/Compiler notes: 

the user should be able to disable the error-popups (like mailbox doesn exist).

i receive them quite a lot even tough the mbox actually exists (imap).

more detailed:
no popup for 2 hours then every 2 minutes a popup then again nothing for n time ...

(Submitted via bugs.kde.org)
(Called from KBugReport dialog)
Comment 1 Stephan Kulow 2004-05-25 08:51:36 UTC
Replaced dexxter@nothing.ch with null@kde.org due to bounces by reporter
Comment 2 Michael Jahn 2004-07-25 11:47:15 UTC
Related: bug 26281, bug 39097, bug 40210.
Comment 3 Carsten Burghardt 2005-02-24 11:13:44 UTC
*** Bug 26281 has been marked as a duplicate of this bug. ***
Comment 4 Carsten Burghardt 2005-02-24 11:14:30 UTC
*** Bug 89555 has been marked as a duplicate of this bug. ***
Comment 5 Carsten Burghardt 2005-02-24 11:15:14 UTC
*** Bug 82829 has been marked as a duplicate of this bug. ***
Comment 6 Carsten Burghardt 2005-02-24 11:15:55 UTC
*** Bug 51439 has been marked as a duplicate of this bug. ***
Comment 7 Carsten Burghardt 2005-02-24 11:16:38 UTC
*** Bug 100151 has been marked as a duplicate of this bug. ***
Comment 8 Modestas Vainius 2006-02-23 23:52:07 UTC
*** This bug has been confirmed by popular vote. ***
Comment 9 Modestas Vainius 2006-02-24 00:23:29 UTC
I have 6 mailboxes and it is really very annoying when my network connection goes down (or I disconnect intentionally) and, once kmail checks for the mail automatically, 6 (!) error message boxes opened up stating it couldn't find the host. To make matters worse, it's really a challenge to close them. They are all modal, so they must be closed in the order they popped up. However, usually the focused one won't close, because it is not the right one. I have to continually switch with ALT+TAB to find the right message box to close. Sometimes this takes even over a minute. This is a huge usability problem.

As evident by my experience, message boxes ARE NOT the correct way to announce errors for the mail program (especially for the automatic actions). I always run kmail in the background, so I don't care if a few automatic operations fail. In such case, the errors should be reported passively (eg. in the error log at the bottom of the window or smth) but not actively (like it is now: popping up a message box (and even multiple ones) and drawing my attention). Please solve this problem. At least prevent multiple message boxes from opening up.
Comment 10 Ismail Onur Filiz 2006-02-24 01:42:53 UTC
Actually I feel like it could be achieved by changing the error notification to use KNotify instead. Shouldn't be that difficult to do, since there already is the "new mail" notification which uses KNotify.
Comment 11 Martin Krischik 2006-11-04 13:31:13 UTC
Is #40210 even one more duplicate of this bug - with another 20 votes for it?
Comment 12 Darius Žitkevičius 2006-11-14 08:35:20 UTC
I think, that best way to fix it is option to disable specified error messages.
Comment 13 Thomas McGuire 2007-03-09 13:52:22 UTC
*** Bug 104634 has been marked as a duplicate of this bug. ***
Comment 14 Thomas McGuire 2007-03-09 13:53:48 UTC
*** Bug 40210 has been marked as a duplicate of this bug. ***
Comment 15 Thomas McGuire 2007-03-09 13:56:43 UTC
*** Bug 142718 has been marked as a duplicate of this bug. ***
Comment 16 Dragan Espenschied 2007-03-09 14:54:38 UTC
Additonally, i suggest to move the "pinentry" from gpgagent into the area of the main window where the message should be displayed.

Instead of popping up a new modal dialog or displaying that the message decryption was unsuccessful, kmail should present me right there a way to enter my passphrase.

This would be awesome for flipping through a lot of messages where only some are encrypted, or when the mail client starts and remembers that the last message it displayed was an encrypted one.
Comment 17 Thomas McGuire 2007-03-28 16:35:04 UTC
*** Bug 115559 has been marked as a duplicate of this bug. ***
Comment 18 Thomas McGuire 2007-04-19 15:41:17 UTC
*** Bug 138197 has been marked as a duplicate of this bug. ***
Comment 19 Thomas McGuire 2007-04-19 15:43:48 UTC
*** Bug 103927 has been marked as a duplicate of this bug. ***
Comment 20 Thomas McGuire 2007-04-29 19:30:23 UTC
*** Bug 144731 has been marked as a duplicate of this bug. ***
Comment 21 Thomas McGuire 2007-06-25 13:00:26 UTC
*** Bug 43145 has been marked as a duplicate of this bug. ***
Comment 22 Thomas McGuire 2007-08-08 01:56:19 UTC
*** Bug 123899 has been marked as a duplicate of this bug. ***
Comment 23 Sergey Y. Afonin 2007-08-08 08:51:10 UTC
> I think, that best way to fix it is option to disable specified error messages. 

No, best way the common logging subsystem for KDE I think. 
For example, in ~/.kde/logs/<application name> with assignable  maximum log file size and/or time of life of messages for every log files.
Comment 24 Maciej Pilichowski 2007-08-08 15:41:30 UTC
Sergey, it would be a nice feature but it does not solve the issue reported here. Besides where to store logs is a transparent thing for UI behaviour.

Getting back to showing errors -- I opt for:
* manual check -- summarized error dialog box, i.e. one error -- one error dialog box, six errors -- one error dialog box (with six errors)
* auto check -- no error dialog boxes, errors should be logged and shown on demand, however status should be always shown (probably in the status bar): something like this "120 errors occurred on 160 attempts to download mail", when the user clicks on the status full log should be shown, datetime, activity, result, with ability to sort, filter out, etc.
Comment 25 Thomas McGuire 2007-09-14 18:23:25 UTC
*** Bug 149819 has been marked as a duplicate of this bug. ***
Comment 26 Thomas McGuire 2007-09-20 19:30:53 UTC
*** Bug 149923 has been marked as a duplicate of this bug. ***
Comment 27 Thomas McGuire 2007-09-20 20:25:14 UTC
*** Bug 149696 has been marked as a duplicate of this bug. ***
Comment 28 Tommi Tervo 2007-11-01 13:49:39 UTC
*** Bug 151689 has been marked as a duplicate of this bug. ***
Comment 29 Thomas McGuire 2008-05-16 19:32:15 UTC
*** Bug 161882 has been marked as a duplicate of this bug. ***
Comment 30 Jack David Baucum 2009-01-28 02:37:31 UTC
This bug has been annoying me too.  I had KMail setup on my laptop, but when my laptop is not online I got annoyed by being inundated with pop-ups informing me what I already know.  KMail should use dbus to find out if it is online or offline and automatically set itself in online or offline mode accordingly.  When it is online and the mail server is not reachable, KMail should fail more gracefully than interrupt the users entire desktop experience for something that is unlikely to be more important than what he or she is currently doing.
Comment 31 Peter Nixon 2009-01-28 12:21:12 UTC
I have been monitoring this bug for a while now, and I don't see any activity from developers. I would like to mention that I have been using kmail since 2001, (When I migrated from Eudora Pro, via a short stay in sylpheed land) and after 7 years as a kmail user, this single bug has become annoying enough (I have 12 mail accounts which means 12 popups.. Often in the wrong order) that I am seriously considering spending the weekend migrating my mail (and more importantly my several hundred filters) to another mail client. PLEASE make kmail take notice of dbus network status, and make these errors non interactive (Using knotify or some other method).
Comment 32 Stefan Zosel 2009-01-28 16:47:44 UTC
I fully agree to Peter. I have only "5" Mailboxes ... and i got one popup after another. 
It's the same if i like to create new mails offline. Kmail is poping up again and again with the message, that the transport was failed.

It's ok to have a red blinking icon in my system tray for that - but i hate this messageboxes. 

Pleeeeeaaaaaaaaaase solve that.
Comment 33 Toralf Förster 2009-02-01 11:53:19 UTC
In addition after suspend to ram/disc KMail wouldn't try to pull new mails before the DSL connection is re-established.
Comment 34 Thomas McGuire 2009-03-18 23:53:15 UTC
*** Bug 186223 has been marked as a duplicate of this bug. ***
Comment 35 Thomas McGuire 2009-03-19 16:31:56 UTC
*** Bug 187585 has been marked as a duplicate of this bug. ***
Comment 36 Thomas McGuire 2009-07-08 00:57:54 UTC
SVN commit 992911 by tmcguire:

By default, use passive popups when you get an error when checking mail.
You can configure this in the notification dialog.

BUG: 39097


 M  +10 -3     imapaccountbase.cpp  
 M  +5 -0      kmail.notifyrc  
 M  +8 -1      popaccount.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=992911
Comment 37 Ritesh Raj Sarraf 2009-07-08 04:58:40 UTC
(In reply to comment #36)
> SVN commit 992911 by tmcguire:
> 
> By default, use passive popups when you get an error when checking mail.
> You can configure this in the notification dialog.
> 
> BUG: 39097
> 
> 
>  M  +10 -3     imapaccountbase.cpp  
>  M  +5 -0      kmail.notifyrc  
>  M  +8 -1      popaccount.cpp  
> 
> 
> WebSVN link: http://websvn.kde.org/?view=rev&revision=992911

Thank you ** 100
Comment 38 Martin Koller 2009-08-05 20:54:14 UTC
*** Bug 123809 has been marked as a duplicate of this bug. ***
Comment 39 Björn Ruberg 2009-12-18 01:17:34 UTC
*** Bug 59748 has been marked as a duplicate of this bug. ***