Bug 149696 - cannot close dialog boxes
Summary: cannot close dialog boxes
Status: RESOLVED DUPLICATE of bug 39097
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: 1.2.3
Platform: Debian stable Linux
: NOR normal with 1 vote (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-09-09 12:37 UTC by Gábor Nagy
Modified: 2007-09-20 20:25 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gábor Nagy 2007-09-09 12:37:49 UTC
Version:           1.2.3 (using KDE KDE 3.5.5)
Installed from:    Debian stable Packages

When I start contact and my laptop is not connected to the internet, the mail check fails.
I have some 13 receiving mail accounts (POP3, IMAP) set up.
For each receiving account an error notification dialog box opens.

The problem is that I cannot close the dialog boxes in the order I want (in the order they are on the desktop). I have to close them in the right order: Error - Kontact <13> first, then Error - Kontact <12>, then 11, then 10.

If by chance number 11 is below number 10, 9, 8, 7, and 6 (this sort of thing happens), I cannot close #10, even though it has the focus.

So what happens: I have a dialog box, it has the focus, I click OK, and nothing happens.

The first time it took me quite a while to figure out that I have to close another, currently covered dialog box first to be able to close this one.

I think this is bad. The boxes should not depend on each other. Probably they are modal, and they should not be. 

I would like to be able to close them in any order, or leave them open, and still be able to continue using kmail.

And anyway, if I have no connection, and I am to be notified, one dialog box is enough, the other 12 is useless.

Another related scenario:
I read my mails, I write a reply, and I am not connected to the internet. Some minutes later kontact tries to check my mails again. Still no connection, so I get some error boxes again.
First of all: I think there is no need for those boxes. I know that I don't have a connection, so there's no need to tell me every 3 minutes.
Second, I am in the middle of doing something, and these error boxes have to be closed (in order) to be able to continue. I would like to just bring the composer front again, and finish the sentence I was in.
Third, it would be great if kmail could check if I have a connection or not before trying to access remote mail servers.
Also it would be great for kmail to be notified when a connection becomes available, and then it would try to download everything.

Cheers,
Gabor
Comment 1 Maciej Pilichowski 2007-09-10 18:01:29 UTC
And fourth -- please, post one issue per one report. 

The main report is a duplicate:
https://bugs.kde.org/show_bug.cgi?id=39097
Comment 2 Thomas McGuire 2007-09-20 20:25:12 UTC
Closing this as a duplicate of bug 39097, which is sort of a catch-all bug report for the current problems with the error dialogs.

*** This bug has been marked as a duplicate of 39097 ***