Bug 142718 - Modal dialogs appearing without user interaction blocking main window
Summary: Modal dialogs appearing without user interaction blocking main window
Status: RESOLVED DUPLICATE of bug 39097
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: 1.9.6
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-03-09 10:06 UTC by Dragan Espenschied
Modified: 2007-03-09 13:56 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dragan Espenschied 2007-03-09 10:06:39 UTC
Version:           1.9.6 (using KDE 3.5.6, Kubuntu (edgy) 4:3.5.6-0ubuntu1~edgy1)
Compiler:          Target: i486-linux-gnu
OS:                Linux (i686) release 2.6.17-11-generic

I frequently experience several modal dialogs in Kmail that are sometimes difficult to spot.

The first one is when i am asked to enter my GPG passphrase, i believe this is handled by an external program called "Aegypten"? When this "pinentry" window appears after i selected the function to send my message, the main window and the composer window do not redraw their content. It means that i can draw with other windows on them. This sometimes leads to puzzling situations where i think that the app crashed while in fact this pinentry is somewhere on screen but below the main window.

Also, when checking mail automatically in an interval, it can happen that a mail account can not be reached or another error occurs that pops up a modal dialog. This dialog also can go unnoticed and be somewhere in the background while i try to handle the main window that does not respond. This is *very* puzzling!

There are many things going on in the background of this app that are not started by user interaction. And they all can pop up modal dialogs and freeze the main window.

This happens with some KDE apps, but with mail i encounter it most. I would suggest to remove modal dialogs from as many programs as possible. One solution would be to stick modal dialogs to the window they belong to, à la OSX. I mean, that would still not be optimal, but a first step. 

Amarok solved the problem quite well by showing in the status bar what processes are running currently in the background and what's their status, without interrupting or freezing the main program.

I think this would be a desirable solution and would increase the usablity and friendliness of KDE very much.

There is a similar bug in the glorious Acrobat reader for MS Windows (and actually hundreds of Windows apps), described here:
http://www.asktog.com/Bughouse/bhApplications.html#Anchor-Adobe-47857

In general a nice resource for looking up what is annoying.

Best greetings to de Kmail team!
Comment 1 Thomas McGuire 2007-03-09 13:56:42 UTC
Both cases of modal dialogs are already reported (bug #63792 and bug #39097).
Closing as a duplicate of the last one.

*** This bug has been marked as a duplicate of 39097 ***