Bug 255081 - kde4-window-decorator --replace
Summary: kde4-window-decorator --replace
Status: RESOLVED DOWNSTREAM
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash with 20 votes (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
: 269671 270373 277044 285664 288669 289825 291079 291175 291235 292398 294033 294100 294229 295018 303108 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-10-24 03:46 UTC by sinozzuke
Modified: 2012-08-20 14:59 UTC (History)
23 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (4.78 KB, text/plain)
2010-11-20 04:38 UTC, nironaCuChANOck
Details
New crash information added by DrKonqi (3.15 KB, text/plain)
2011-12-31 05:59 UTC, KitchM
Details
New crash information added by DrKonqi (2.94 KB, text/plain)
2012-04-12 02:55 UTC, Yuri
Details
New crash information added by DrKonqi (2.97 KB, text/plain)
2012-04-16 20:02 UTC, John
Details
New crash information added by DrKonqi (2.97 KB, text/plain)
2012-04-18 18:35 UTC, John
Details
New crash information added by DrKonqi (2.67 KB, text/plain)
2012-08-20 14:55 UTC, Leonardo
Details
New crash information added by DrKonqi (4.40 KB, text/plain)
2012-08-20 14:59 UTC, Leonardo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sinozzuke 2010-10-24 03:46:12 UTC
Application: kde4-window-decorator (0.0.1)
KDE Platform Version: 4.5.2 (KDE 4.5.2)
Qt Version: 4.7.0
Operating System: Linux 2.6.34.7-0.4-desktop x86_64
Distribution: "openSUSE 11.3 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:
> kde4-window-decorator --replace

X Error: BadWindow (invalid Window parameter) 3
Major opcode: 20 (X_GetProperty)
Resource id:  0x8200010

- Unusual behavior I noticed:

-- Backtrace:
Application: KDE Window Decorator (kde4-window-decorator), signal: Segmentation fault
[KCrash Handler]
#6  0x00007ff21b8c4ee9 in QRasterWindowSurface::~QRasterWindowSurface (this=0x83df10, __in_chrg=<value optimized out>) at painting/qwindowsurface_raster.cpp:104
#7  0x00007ff21b8c4f69 in QRasterWindowSurface::~QRasterWindowSurface (this=0x83df10, __in_chrg=<value optimized out>) at painting/qwindowsurface_raster.cpp:108
#8  0x00007ff21b8e2b52 in QWidgetBackingStore::~QWidgetBackingStore (this=0x84b220, __in_chrg=<value optimized out>) at painting/qbackingstore.cpp:883
#9  0x00007ff21b71f219 in QWidgetBackingStoreTracker::destroy (this=0x84b4e0) at kernel/qwidget.cpp:205
#10 0x00007ff21b71f369 in QWidgetPrivate::deleteExtra (this=0x7b1260) at kernel/qwidget.cpp:1739
#11 0x00007ff21b71f5ac in QWidgetPrivate::~QWidgetPrivate (this=0x7b1260, __in_chrg=<value optimized out>) at kernel/qwidget.cpp:318
#12 0x00007ff21b71f8c9 in QWidgetPrivate::~QWidgetPrivate (this=0x7b1260, __in_chrg=<value optimized out>) at kernel/qwidget.cpp:323
#13 0x00007ff21c328c33 in cleanup (this=0x789160, __in_chrg=<value optimized out>) at ../../src/corelib/tools/qscopedpointer.h:62
#14 ~QScopedPointer (this=0x789160, __in_chrg=<value optimized out>) at ../../src/corelib/tools/qscopedpointer.h:100
#15 QObject::~QObject (this=0x789160, __in_chrg=<value optimized out>) at kernel/qobject.cpp:817
#16 0x00007ff21b72197d in QWidget::~QWidget (this=0x789160, __in_chrg=<value optimized out>) at kernel/qwidget.cpp:1466
#17 0x00007ff21d2ecc21 in ~Private (this=0x789160, __in_chrg=<value optimized out>) at /usr/src/debug/kdelibs-4.5.2/kdeui/util/kmanagerselection.cpp:376
#18 KSelectionWatcher::Private::~Private (this=0x789160, __in_chrg=<value optimized out>) at /usr/src/debug/kdelibs-4.5.2/kdeui/util/kmanagerselection.cpp:376
#19 0x00007ff21d118d81 in KSelectionWatcher::~KSelectionWatcher (this=0x718c50, __in_chrg=<value optimized out>) at /usr/src/debug/kdelibs-4.5.2/kdeui/util/kmanagerselection.cpp:419
#20 0x00007ff21d118d99 in KSelectionWatcher::~KSelectionWatcher (this=0x718c50, __in_chrg=<value optimized out>) at /usr/src/debug/kdelibs-4.5.2/kdeui/util/kmanagerselection.cpp:420
#21 0x00007ff21c323f34 in QObjectPrivate::deleteChildren (this=0x78e360) at kernel/qobject.cpp:1949
#22 0x00007ff21c328be2 in QObject::~QObject (this=0x7ab800, __in_chrg=<value optimized out>) at kernel/qobject.cpp:945
#23 0x00007ff21cc987d8 in Plasma::Theme::~Theme (this=0x7ab800, __in_chrg=<value optimized out>) at /usr/src/debug/kdelibs-4.5.2/plasma/theme.cpp:389
#24 0x00007ff21cc9a2b7 in ~ThemeSingleton () at /usr/src/debug/kdelibs-4.5.2/plasma/theme.cpp:341
#25 destroy () at /usr/src/debug/kdelibs-4.5.2/plasma/theme.cpp:356
#26 0x00007ff21aed94e1 in __run_exit_handlers () from /lib64/libc.so.6
#27 0x00007ff21aed9535 in exit () from /lib64/libc.so.6
#28 0x00007ff21aec2b84 in __libc_start_main () from /lib64/libc.so.6
#29 0x0000000000409dd9 in _start ()

Reported using DrKonqi
Comment 1 Christoph Feck 2010-11-12 03:38:41 UTC
The KDE Window Decorator is developed as a part of the Compiz window manager. Please report this bug to the Compiz developers. For more information, see http://wiki.compiz.org/HowtoSubmitBugReports
Comment 2 nironaCuChANOck 2010-11-20 04:38:14 UTC
Created attachment 53569 [details]
New crash information added by DrKonqi

kde4-window-decorator (0.0.1) on KDE Platform 4.5.3 (KDE 4.5.3) using Qt 4.7.1

- What I was doing when the application crashed:

- Unusual behavior I noticed:

- Custom settings of the application:

konsole text:

 Major opcode: 2 (X_ChangeWindowAttributes)
  Resource id:  0x4a004b6
X Error: BadWindow (invalid Window parameter) 3
  Major opcode: 2 (X_ChangeWindowAttributes)
  Resource id:  0x4a004b8
X Error: BadWindow (invalid Window parameter) 3
  Major opcode: 2 (X_ChangeWindowAttributes)
  Resource id:  0x4a004b8
X Error: BadWindow (invalid Window parameter) 3
  Major opcode: 2 (X_ChangeWindowAttributes)
  Resource id:  0x4a004ba
X Error: BadWindow (invalid Window parameter) 3
  Major opcode: 2 (X_ChangeWindowAttributes)
  Resource id:  0x4a004ba
X Error: BadWindow (invalid Window parameter) 3
  Major opcode: 40 (X_TranslateCoords)
  Resource id:  0x4a00490
X Error: BadWindow (invalid Window parameter) 3
  Major opcode: 40 (X_TranslateCoords)
  Resource id:  0x4a004ba
X Error: BadWindow (invalid Window parameter) 3
  Major opcode: 40 (X_TranslateCoords)
  Resource id:  0x4a004ba
X Error: BadWindow (invalid Window parameter) 3
  Major opcode: 2 (X_ChangeWindowAttributes)
  Resource id:  0x4a00490
X Error: BadWindow (invalid Window parameter) 3
  Major opcode: 2 (X_ChangeWindowAttributes)
  Resource id:  0x4a00490
X Error: BadWindow (invalid Window parameter) 3
  Major opcode: 2 (X_ChangeWindowAttributes)
  Resource id:  0x4a004b2
X Error: BadWindow (invalid Window parameter) 3
  Major opcode: 2 (X_ChangeWindowAttributes)
  Resource id:  0x4a004b2
X Error: BadWindow (invalid Window parameter) 3
  Major opcode: 2 (X_ChangeWindowAttributes)
  Resource id:  0x4a004b4
X Error: BadWindow (invalid Window parameter) 3
  Major opcode: 2 (X_ChangeWindowAttributes)
  Resource id:  0x4a004b4
X Error: BadWindow (invalid Window parameter) 3
  Major opcode: 2 (X_ChangeWindowAttributes)
  Resource id:  0x4a004b6
X Error: BadWindow (invalid Window parameter) 3
  Major opcode: 2 (X_ChangeWindowAttributes)
  Resource id:  0x4a004b6
X Error: BadWindow (invalid Window parameter) 3
  Major opcode: 2 (X_ChangeWindowAttributes)
  Resource id:  0x4a004b8
X Error: BadWindow (invalid Window parameter) 3
  Major opcode: 2 (X_ChangeWindowAttributes)
  Resource id:  0x4a004b8

-- Backtrace (Reduced):
#6  0x00007ff747aef3b9 in QRasterWindowSurface::~QRasterWindowSurface (this=0x166ca10, __in_chrg=<value optimized out>) at painting/qwindowsurface_raster.cpp:104
#7  0x00007ff747aef439 in QRasterWindowSurface::~QRasterWindowSurface (this=0x166ca10, __in_chrg=<value optimized out>) at painting/qwindowsurface_raster.cpp:108
#8  0x00007ff747b09982 in QWidgetBackingStore::~QWidgetBackingStore (this=0x164c4c0, __in_chrg=<value optimized out>) at painting/qbackingstore.cpp:883
#9  0x00007ff747946579 in QWidgetBackingStoreTracker::destroy (this=0x16626c0) at kernel/qwidget.cpp:205
#10 0x00007ff7479466c9 in QWidgetPrivate::deleteExtra (this=0x15e70e0) at kernel/qwidget.cpp:1750
Comment 3 Christoph Feck 2011-03-30 21:04:04 UTC
*** Bug 269671 has been marked as a duplicate of this bug. ***
Comment 4 Christoph Feck 2011-07-04 22:01:38 UTC
*** Bug 277044 has been marked as a duplicate of this bug. ***
Comment 5 Beat Wolf 2011-10-14 08:28:12 UTC
*** Bug 270373 has been marked as a duplicate of this bug. ***
Comment 6 Phil Evans 2011-11-03 19:27:49 UTC
To clarify: is this really a compiz issue? I am not using compiz, but every time I log out of KDE, kwin crashes. It seems odd to me that this should be a compiz issue, not a KDE one.
Comment 7 Christoph Feck 2011-11-03 20:31:05 UTC
Phil, please add the backtrace for the KWin crash. If you are using Qt 4.8.0, this might be a duplicate of bug 282933 (which recently got fixed).
Comment 8 Christoph Feck 2011-11-03 22:18:38 UTC
*** Bug 285664 has been marked as a duplicate of this bug. ***
Comment 9 Phil Evans 2011-11-04 08:10:58 UTC
Sure -- I'll let KDE create a bug report itself and append it here, as I guess that's the easiest way...
Comment 10 Phil Evans 2011-11-04 08:24:25 UTC
Hmm, now the crash has stopped! I uninstalled compiz first (since I was not using it), so maybe that was it. Although now instead when I log in to KDE, it frequently stops part way through the session startup and drops me back to the kdm login screen(!). I reinstaled compiz, but no change - it still sometimes crashes on login -- but with no crash handler so I don't have a backtrace --, but no longer on logout!
Comment 11 Christoph Feck 2011-12-10 17:44:27 UTC
*** Bug 288669 has been marked as a duplicate of this bug. ***
Comment 12 Christoph Feck 2011-12-26 11:53:12 UTC
*** Bug 289825 has been marked as a duplicate of this bug. ***
Comment 13 KitchM 2011-12-31 05:59:23 UTC
Created attachment 67272 [details]
New crash information added by DrKonqi

kde4-window-decorator (0.0.1) on KDE Platform 4.7.4 (4.7.4) using Qt 4.8.0

- What I was doing when the application crashed:

I was shutting down computer and this popped up.

-- Backtrace (Reduced):
#6  0x000000328f9c3d89 in QRasterWindowSurface::~QRasterWindowSurface (this=0xa60ef0, __in_chrg=<optimized out>) at painting/qwindowsurface_raster.cpp:117
#7  0x000000328f9c3e09 in QRasterWindowSurface::~QRasterWindowSurface (this=0xa60ef0, __in_chrg=<optimized out>) at painting/qwindowsurface_raster.cpp:121
#8  0x000000328f9dfd7e in QWidgetBackingStore::~QWidgetBackingStore (this=0xb3f820, __in_chrg=<optimized out>) at painting/qbackingstore.cpp:909
#9  0x000000328f812089 in QWidgetBackingStoreTracker::destroy (this=0xb4b490) at kernel/qwidget.cpp:217
#10 0x000000328f8121de in QWidgetPrivate::deleteExtra (this=0xa76bd0) at kernel/qwidget.cpp:1829
Comment 14 Andrew 2012-01-02 11:01:26 UTC
Got something similar. KDE 4.7.4, Qt 4.8, fedora 16 x64.
Happens after launch /usr/bin/compiz-manager (reproducible):

$ /usr/bin/compiz-manager 
xset q doesn't reveal the location of the log file. Using fallback /var/log/Xorg.0.log 
Detected PCI ID for VGA: 01:00.0 0300: 10de:0141 (rev a2) (prog-if 00 [VGA controller])
Checking for texture_from_pixmap: present. 
Checking for non power of two support: present. 
Checking for Composite extension: present. 
Comparing resolution (1280x1024) to maximum 3D texture size (4096): Passed.
Checking for nVidia: not present. 
Checking for FBConfig: present. 
Starting kde4-window-decorator
KCrash: Application 'kde4-window-decorator' crashing...
KCrash: Attempting to start /usr/libexec/kde4/drkonqi from kdeinit
sock_file=/home/test/.kde/socket-localhost.localdomain/kdeinit4__0
Backend     : kconfig4
Integration : true
Profile     : default
Adding plugins
Initializing core options...done
Initializing composite options...done
Initializing crashhandler options...done
Initializing opengl options...done
/usr/bin/compiz (decor) - Warn: failed to bind pixmap to texture
/usr/bin/compiz (decor) - Warn: failed to bind pixmap to texture
Initializing decor options...done
Initializing kdecompat options...done
Initializing resize options...done
Initializing snap options...done
Initializing move options...done
Initializing scale options...done
Initializing resizeinfo options...done
Initializing place options...done
Initializing staticswitcher options...done
Initializing workarounds options...done
Initializing notification options...done
Initializing gnomecompat options...done
Initializing mousepoll options...done
Initializing vpswitch options...done
Initializing session options...done
Initializing wall options...done

glibmm-ERROR **: 
unhandled exception (type std::exception) in signal handler:
what: call to empty boost::function

/usr/bin/compiz-manager: line 367:  7145 Trace/breakpoint trap   ${COMPIZ_BIN_PATH}${COMPIZ_NAME} $COMPIZ_OPTIONS "$@" $COMPIZ_PLUGINS
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.



# auto backtrace:

Application: KDE Window Decorator (kde4-window-decorator), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[KCrash Handler]
#6  0x0000003af73c3d89 in QRasterWindowSurface::~QRasterWindowSurface() () from /usr/lib64/libQtGui.so.4
#7  0x0000003af73c3e09 in QRasterWindowSurface::~QRasterWindowSurface() () from /usr/lib64/libQtGui.so.4
#8  0x0000003af73dfd7e in ?? () from /usr/lib64/libQtGui.so.4
#9  0x0000003af7212089 in ?? () from /usr/lib64/libQtGui.so.4
#10 0x0000003af72121de in QWidgetPrivate::deleteExtra() () from /usr/lib64/libQtGui.so.4
#11 0x0000003af721240c in QWidgetPrivate::~QWidgetPrivate() () from /usr/lib64/libQtGui.so.4
#12 0x0000003af7212729 in QWidgetPrivate::~QWidgetPrivate() () from /usr/lib64/libQtGui.so.4
#13 0x0000003af4d912b0 in QObject::~QObject() () from /usr/lib64/libQtCore.so.4
#14 0x0000003af721446d in QWidget::~QWidget() () from /usr/lib64/libQtGui.so.4
#15 0x0000003b0c57bdff in ?? () from /usr/lib64/libplasma.so.3
#16 0x0000003b0c5e043f in Plasma::Theme::~Theme() () from /usr/lib64/libplasma.so.3
#17 0x0000003b0c5e0967 in ?? () from /usr/lib64/libplasma.so.3
#18 0x0000003ae9c39931 in __run_exit_handlers () from /lib64/libc.so.6
#19 0x0000003ae9c399b5 in exit () from /lib64/libc.so.6
#20 0x0000003ae9c216a4 in __libc_start_main () from /lib64/libc.so.6
#21 0x000000000040a08d in _start ()
Comment 15 Christoph Feck 2012-01-09 21:13:13 UTC
*** Bug 291079 has been marked as a duplicate of this bug. ***
Comment 16 Christoph Feck 2012-01-10 15:54:59 UTC
*** Bug 291175 has been marked as a duplicate of this bug. ***
Comment 17 Christoph Feck 2012-01-11 01:49:23 UTC
*** Bug 291235 has been marked as a duplicate of this bug. ***
Comment 18 Dario Andres 2012-01-25 22:54:15 UTC
*** Bug 292398 has been marked as a duplicate of this bug. ***
Comment 19 Jekyll Wu 2012-02-14 01:40:16 UTC
*** Bug 294033 has been marked as a duplicate of this bug. ***
Comment 20 Christoph Feck 2012-02-14 21:03:23 UTC
*** Bug 294100 has been marked as a duplicate of this bug. ***
Comment 21 Jekyll Wu 2012-02-16 12:37:47 UTC
*** Bug 294229 has been marked as a duplicate of this bug. ***
Comment 22 Christoph Feck 2012-02-28 22:01:03 UTC
*** Bug 295018 has been marked as a duplicate of this bug. ***
Comment 23 Yuri 2012-04-12 02:55:07 UTC
Created attachment 70326 [details]
New crash information added by DrKonqi

kde4-window-decorator (0.0.1) on KDE Platform 4.7.4 (4.7.4) using Qt 4.7.4

I have installed Compiz, and tried to have a 3d desktop, with some success.

-- Backtrace (Reduced):
#6  0x00007f1cfb9a0cc9 in QRasterWindowSurface::~QRasterWindowSurface (this=0x1b66400, __in_chrg=<optimized out>) at painting/qwindowsurface_raster.cpp:110
#7  0x00007f1cfb9a0d49 in QRasterWindowSurface::~QRasterWindowSurface (this=0x1b66400, __in_chrg=<optimized out>) at painting/qwindowsurface_raster.cpp:114
#8  0x00007f1cfb9ba32e in QWidgetBackingStore::~QWidgetBackingStore (this=0x1bd9eb0, __in_chrg=<optimized out>) at painting/qbackingstore.cpp:883
#9  0x00007f1cfb7f7a79 in QWidgetBackingStoreTracker::destroy (this=0x1bd4a70) at kernel/qwidget.cpp:210
#10 0x00007f1cfb7f7bce in QWidgetPrivate::deleteExtra (this=0x1b86110) at kernel/qwidget.cpp:1796
Comment 24 nironaCuChANOck 2012-04-12 11:17:24 UTC
OK, thanks
works well

El 11 de abril de 2012 21:55, Yuri <yuribarros03@gmail.com> escribió:

> https://bugs.kde.org/show_bug.cgi?id=255081
>
> --- Comment #23 from Yuri <yuribarros03@gmail.com> ---
> Created attachment 70326 [details]
>  --> https://bugs.kde.org/attachment.cgi?id=70326&action=edit
> New crash information added by DrKonqi
>
> kde4-window-decorator (0.0.1) on KDE Platform 4.7.4 (4.7.4) using Qt 4.7.4
>
> I have installed Compiz, and tried to have a 3d desktop, with some success.
>
> -- Backtrace (Reduced):
> #6  0x00007f1cfb9a0cc9 in QRasterWindowSurface::~QRasterWindowSurface
> (this=0x1b66400, __in_chrg=<optimized out>) at
> painting/qwindowsurface_raster.cpp:110
> #7  0x00007f1cfb9a0d49 in QRasterWindowSurface::~QRasterWindowSurface
> (this=0x1b66400, __in_chrg=<optimized out>) at
> painting/qwindowsurface_raster.cpp:114
> #8  0x00007f1cfb9ba32e in QWidgetBackingStore::~QWidgetBackingStore
> (this=0x1bd9eb0, __in_chrg=<optimized out>) at
> painting/qbackingstore.cpp:883
> #9  0x00007f1cfb7f7a79 in QWidgetBackingStoreTracker::destroy
> (this=0x1bd4a70)
> at kernel/qwidget.cpp:210
> #10 0x00007f1cfb7f7bce in QWidgetPrivate::deleteExtra (this=0x1b86110) at
> kernel/qwidget.cpp:1796
>
> --
> You are receiving this mail because:
> You are on the CC list for the bug.
>
Comment 25 John 2012-04-16 20:02:22 UTC
Created attachment 70440 [details]
New crash information added by DrKonqi

kde4-window-decorator (0.0.1) on KDE Platform 4.7.4 (4.7.4) using Qt 4.7.4

- What I was doing when the application crashed: Log off

Any time I log off or shutdown system ,I get this error

-- Backtrace (Reduced):
#6  0x00007fbe78128cc9 in QRasterWindowSurface::~QRasterWindowSurface (this=0x1e5c0e0, __in_chrg=<optimized out>) at painting/qwindowsurface_raster.cpp:110
#7  0x00007fbe78128d49 in QRasterWindowSurface::~QRasterWindowSurface (this=0x1e5c0e0, __in_chrg=<optimized out>) at painting/qwindowsurface_raster.cpp:114
#8  0x00007fbe7814232e in QWidgetBackingStore::~QWidgetBackingStore (this=0x1e57af0, __in_chrg=<optimized out>) at painting/qbackingstore.cpp:883
#9  0x00007fbe77f7fa79 in QWidgetBackingStoreTracker::destroy (this=0x1e57a40) at kernel/qwidget.cpp:210
#10 0x00007fbe77f7fbce in QWidgetPrivate::deleteExtra (this=0x1e0a860) at kernel/qwidget.cpp:1796
Comment 26 John 2012-04-18 18:35:50 UTC
Created attachment 70488 [details]
New crash information added by DrKonqi

kde4-window-decorator (0.0.1) on KDE Platform 4.7.4 (4.7.4) using Qt 4.7.4

- What I was doing when the application crashed:
When I shutdown or restart KDE decorater crashes

-- Backtrace (Reduced):
#6  0x00007fdc9f52fcc9 in QRasterWindowSurface::~QRasterWindowSurface (this=0x956a70, __in_chrg=<optimized out>) at painting/qwindowsurface_raster.cpp:110
#7  0x00007fdc9f52fd49 in QRasterWindowSurface::~QRasterWindowSurface (this=0x956a70, __in_chrg=<optimized out>) at painting/qwindowsurface_raster.cpp:114
#8  0x00007fdc9f54932e in QWidgetBackingStore::~QWidgetBackingStore (this=0x9abea0, __in_chrg=<optimized out>) at painting/qbackingstore.cpp:883
#9  0x00007fdc9f386a79 in QWidgetBackingStoreTracker::destroy (this=0x9abfe0) at kernel/qwidget.cpp:210
#10 0x00007fdc9f386bce in QWidgetPrivate::deleteExtra (this=0x95b880) at kernel/qwidget.cpp:1796
Comment 27 Hugo Pereira Da Costa 2012-07-09 14:55:48 UTC
*** Bug 303108 has been marked as a duplicate of this bug. ***
Comment 28 Leonardo 2012-08-20 14:55:08 UTC
Created attachment 73322 [details]
New crash information added by DrKonqi

akonadi_nepomuk_feeder (4.9) on KDE Platform 4.9.00 using Qt 4.8.2

- What I was doing when the application crashed

Closing the session. It did not crashed prior 4.9.

-- Backtrace (Reduced):
#6  0x00007fbc1f7aa9f9 in QRasterWindowSurface::~QRasterWindowSurface (this=0x1b3db00, __in_chrg=<optimized out>) at painting/qwindowsurface_raster.cpp:117
#7  0x00007fbc1f7aaa79 in QRasterWindowSurface::~QRasterWindowSurface (this=0x1b3db00, __in_chrg=<optimized out>) at painting/qwindowsurface_raster.cpp:121
#8  0x00007fbc1f7c3d22 in QWidgetBackingStore::~QWidgetBackingStore (this=0x1b3d940, __in_chrg=<optimized out>) at painting/qbackingstore.cpp:909
#9  0x00007fbc1f5f2e79 in QWidgetBackingStoreTracker::destroy (this=0x1b78020) at kernel/qwidget.cpp:217
#10 0x00007fbc1f5f2fc9 in QWidgetPrivate::deleteExtra (this=0x1b96450) at kernel/qwidget.cpp:1831
Comment 29 Leonardo 2012-08-20 14:59:26 UTC
Created attachment 73323 [details]
New crash information added by DrKonqi

kmix (4.2) on KDE Platform 4.9.00 using Qt 4.8.2

I was closing the session.

-- Backtrace (Reduced):
#6  0x00007f6fdfbdb9f9 in QRasterWindowSurface::~QRasterWindowSurface (this=0x196cee0, __in_chrg=<optimized out>) at painting/qwindowsurface_raster.cpp:117
#7  0x00007f6fdfbdba79 in QRasterWindowSurface::~QRasterWindowSurface (this=0x196cee0, __in_chrg=<optimized out>) at painting/qwindowsurface_raster.cpp:121
#8  0x00007f6fdfbf4d22 in QWidgetBackingStore::~QWidgetBackingStore (this=0x19c7c50, __in_chrg=<optimized out>) at painting/qbackingstore.cpp:909
#9  0x00007f6fdfa23e79 in QWidgetBackingStoreTracker::destroy (this=0x1950c00) at kernel/qwidget.cpp:217
#10 0x00007f6fdfa23fc9 in QWidgetPrivate::deleteExtra (this=0x18c58f0) at kernel/qwidget.cpp:1831