Bug 292398 - Crashes when I shut my Laptop
Summary: Crashes when I shut my Laptop
Status: RESOLVED DUPLICATE of bug 255081
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-25 15:11 UTC by olevanosoldier
Modified: 2012-01-25 22:54 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description olevanosoldier 2012-01-25 15:11:58 UTC
Application: kde4-window-decorator (0.0.1)
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-15-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:  Every time I close my laptop it crashes right away.  This just started when I applied the big batch of patches that was ppushed out the other day.

The crash can be reproduced every time.

-- Backtrace:
Application: KDE Window Decorator (kde4-window-decorator), signal: Segmentation fault
[KCrash Handler]
#7  0x0541b29b in QRasterWindowSurface::~QRasterWindowSurface (this=0x9fec7a0, __in_chrg=<optimized out>) at painting/qwindowsurface_raster.cpp:110
#8  0x0541b332 in QRasterWindowSurface::~QRasterWindowSurface (this=0x9fec7a0, __in_chrg=<optimized out>) at painting/qwindowsurface_raster.cpp:114
#9  0x05437504 in QWidgetBackingStore::~QWidgetBackingStore (this=0xa05cbe0, __in_chrg=<optimized out>) at painting/qbackingstore.cpp:883
#10 0x0524e77c in QWidgetBackingStoreTracker::destroy (this=0xa05e5b8) at kernel/qwidget.cpp:210
#11 0x0524e8d8 in QWidgetPrivate::deleteExtra (this=0x9ff6c88) at kernel/qwidget.cpp:1796
#12 0x0524eaec in QWidgetPrivate::~QWidgetPrivate (this=0x9ff6c88, __in_chrg=<optimized out>) at kernel/qwidget.cpp:341
#13 0x0524ee02 in QWidgetPrivate::~QWidgetPrivate (this=0x9ff6c88, __in_chrg=<optimized out>) at kernel/qwidget.cpp:346
#14 0x076c8491 in cleanup (pointer=<optimized out>) at ../../include/QtCore/../../src/corelib/tools/qscopedpointer.h:62
#15 ~QScopedPointer (this=0x9f8a394, __in_chrg=<optimized out>) at ../../include/QtCore/../../src/corelib/tools/qscopedpointer.h:100
#16 QObject::~QObject (this=0x9f8a390, __in_chrg=<optimized out>) at kernel/qobject.cpp:818
#17 0x0525105f in QWidget::~QWidget (this=0x9f8a390, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1528
#18 0x01e4ea2f in ~EffectWatcher (this=0x9f8a390, __in_chrg=<optimized out>) at ../../plasma/private/effectwatcher_p.h:30
#19 Plasma::EffectWatcher::~EffectWatcher (this=0x9f8a390, __in_chrg=<optimized out>) at ../../plasma/private/effectwatcher_p.h:30
#20 0x01ebd7b8 in ~ThemePrivate (this=0xa02f348, __in_chrg=<optimized out>) at ../../plasma/theme.cpp:119
#21 Plasma::Theme::~Theme (this=0xa032640, __in_chrg=<optimized out>) at ../../plasma/theme.cpp:482
#22 0x01ebdd49 in ~ThemeSingleton (this=0xa032640, __in_chrg=<optimized out>) at ../../plasma/theme.cpp:421
#23 destroy () at ../../plasma/theme.cpp:437
#24 0x01dbde69 in KCleanUpGlobalStatic::~KCleanUpGlobalStatic (this=0x201c3d8, __in_chrg=<optimized out>) at ../../kdecore/kernel/kglobal.h:62
#25 0x0076e981 in ?? () from /lib/i386-linux-gnu/libc.so.6
#26 0x0076ea0d in exit () from /lib/i386-linux-gnu/libc.so.6
#27 0x0075511b in __libc_start_main () from /lib/i386-linux-gnu/libc.so.6
#28 0x0804f995 in _start ()

Possible duplicates by query: bug 291235, bug 291175, bug 291079, bug 289825, bug 288670.

Reported using DrKonqi
Comment 1 Dario Andres 2012-01-25 22:54:15 UTC
[Comment from a bug report cleaner]
Related to bug 255081. The crash is inside the Compiz window decorator for KDE4.
Regards

*** This bug has been marked as a duplicate of bug 255081 ***