Bug 294229 - log off
Summary: log off
Status: RESOLVED DUPLICATE of bug 255081
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-16 12:29 UTC by extractor
Modified: 2012-02-16 12:37 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description extractor 2012-02-16 12:29:23 UTC
Application: kde4-window-decorator (0.0.1)
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-16-server x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
Everytime i log off.
And in gnome interface taskbar from left does not appear anymore.

The crash can be reproduced every time.

-- Backtrace:
Application: KDE Window Decorator (kde4-window-decorator), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f00c0e8a7a0 (LWP 2913))]

Thread 2 (Thread 0x7f00a7c44700 (LWP 2918)):
#0  0x00007f00bd745773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f00b6674f68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f00b6675429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f00bdeadf3e in QEventDispatcherGlib::processEvents (this=0x1fbee10, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f00bde81cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f00bde81ef7 in QEventLoop::exec (this=0x7f00a7c43db0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f00bdd9927f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007f00bde64cbf in QInotifyFileSystemWatcherEngine::run (this=0x1fd7c60) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f00bdd9bd05 in QThreadPrivate::start (arg=0x1fd7c60) at thread/qthread_unix.cpp:331
#9  0x00007f00bc221efc in start_thread (arg=0x7f00a7c44700) at pthread_create.c:304
#10 0x00007f00bd75189d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f00c0e8a7a0 (LWP 2913)):
[KCrash Handler]
#6  0x00007f00be81ecc9 in QRasterWindowSurface::~QRasterWindowSurface (this=0x1fbdd70, __in_chrg=<optimized out>) at painting/qwindowsurface_raster.cpp:110
#7  0x00007f00be81ed49 in QRasterWindowSurface::~QRasterWindowSurface (this=0x1fbdd70, __in_chrg=<optimized out>) at painting/qwindowsurface_raster.cpp:114
#8  0x00007f00be83832e in QWidgetBackingStore::~QWidgetBackingStore (this=0x1fbe7a0, __in_chrg=<optimized out>) at painting/qbackingstore.cpp:883
#9  0x00007f00be675a79 in QWidgetBackingStoreTracker::destroy (this=0x1fbefc0) at kernel/qwidget.cpp:210
#10 0x00007f00be675bce in QWidgetPrivate::deleteExtra (this=0x1f9d660) at kernel/qwidget.cpp:1796
#11 0x00007f00be675dfc in QWidgetPrivate::~QWidgetPrivate (this=0x1f9d660, __in_chrg=<optimized out>) at kernel/qwidget.cpp:341
#12 0x00007f00be676109 in QWidgetPrivate::~QWidgetPrivate (this=0x1f9d660, __in_chrg=<optimized out>) at kernel/qwidget.cpp:346
#13 0x00007f00bde9a39b in cleanup (pointer=<optimized out>) at ../../include/QtCore/../../src/corelib/tools/qscopedpointer.h:62
#14 ~QScopedPointer (this=0x1ec6988, __in_chrg=<optimized out>) at ../../include/QtCore/../../src/corelib/tools/qscopedpointer.h:100
#15 QObject::~QObject (this=0x1ec6980, __in_chrg=<optimized out>) at kernel/qobject.cpp:818
#16 0x00007f00be6781b2 in QWidget::~QWidget (this=0x1ec6980, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1528
#17 0x00007f00be6783c9 in QWidget::~QWidget (this=0x1ec6980, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1671
#18 0x00007f00bebe2d15 in QGlobalStaticDeleter<QWidget>::~QGlobalStaticDeleter (this=0x7f00bf10f408, __in_chrg=<optimized out>) at ../../include/QtCore/../../src/corelib/global/qglobal.h:1825
#19 0x00007f00bd6ab821 in __run_exit_handlers (status=0, listp=0x7f00bda085a8, run_list_atexit=true) at exit.c:78
#20 0x00007f00bd6ab8a5 in __GI_exit (status=<optimized out>) at exit.c:100
#21 0x00007f00bd691314 in __libc_start_main (main=0x4094b0, argc=3, ubp_av=0x7fff3ee59f48, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff3ee59f38) at libc-start.c:258
#22 0x0000000000409ced in _start ()

Possible duplicates by query: bug 294100, bug 294033, bug 292398, bug 291235, bug 291175.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-02-16 12:37:47 UTC

*** This bug has been marked as a duplicate of bug 255081 ***