Bug 269671 - Kwin crash on shutdown
Summary: Kwin crash on shutdown
Status: RESOLVED DUPLICATE of bug 255081
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-29 09:11 UTC by Stéphane Berbigier
Modified: 2011-10-18 07:09 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (2.94 KB, text/plain)
2011-10-18 07:09 UTC, Phil Evans
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stéphane Berbigier 2011-03-29 09:11:15 UTC
Application: kde4-window-decorator (0.0.1)
KDE Platform Version: 4.6.00 (4.6.0) "release 6"
Qt Version: 4.7.1
Operating System: Linux 2.6.37.1-1.2-desktop x86_64
Distribution: "openSUSE 11.4 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:
Just trying to shutdown the computer. Each time I clos the session I have an window informing me that kwin has crashed. Which is not very bad until it works well when the session is opened...
I've had a few issues though with desktop effects (X freezing for a few minutes), especially when using the window switching effect (alt+Tab). It has seemed to be ok since I unchecked "test de fonctionnement" (I don't know what it's called in english) and unchecked "Direct rendering" on the desktop effects advanced options tab. And I don't know if there is any link with this matter anyway.

The crash can be reproduced every time.

-- Backtrace:
Application: KDE Window Decorator (kde4-window-decorator), signal: Segmentation fault
[KCrash Handler]
#6  0x00007fea7c7b9fc9 in QRasterWindowSurface::~QRasterWindowSurface (this=0x7e7030, __in_chrg=<value optimized out>) at painting/qwindowsurface_raster.cpp:104
#7  0x00007fea7c7ba049 in QRasterWindowSurface::~QRasterWindowSurface (this=0x7e7030, __in_chrg=<value optimized out>) at painting/qwindowsurface_raster.cpp:108
#8  0x00007fea7c7d7c92 in QWidgetBackingStore::~QWidgetBackingStore (this=0x7e8b50, __in_chrg=<value optimized out>) at painting/qbackingstore.cpp:883
#9  0x00007fea7c612109 in QWidgetBackingStoreTracker::destroy (this=0x7e8aa0) at kernel/qwidget.cpp:205
#10 0x00007fea7c612259 in QWidgetPrivate::deleteExtra (this=0x7a8620) at kernel/qwidget.cpp:1750
#11 0x00007fea7c61249c in QWidgetPrivate::~QWidgetPrivate (this=0x7a8620, __in_chrg=<value optimized out>) at kernel/qwidget.cpp:318
#12 0x00007fea7c6127b9 in QWidgetPrivate::~QWidgetPrivate (this=0x7a8620, __in_chrg=<value optimized out>) at kernel/qwidget.cpp:323
#13 0x00007fea7d212ec3 in cleanup (this=0x79b300, __in_chrg=<value optimized out>) at ../../src/corelib/tools/qscopedpointer.h:62
#14 ~QScopedPointer (this=0x79b300, __in_chrg=<value optimized out>) at ../../src/corelib/tools/qscopedpointer.h:100
#15 QObject::~QObject (this=0x79b300, __in_chrg=<value optimized out>) at kernel/qobject.cpp:817
#16 0x00007fea7c61484d in QWidget::~QWidget (this=0x79b300, __in_chrg=<value optimized out>) at kernel/qwidget.cpp:1477
#17 0x00007fea7e206091 in ~Private (this=0x79b300, __in_chrg=<value optimized out>) at /usr/src/debug/kdelibs-4.6.0/kdeui/util/kmanagerselection.cpp:376
#18 KSelectionWatcher::Private::~Private (this=0x79b300, __in_chrg=<value optimized out>) at /usr/src/debug/kdelibs-4.6.0/kdeui/util/kmanagerselection.cpp:376
#19 0x00007fea7e0233f1 in KSelectionWatcher::~KSelectionWatcher (this=0x79b410, __in_chrg=<value optimized out>) at /usr/src/debug/kdelibs-4.6.0/kdeui/util/kmanagerselection.cpp:419
#20 0x00007fea7e023409 in KSelectionWatcher::~KSelectionWatcher (this=0x79b410, __in_chrg=<value optimized out>) at /usr/src/debug/kdelibs-4.6.0/kdeui/util/kmanagerselection.cpp:420
#21 0x00007fea7d20e1d4 in QObjectPrivate::deleteChildren (this=0x7979d0) at kernel/qobject.cpp:1949
#22 0x00007fea7d212e72 in QObject::~QObject (this=0x798440, __in_chrg=<value optimized out>) at kernel/qobject.cpp:945
#23 0x00007fea7db8ac10 in Plasma::Theme::~Theme (this=0x798440, __in_chrg=<value optimized out>) at /usr/src/debug/kdelibs-4.6.0/plasma/theme.cpp:451
#24 0x00007fea7db8af37 in ~ThemeSingleton () at /usr/src/debug/kdelibs-4.6.0/plasma/theme.cpp:403
#25 destroy () at /usr/src/debug/kdelibs-4.6.0/plasma/theme.cpp:418
#26 0x00007fea7bdbd5a1 in __run_exit_handlers () from /lib64/libc.so.6
#27 0x00007fea7bdbd5f5 in exit () from /lib64/libc.so.6
#28 0x00007fea7bda6c04 in __libc_start_main () from /lib64/libc.so.6
#29 0x0000000000409d29 in _start ()

Possible duplicates by query: bug 255081.

Reported using DrKonqi
Comment 1 Christoph Feck 2011-03-30 21:04:04 UTC

*** This bug has been marked as a duplicate of bug 255081 ***
Comment 2 Phil Evans 2011-10-18 07:09:06 UTC
Created attachment 64661 [details]
New crash information added by DrKonqi

kde4-window-decorator (0.0.1) on KDE Platform 4.7.2 (4.7.2) using Qt 4.7.4

- What I was doing when the application crashed:
Logging off KDE.
This happens every time I log out.

-- Backtrace (Reduced):
#6  0x00007f9cc0ffcc09 in QRasterWindowSurface::~QRasterWindowSurface (this=0x21863e0, __in_chrg=<optimized out>) at painting/qwindowsurface_raster.cpp:110
#7  0x00007f9cc0ffcc89 in QRasterWindowSurface::~QRasterWindowSurface (this=0x21863e0, __in_chrg=<optimized out>) at painting/qwindowsurface_raster.cpp:114
#8  0x00007f9cc101626e in QWidgetBackingStore::~QWidgetBackingStore (this=0x2182b10, __in_chrg=<optimized out>) at painting/qbackingstore.cpp:883
#9  0x00007f9cc0e53a29 in QWidgetBackingStoreTracker::destroy (this=0x2189f40) at kernel/qwidget.cpp:210
#10 0x00007f9cc0e53b7e in QWidgetPrivate::deleteExtra (this=0x206ba50) at kernel/qwidget.cpp:1796