Bug 295018 - kde-window-decorator always crashes when executed.
Summary: kde-window-decorator always crashes when executed.
Status: RESOLVED DUPLICATE of bug 255081
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-28 19:24 UTC by Victor Tramp
Modified: 2012-02-28 22:01 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Victor Tramp 2012-02-28 19:24:38 UTC
Application: kde4-window-decorator (0.0.1)
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.8.0
Operating System: Linux 3.2.7-1.fc16.x86_64 x86_64
Distribution: "Fedora release 16 (Verne)"

-- Information about the crash:
- What I was doing when the application crashed:
Whether starting kde-window-decorator from the command line (with either compiz --replace or kde-window-decorator --replace) or from the fusion-icon applet, it crashes.

The crash can be reproduced every time.

-- Backtrace:
Application: KDE Window Decorator (kde4-window-decorator), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
82	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[KCrash Handler]
#6  0x0000003f7a1c4219 in QRasterWindowSurface::~QRasterWindowSurface (this=0x1e53b00, __in_chrg=<optimized out>) at painting/qwindowsurface_raster.cpp:117
#7  0x0000003f7a1c4299 in QRasterWindowSurface::~QRasterWindowSurface (this=0x1e53b00, __in_chrg=<optimized out>) at painting/qwindowsurface_raster.cpp:121
#8  0x0000003f7a1e020e in QWidgetBackingStore::~QWidgetBackingStore (this=0x1e52540, __in_chrg=<optimized out>) at painting/qbackingstore.cpp:909
#9  0x0000003f7a012329 in QWidgetBackingStoreTracker::destroy (this=0x1e56ea0) at kernel/qwidget.cpp:217
#10 0x0000003f7a01247e in QWidgetPrivate::deleteExtra (this=0x1e57630) at kernel/qwidget.cpp:1829
#11 0x0000003f7a0126ac in QWidgetPrivate::~QWidgetPrivate (this=0x1e57630, __in_chrg=<optimized out>) at kernel/qwidget.cpp:356
#12 0x0000003f7a0129c9 in QWidgetPrivate::~QWidgetPrivate (this=0x1e57630, __in_chrg=<optimized out>) at kernel/qwidget.cpp:361
#13 0x0000003f76f916a0 in cleanup (pointer=<optimized out>) at ../../src/corelib/tools/qscopedpointer.h:62
#14 ~QScopedPointer (this=0x1e57298, __in_chrg=<optimized out>) at ../../src/corelib/tools/qscopedpointer.h:100
#15 QObject::~QObject (this=0x1e57290, __in_chrg=<optimized out>) at kernel/qobject.cpp:817
#16 0x0000003f7a01470d in QWidget::~QWidget (this=0x1e57290, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1550
#17 0x0000003f89d7bdff in ~EffectWatcher (this=0x1e57290, __in_chrg=<optimized out>) at /usr/src/debug/kdelibs-4.7.4/plasma/private/effectwatcher_p.h:30
#18 Plasma::EffectWatcher::~EffectWatcher (this=0x1e57290, __in_chrg=<optimized out>) at /usr/src/debug/kdelibs-4.7.4/plasma/private/effectwatcher_p.h:30
#19 0x0000003f89de043f in ~ThemePrivate (this=0x1e38b50, __in_chrg=<optimized out>) at /usr/src/debug/kdelibs-4.7.4/plasma/theme.cpp:119
#20 Plasma::Theme::~Theme (this=0x1e35440, __in_chrg=<optimized out>) at /usr/src/debug/kdelibs-4.7.4/plasma/theme.cpp:482
#21 0x0000003f89de0967 in ~ThemeSingleton (this=0x1e35440, __in_chrg=<optimized out>) at /usr/src/debug/kdelibs-4.7.4/plasma/theme.cpp:421
#22 destroy () at /usr/src/debug/kdelibs-4.7.4/plasma/theme.cpp:437
#23 0x0000003f6be39931 in __run_exit_handlers (status=0, listp=0x3f6c1b1668, run_list_atexit=true) at exit.c:78
#24 0x0000003f6be399b5 in __GI_exit (status=<optimized out>) at exit.c:100
#25 0x0000003f6be216a4 in __libc_start_main (main=0x409920 <main(int, char**)>, argc=2, ubp_av=0x7fff56041518, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff56041508) at libc-start.c:258
#26 0x000000000040a0cd in _start ()

Possible duplicates by query: bug 294229, bug 294100, bug 294033, bug 292398, bug 291235.

Reported using DrKonqi
Comment 1 Victor Tramp 2012-02-28 19:29:46 UTC
Also of note, i have an Intel Graphics card, not nVidia or ATI.

identical failures, on two machines

Dell Latitude 
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09) (prog-if 00 [VGA controller])
        Subsystem: Dell Device 049b
        Flags: bus master, fast devsel, latency 0, IRQ 43
        Memory at e2800000 (64-bit, non-prefetchable) [size=4M]
        Memory at d0000000 (64-bit, prefetchable) [size=256M]
        I/O ports at 8000 [size=64]
        Expansion ROM at <unassigned> [disabled]
        Capabilities: [90] MSI: Enable+ Count=1/1 Maskable- 64bit-
        Capabilities: [d0] Power Management version 2
        Capabilities: [a4] PCI Advanced Features
        Kernel driver in use: i915
        Kernel modules: i915

and an HP desktop

00:02.0 VGA compatible controller: Intel Corporation 4 Series Chipset Integrated Graphics Controller (rev 03) (prog-if 00 [VGA controller])
        Subsystem: Hewlett-Packard Company Device 3646
        Flags: bus master, fast devsel, latency 0, IRQ 47
        Memory at f0000000 (64-bit, non-prefetchable) [size=4M]
        Memory at e0000000 (64-bit, prefetchable) [size=256M]
        I/O ports at 1230 [size=8]
        Expansion ROM at <unassigned> [disabled]
        Capabilities: [90] MSI: Enable+ Count=1/1 Maskable- 64bit-
        Capabilities: [d0] Power Management version 2
        Kernel driver in use: i915
        Kernel modules: i915
Comment 2 Christoph Feck 2012-02-28 22:01:03 UTC

*** This bug has been marked as a duplicate of bug 255081 ***