Bug 294100 - win decorator crashes at shutdown
Summary: win decorator crashes at shutdown
Status: RESOLVED DUPLICATE of bug 255081
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-14 20:26 UTC by Lans
Modified: 2012-02-14 21:03 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lans 2012-02-14 20:26:49 UTC
Application: kde4-window-decorator (0.0.1)
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.17-shortdescription x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:

Just trying to shutdown the computer. Each time I close the session I have an window informing me that kwin has crashed.

The crash can be reproduced every time.

-- Backtrace:
Application: KDE Window Decorator (kde4-window-decorator), signal: Segmentation fault
[KCrash Handler]
#6  0x00007f80f1939cc9 in QRasterWindowSurface::~QRasterWindowSurface (this=0x11d3c00, __in_chrg=<optimized out>) at painting/qwindowsurface_raster.cpp:110
#7  0x00007f80f1939d49 in QRasterWindowSurface::~QRasterWindowSurface (this=0x11d3c00, __in_chrg=<optimized out>) at painting/qwindowsurface_raster.cpp:114
#8  0x00007f80f195332e in QWidgetBackingStore::~QWidgetBackingStore (this=0x11d3d00, __in_chrg=<optimized out>) at painting/qbackingstore.cpp:883
#9  0x00007f80f1790a79 in QWidgetBackingStoreTracker::destroy (this=0x11d3c50) at kernel/qwidget.cpp:210
#10 0x00007f80f1790bce in QWidgetPrivate::deleteExtra (this=0x1148c20) at kernel/qwidget.cpp:1796
#11 0x00007f80f1790dfc in QWidgetPrivate::~QWidgetPrivate (this=0x1148c20, __in_chrg=<optimized out>) at kernel/qwidget.cpp:341
#12 0x00007f80f1791109 in QWidgetPrivate::~QWidgetPrivate (this=0x1148c20, __in_chrg=<optimized out>) at kernel/qwidget.cpp:346
#13 0x00007f80f0fb539b in cleanup (pointer=<optimized out>) at ../../include/QtCore/../../src/corelib/tools/qscopedpointer.h:62
#14 ~QScopedPointer (this=0x115f798, __in_chrg=<optimized out>) at ../../include/QtCore/../../src/corelib/tools/qscopedpointer.h:100
#15 QObject::~QObject (this=0x115f790, __in_chrg=<optimized out>) at kernel/qobject.cpp:818
#16 0x00007f80f17931b2 in QWidget::~QWidget (this=0x115f790, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1528
#17 0x00007f80f258f87f in ~EffectWatcher (this=0x115f790, __in_chrg=<optimized out>) at ../../plasma/private/effectwatcher_p.h:30
#18 Plasma::EffectWatcher::~EffectWatcher (this=0x115f790, __in_chrg=<optimized out>) at ../../plasma/private/effectwatcher_p.h:30
#19 0x00007f80f25f487f in ~ThemePrivate (this=0x11498d0, __in_chrg=<optimized out>) at ../../plasma/theme.cpp:119
#20 Plasma::Theme::~Theme (this=0x115d2d0, __in_chrg=<optimized out>) at ../../plasma/theme.cpp:482
#21 0x00007f80f25f4d97 in ~ThemeSingleton (this=0x115d2d0, __in_chrg=<optimized out>) at ../../plasma/theme.cpp:421
#22 destroy () at ../../plasma/theme.cpp:437
#23 0x00007f80f07c6821 in __run_exit_handlers (status=0, listp=0x7f80f0b235a8, run_list_atexit=true) at exit.c:78
#24 0x00007f80f07c68a5 in __GI_exit (status=<optimized out>) at exit.c:100
#25 0x00007f80f07ac314 in __libc_start_main (main=0x4094b0, argc=3, ubp_av=0x7fff8964f8b8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff8964f8a8) at libc-start.c:258
#26 0x0000000000409ced in _start ()

Possible duplicates by query: bug 294033, bug 292398, bug 291235, bug 291175, bug 291079.

Reported using DrKonqi
Comment 1 Christoph Feck 2012-02-14 21:03:23 UTC

*** This bug has been marked as a duplicate of bug 255081 ***